WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] WP2.0 User Cookie Not Detected (10 posts)

  1. groovenectar
    Member
    Posted 8 years ago #

    Alright, I go to my blog root... everything's fine. I click Login, and I login... everything's fine. I do what I need to do in the admin area, and click View Site ยป (without logging out). I'm back to my blog root, and rather than seeing a Site Admin link in the sidebar (as I did with v1.5), I still see a Login link! If I add /wp-admin/ to the URL, it forwards me to the dashboard (which it should, since I'm still logged in)... Enabling the Remember Me option in the login screen has no effect.

    In sidebar.php, it is using the wp_loginout() function, but obviously the cookie is not being detected in the blog root.

    Does anyone have an idea as to what could be causing this?

    Thanks,
    -Daniel.

  2. monkeypup
    Member
    Posted 8 years ago #

    This is happening to me too! It never remembers me. This is a pain in the ass when I use the posting bookmarklet and have to sign in every time.

  3. groovenectar
    Member
    Posted 8 years ago #

    Would you happen to have WPG2 (WordPress/Gallery2 integration plugin) installed in your setup? I do, actually... I don't know whether or not that's the problem. For some reason I seem to remember the problem before Gallery2 was integrated. If I manually modify the URL in the browser to the integrated Gallery2 login, and login... It seems to apply that cookie to WordPress... Not sure what's going on, though...

  4. groovenectar
    Member
    Posted 8 years ago #

    Monkeypup, I found out what the problem was, at least on my setup... See, I had been planning on taking out the "www" from my domain, but I forgot to do it before I installed WP... So it wasn't until after I installed it that I started removing the "www" (I'm making the transition slowly, so it works both ways now).. Anyway, I went through the options in the database and changed occurrences of the "www," but it looks like I forgot to go through the other pages of options. So here's what I did to make it work...

    Went to phpMyAdmin... Opened the wp_options table.. There's an option called "home" (on my setup, it's on the second page, option_id 40) .. So it appears that was the culprit.. The "www" was in there, so I removed it, and now it works.

    Please let me know if you try this and it works for you, too...

  5. monkeypup
    Member
    Posted 8 years ago #

    did it. no luck here...

  6. emmadw
    Member
    Posted 8 years ago #

    I've had no problems with it remembering the cookie - but, I'm using Firefox 1.5 - could that be the difference?

  7. groovenectar
    Member
    Posted 8 years ago #

    @Emmadw:
    Well, that shouldn't be the problem... I'm using FF1.5 too..

    @monkeypup
    However, if you do use Firefox, you should get the extension Add N Edit Cookies, as that could help us troubleshoot this problem further. Try this: Login to your WP Admin... Go to Options -> General, and look at "Blog address." Be sure that is set to the right value, and then save it. We are trying to make sure that all of the blog URLs are consistent with the URL that you use.

    Clear all of your cookies, go back to your blog home and login again. See if it works. If it doesn't, check Add N Edit Cookies to see what URL the cookie is looking for. (We are looking for the host, and the path). Actually, you can also do this from Firefox options under privacy, but with the extension you can modify it to try to see what changes will get it working. You also might want to look at the wp_options table in the database again and see if any other inconsistent URLs are in there.

    Finally, try manually modifying the blog URL in the browser. If there's no "www," add one. If there is, take it away. See if that makes the "Site Admin" link show up, and that should be further help in finding out what the problem is. Please let me know if this works... In the meantime, I'll set this topic back to unresolved.

  8. monkeypup
    Member
    Posted 8 years ago #

    Groove-
    That did it! Hooray!
    Thanks soo much. It was how the blog was listed in the options panel. The WWW thingeroo was defeating me.
    Sorry to be a pain.
    Mp

  9. groovenectar
    Member
    Posted 8 years ago #

    Glad it is working!

    Actually, I have no idea where that setting is stored in the options panel... There doesn't seem to be a reference to it in the options table. It would be nice to know where these extra settings are stored, though.

    And hey, there's no pain in sharing!

  10. verymum
    Member
    Posted 7 years ago #

    @groovenectar - thanks a million, I was having the same problem on Firefox (mac), Safari, Firefox (PC), and IE (just to test). After following your instructions, all is well.

Topic Closed

This topic has been closed to new replies.

About this Topic