WordPress.org

Ready to get started?Download WordPress

Forums

WP1.5 Comments working but moderation isn't (11 posts)

  1. sfmobius
    Member
    Posted 9 years ago #

    Everything appears to be up and running but when I tested comments it posted directly w/o any moderation even though I set it to hold firs time posters.

  2. lawtai
    Member
    Posted 9 years ago #

    i'm guessing you were still most likely logged in, so it recognized you and didn't throw your comment to moderation.

  3. rahmac
    Member
    Posted 9 years ago #

    I have comments posting immediately even though I have moderation set for all comments. I am not logged in when I try this...
    I am using a modified theme for the design. Could this be causing problems?

  4. kirkir
    Member
    Posted 9 years ago #

    I am having the same problem. I have my Discussions Options set to "An administrator must approve the comment (regardless of any matches below) " and upon testing, I am not having any comments moderated. Please help..... I am also using a modified theme, specifically, the gila theme from this site: http://www.bloggingpro.com/archives/2005/03/04/wordpress-theme-gila/

    Also, I have Spam Karma on but I have the "Take in account moderation criteria set on the Discussion page." setting CHECKED and am having the same issue.

    Anyone else had the same issue and resolved it? Any ideas?

  5. This is a known bug and will apparently be fixed in v1.5.1. For now, just rely on other anti-spam solutions, such as Spam Karma (and don't forget to uncheck "Take in account moderation criteria set on the Discussion page").

  6. kirkir
    Member
    Posted 9 years ago #

    Thank macmanx for that info. But how can I moderate all comments on my wordpress blog? Is there a plugin or hack or anything that works?

  7. But how can I moderate all comments on my wordpress blog?

    That's easy. Just put a space in your moderation list. If you do, everything with a space in it will be moderated. A period will also work.

    Other anti-spam solutions: http://codex.wordpress.org/Combating_Comment_Spam

  8. finalcut
    Member
    Posted 9 years ago #

    boy some of the spam measures are whey i upgraded. To have them not work at all is a real disappointment.

    Not only are all comments auto approved on my blog - but I get no email about them. I have tried the remove "$more" trick in the functions file and that didn't work either.

    I know software gets released with bugs - but to have major features just flat out not work seems kinda crazy to me.

  9. kirkir
    Member
    Posted 9 years ago #

    macmanx, thanks for that idea.... can't believe I hadn't thought of something like that. I ended up not being able to just use a space. Instead I am using all the common punctuation marks as triggers to moderate comments like:
    .
    ?
    !
    ,
    @

    It's working so far...

  10. jaypee
    Member
    Posted 8 years ago #

    I'm also experiencing this problem. I've enabled the option that the admin must approve comment first before it appears..i also have Spam Karma 2 installed..and all the comments get posted without being approved..also, i can seem to find this "Take in account moderation criteria set on the Discussion page"..is it in the Spam Karma settings? I've just used the different punctuation marks as triggers, i still have to wait and see if it would work.

  11. That option was in Spam Karma v1.x, but may have been removed or renamed in Spam Karma v2.x. Are the comments correctly moderated when Spam Karma is deactivated?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.