WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] WP using way too much RAM (8 posts)

  1. brad8985
    Member
    Posted 4 years ago #

    Ok, I will try to lay this out as clearly as possible.

    - I built a site in WP 3.0
    - Site working fine on MAMP
    - Site starting to lag on MAMP as I add pages
    - Site wont work on MAMP, just times out but wp-admin is fine
    - Upload site to random folder to test
    - Site works fine
    - Few hours later, Site wont work at all, times out
    - wp-admin still works fine unless you are creating or editing pages
    - I contact Dreamhost, they tell me the problem is that my site is using all of the RAM, strange
    - I try everything, disabling plugins, emptying custom pages that have php code and even the header and footer and reloading
    - I try optimising tables, caching plugins and re exporting/ importing the database

    I have approx 150 pages that use the same template, they all pull approx 30 images each from the gallery but this site fails to even load the main page which does not touch any of those page templates. It used to work fine, now it doesn't and all I have done is add more pages, I even deleted the php calls that gather all of the image attachments, still not working.

    So lost, any ideas?

  2. brad8985
    Member
    Posted 4 years ago #

    The URL is swanlakelimos.co.nz/test/pmjphotography.co.uk

  3. brad8985
    Member
    Posted 4 years ago #

    OK so for anyone interested here's how I solved this problem.

    It actually has nothing to do with the RAM, well it does but in a
    ripple effect sorta way. Apparently if you have a large number of
    pages (not posts) in WP and you have a custom permalink structure such
    as %category%/%postname%/ which most people do due to (apparent) SEO
    benefits then it basically just turns to shit. You have to use one of
    the default link structures that rely on numeric characters if you
    have more than approx 40 or 50 pages. The problem though is I could
    not get to the permalink menu due to the actual problem I was having so I got around it by changing it directly in phpMyAdmin.

    So basically it is a bug in the rewrite.php file located in wp-
    includes. If anyone else has this issue the first thing I
    would ask them is if they have more than say 40 -50 pages (not posts)
    as well as a custom permalink structure. If so, change back to one of the default permalink structures and you should be fine. If you cant get into your permalinks page then you need to go to your database, table labeleld wp_options and change the field labelled"permalink_structure" to "/%year%/%monthnum%/%postname%/".
    Then you will be able to access your permalinks page in the WP Admin and
    change it to any of the defualt permalink settings you want.

    Cheers.

  4. Aaron Reimann
    Member
    Posted 4 years ago #

    I would hardly say this is resolved. I am having the same issue. Brad, your suggestion worked for me, but it must be a bug in WP 3.0.

    Have you contacted anyone about this?

  5. iridiax
    Member
    Posted 4 years ago #

    It's a known issue that's been around for a while:

    http://codex.wordpress.org/Using_Permalinks#Structure_Tags

  6. Norman C Hoffmann
    Member
    Posted 3 years ago #

    I added the word "shopping" to my custom url. I am also having memory problems. WP 3+ Multisite. And, both my tags and search pages go to white screen.

    http://adshopeasy.com/

  7. Norman C Hoffmann
    Member
    Posted 3 years ago #

    Just added /%post_id%/ to permalinks. Made no difference to search and tag. Should help memory with pages though.

  8. Norman C Hoffmann
    Member
    Posted 3 years ago #

    Wow, experienced an immediate 10% decrease in memory usage using /%post_id%/%day%/shopping/%postname%/ with WP 3+ Multisite. WOW.

Topic Closed

This topic has been closed to new replies.

About this Topic