WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] WP uploaded via FTP, can't access wp-admin/install.php (8 posts)

  1. innermoonlight
    Member
    Posted 4 years ago #

    I've downloaded/unzipped WP. Created a mySQL database.

    My host is Streamline.net and I don't have privileges to change the mySQL database name/user etc. but as far as I can tell this isn't important, because the database is there, and I put the info that streamline.net gave me into the wp-config.php file.

    I've tried uploading all the files to the root directory, to the htdocs directory, to a "wordpress" and "wp" directory, but all I can get when I try to visit: mysiteurl.com/wp-admin/install.php

    -is either the 404 not found error, or this string of text that means nothing to me.

    Warning: require_once(/home/fhlinux138/f/mysite.co.uk/user/htdocs/wp-includes/wp-db.php) [function.require-once]: failed to open stream: No such file or directory in /home/fhlinux138/f/mysite.co.uk/user/htdocs/wp-includes/functions.php on line 2772

    I'm a complete newcomer to WordPress, but have basic html and have been running a different site with streamline.net (the files for which I've since deleted via FTP).

    Is it a problem with my host? Or is it something I'm doing wrong?
    Please help!

  2. Samuel B
    moderator
    Posted 4 years ago #

    it should work in any of those folders
    the error message says this file is missing
    wp-includes/wp-db.php
    make sure the uploads are using ascii not binary

  3. innermoonlight
    Member
    Posted 4 years ago #

    Ok, I'll check that the file is in place. Also, how do I tell if the uploads are ascii/binary?

    Thanks for your help!

  4. Samuel B
    moderator
    Posted 4 years ago #

    ftp clients show hidden files in different places
    in filezilla it's
    server tab - force show hidden files

  5. innermoonlight
    Member
    Posted 4 years ago #

    Ok, so it turns out the previous error was because my ftp (built into streamline.net) was cutting my upload in half, so half the files didn't make it onto the root directory in the first place.

    I've made sure all the files are there now, and I'm still just getting error messages. (Also the uploads are via ascii)

    These are the new error messages:

    Warning: include_once(/home/fhlinux138/f/mysite.co.uk/user/htdocs/wp-includes/pomo/mo.php) [function.include-once]: failed to open stream: No such file or directory in /home/fhlinux138/f/mysite.co.uk/user/htdocs/wp-settings.php on line 307

    Warning: include_once() [function.include]: Failed opening '/home/fhlinux138/f/mysite.co.uk/user/htdocs/wp-includes/pomo/mo.php' for inclusion (include_path='.:/usr/share/pear-php5') in /home/fhlinux138/f/mysite.co.uk/user/htdocs/wp-settings.php on line 307

    Fatal error: Class 'Translations' not found in /home/fhlinux138/f/mysite.co.uk/user/htdocs/wp-includes/l10n.php on line 407

    I've checked the above mentioned files (wp-settings.php, l10.php) and as far as I can see they are uploaded and in the right places.

    Any ideas?

  6. Samuel B
    moderator
    Posted 4 years ago #

    /wp-includes/pomo/mo.php
    says this file is missing now

  7. innermoonlight
    Member
    Posted 4 years ago #

    Ok, so I deleted a re-uploaded everything, and after going through the files with a fine toothed comb, I found that some of the wp-includes files, hidden well within a few directories, were missing.

    My ftp server must have just cut off or given up partway through the upload due to the file size of the wp-includes directory.

    So it's finally working! Woohoo!

    So, as a note for future users of Streamline.net who have this same problem, you need to check that all of the files are uploaded, every single little one in every directory in the whole WordPress folder.

    Also, in the wp-config.php file, the server "localhost" doesn't work for Streamline, you need to use the number provided when you create your mySQL database.

    Resolved!

  8. Samuel B
    moderator
    Posted 4 years ago #

    yea! :>)
    glad you were persistent - a lot of folks just give up

Topic Closed

This topic has been closed to new replies.

About this Topic