WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] WP Unable to Approve Comments : 500 Internal Server Error (27 posts)

  1. Hema Latha
    Member
    Posted 2 years ago #

    Wp Version: 3.2.1
    Hosting: Linux 4 Grid Ultimate Plan Shared Hosting Godaddy

    I'm unable to approve all the pending comments,
    as it ends up in 500 Internal Server Error.

    I contacted Godaddy Support:

    Hello Support,
    I'm unable to even approve comments inside my wp-admin for the site http://mysite.com as I get 500 internal server error. I have enabled the Error Logs:

    Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace.

    Kindly do the needful. Thank you.

    Godaddy Support Replied:

    Thank you for contacting Online Support.

    This particular error can be caused by a variety of issues but is most likely caused by a corrupt .htaccess file. Check to see if there is an .htaccess file in the directory where the error is being generated or any directory above in the tree. If so, temporarily rename the .htaccess file and refresh the page. If the error does not reappear, the .htaccess file is the issue. Repair the file or leave it disabled.

    Most of the time .htaccess issues are caused by trying to overwrite PHP settings, being uploaded in binary format or permissions issues.

    To resolve this matter, be sure to upload .htaccess files in ASCII mode. Also, set the permissions to 644, which makes it usable by the server, but prevents it from being read from a browser.

    If you are trying to make changes to PHP settings, be sure to make said changes to the php.ini or php5.ini file (depending on the version you are using).

    Please let us know if we can assist you in any other way.

    http://wordpress.org/extend/plugins/bulletproof-security/

    I use Bullet Proof Security Plugin for .htaccess
    And saw that the "Your Current htaccess File" is old.
    I again created a new "Secure .htaccess" file & updated settings.
    But, Still I'm getting the 500 Internal Server Error,
    If I try to 'select all' & approve comments.

    Uncommented:
    AddHandler x-httpd-php5 .php

    Issue didn't solve.

    From WordPress Support Forum, I got these lines & added it to .htaccess

    AddType x-mapp-php5 .php
    AddHandler x-mapp-php5 .php

    After that when I tried to Unlock/Lock BulletProof Security .htacess,
    My wp-admin redirected to a page full of errors which I couldn't make.

    Please view the errors here: PASTEBIN.

    Deleted .htacces & created a new secure .htaccess again.

    Pl help me how to solve this issue:
    =====================================

    1. Unable to Approve Comments: 500 Internal Server Error.

    Please view the Sample Error Logs here: PASTEBIN.

    Thank You.

  2. Pioneer Valley Web Design
    Member
    Posted 2 years ago #

    Are you using PHP version 5 ??? ....looks like WP is looking for 5+ (which is required for latest WP installs)...also are all plugins compatible with PHP5 ? Also what version of PHP are you at?

    If you have multiple sites hosted in one account, all the sites need to work with the current installed web host's apps such as PHP5.2 or 5.3. (so if you go from PHP 4 to PHP5 and one site is running WP 2.7 or vs. versa if your running PHP4 and installed WP 3+ you can and will have issues).

  3. Hema Latha
    Member
    Posted 2 years ago #

    (a) Yes, I have one more wp blog inside the same hosting account.
    Now .. I have updated BulletProof Security Plugin in that blog also.

    (b) Both the wp blogs are using wp Version 3.2.1

    (c) PHP Version: 5.2.17

    (d) I have a php5.ini file in the root directory.

    memory_limit = 64M
    upload_max_filesize = 64M
    post_max_size = 64M
    file_uploads = On

    (e) In both the wp blogs htaccess file, I have added this:

    # CUSTOM PHP.INI FILES - handlers and mod_suphp htaccess code for Web Hosts
    # If you are using either a BPS Pro custom php.ini file or one that you created yourself
    # If your host is GoDaddy and you have a custom php.ini file
    # uncomment the 1 line of code directly below
    AddHandler x-httpd-php5 .php

    (f) Installed Plugins:

    1. Akismet
    2. All in One SEO Pack
    3. Breadcrumb NavXT
    4. BulletProof Security
    5. Custom Upload Dir
    6. DB Cache Reloaded Fix
    7. Google XML Sitemaps
    8. Growmap Anti Spambot Plugin
    9. nrelate Related Content
    10. Use Google Libraries
    11. WP-CommentNavi
    12. WP Super Cache
    13. WP Super Popup

    What should I do ???

  4. Pioneer Valley Web Design
    Member
    Posted 2 years ago #

    1. Remove the ini file(s) to start or create a full ini file...

    2. Deactivate ALL plugins one at time, and then revert to default theme.

    3. (Part A) Why do you have multiple SEO plugins?
    (Part B) I would suspect a comment plugin if having comment issues.

    4. Enable your theme (if not default one), then activate ONLY plugins which you have researched the compatibly of with A) Your Theme, B) Your WordPress Version, C) Your hosting Environment D) Other Plugins.

    Activate only one plugin at a time, run site through all tasks a site visitor would, look at performance, page layout, can I comment, etc.

    Do so for each plugin until you replicate the issue, then don't use that plugin.

  5. AITpro
    Member
    Posted 2 years ago #

    Yep what SwansonPhotos said. You need to isolate the source of the problem.

    Is this a Network / MU installation of WordPress?
    If this is MU:
    BPS should only be activated for the Primary site
    BPS should not be Network activated

    i found a similar thread here >>> http://wordpress.org/support/topic/wordpress-multisite-subdomain-dashboard-500-internal-server-error?replies=7

    Also the email that GoDaddy sent you is an All-purpose pre-made email reply. What gives that away right away is that GD is now setting file permissions to 604 by default not 644.

    And another similar problem thread.
    http://mu.wordpress.org/forums/topic/17051#post-95531

  6. Hema Latha
    Member
    Posted 2 years ago #

    Hello, Thanks for the responses. Pl have a look now.

    Reply:
    - No. Not multi site.
    - There is a phpbb3 Forum installed in the subfolder
    - Blog installed at /public_html/
    - Forum installed at /public_html/forums

    I have done the below steps:

    1. Deactivated all the Plugins
    2. Changed to the default theme Twenty Eleven 1.3
    3. Tried to approve 'all comments'
    4. Result: 500 Internal Server Error.

    --------------------------------------------------------------
    After Few Days :
    --------------------------------------------------------------

    1. I moved my site to Dedicated Server in HostGator.
    2. Updated BulletProofSecurity Plugin.
    3. Uncommented:
    4. IfModule mod_suphp.c
    4.1suPHP_ConfigPath /home/user123/public_html/php.ini
    4.2IfModule
    5. Tried to approve 'all comments'
    6. Page keeps loading telling 'Connecting' at the browser top
    7. And after 15 to 20 minutes
    8. Result: Displayed the 'custom db-error.php' page.

    6. But the comments were published when I visited Dashboard.
    --------------------------------------------------------------
    Also > Server Load: 84.01 (8 cpus)
    --------------------------------------------------------------

    1. Deleted custom db-error.php
    2. Tried to approve 'all comments'
    3. Page keeps loading telling 'Connecting' at the browser top
    4. And after 15 to 20 minutes
    5. Result: Error establishing a database connection

    6. But the comments were published when I visited Dashboard.
    --------------------------------------------------------------
    Also > Server Load: 94.04 (8 cpus)
    --------------------------------------------------------------

    1. Tried again to approve 'all comments'
    2. Page keeps loading telling 'Connecting' at the browser top
    3. >>> And after 15 to 20 minutes
    4. Result: 20 comments approved (No Error)
    --------------------------------------------------------------
    Also > Server Load: 13.92 (8 cpus)
    --------------------------------------------------------------

    1. Again tried
    2. Page keeps loading telling 'Connecting' at the browser top
    3. >>> And after 15 to 20 minutes
    4. Result: 20 comments approved (No Error)

    5. It takes SEVERAL MINUTES to approve the comments now.
    --------------------------------------------------------------
    Also > Server Load: 79.83 (8 cpus)
    --------------------------------------------------------------

    There is something wrong, I don't know what.

    Will Re-installing wordpress fix this problem ???
    How to reinstall without loosing anything ?

    Can I rename all the Files & Folders that are seen when I open public_html directory to Old. Eg. wp-includes to OLDwp-includes,
    And Upload a fresh copy of all wp files, except the wp-content & wp-config ?

    Or the issue is something else ?

    Pl help me. Thank you.

  7. AITpro
    Member
    Posted 2 years ago #

    There is a possible Zend Guard problem on GoDaddy where the .htaccess file is being corrupted during fwrite. I am still looking into this further and it is not conclusive that Zend Guard is the problem, but it looks like it is the cause of the problem at this point. You have switched to another web host so this would not be relevant to your issue.

    3. Uncommented:
    4. IfModule mod_suphp.c
    4.1suPHP_ConfigPath /home/user123/public_html/php.ini
    4.2IfModule

    Do you actually have a custom php.ini file that you created for your site? This code is ONLY meant to uncommented if you really do have a custom php.ini file that you created otherwise you should not uncomment this code.

    Yep you should eliminate WP core files entirely at this point by replacing them, but it is most likely a DB corruption problem so optimize and run a repair of your DB (this will fix most DB problems, but in some cases will not fix all DB problems or corruption). The problem originally appeared to have something to do with your permalink structure, .htaccess file was corrupted or a cache problem, but i am not so sure any more. I am now leaning towards DB corruption - all the problems and errors are indicating a DB problem. So when you moved to your new host server i assume you just did a host migration of your files and DB and did not do a new clean installation? What you could do is install a new WordPress site and if everything is good then just migrate (SQL import, etc) your content from your old DB to the new site DB.

  8. Hema Latha
    Member
    Posted 2 years ago #

    Hello AITPro,

    I have one more wp blog in the same server running without any problem.
    It has it's own cpanel & not connected with this wp blog.

    I deleted all the wp files & folders.
    Uploaded a refresh wp v3.3 files & installed it -> a clean fresh blog.

    There are no plugins except Akismet.
    There are no php.ini or php5.ini file.
    Permalinks - Postname: site.com/sample-post/

    Dropped all the tables in the new database,
    Using BigDump script: Uploaded the old database to the new database.

    (Coz I was unable to upload the new db as it gave error,
    Came to know from a forum that I have to drop the old tables.
    So dropped all the tables)

    Dropped few unwanted tables in the present db & kept only these tables:
    commentmeta
    comments
    links
    options
    postmeta
    posts
    terms
    term_relationships
    term_taxonomy
    usermeta
    users

    Repaired the above tables.
    Optimized the above tables.

    Still it takes very long time to approve 'all comments'.
    Error logs say only about /404.shtml
    Is there any other way to find out what is causing the problem?

    Server Stats Screenshot: http://i42.tinypic.com/az6z9l.png

    Thank you.

  9. AITpro
    Member
    Posted 2 years ago #

    Yep that Server Load is off the charts. Something must be looping to cause such a huge resource drain. This is just WP's core commenting and not some additioal plugin that you have installed right?

    You should set up up WP debugging so that you can isolate where the problem is occurring exactly. Once you have that info you can then start working on fixing the exact problem area.

    WP Debug >>> http://codex.wordpress.org/Editing_wp-config.php

    WP debugging will display php errors to you, but you can also set a custom php.ini file to show php errors ONLY in a php error log file if you don't want them displayed publicly. Some web hosts have a built in php error log that you can check in your Control Panel so see if you already have that before creating a new php error log.

    Also post your websites URL so i can look at your site with FF tools.

  10. alokj99
    Member
    Posted 2 years ago #

    Same with me.

    I have 7 - 9 websites on wordpress and I have been facing the downtime with Godaddy linux hosting installed wordpress on it.

    I have emailed support more than 10 times in last 2 months and they keep giving me stupid reasons about my TSP.

    I have another 1 website which work superb without issues on another hosting (hosted in Dallas)

    The support is telling me that ISP of India has a problem and not we. lol this is awesome way of finger pointing and pushing issues on someone else head from support of godday head.

    all my clients and their traffic is from different locations and they are complaining about the same thing. So as per godaddy this problem is with all server providers and not them.

    "whole world ISP has issues to access godaddy hosting" but godaddy is working fine :) lol

    I guess i really need to seriously think of moving all domains and hosting to other provider.

  11. AITpro
    Member
    Posted 2 years ago #

    Been using GoDaddy for 2 years. I'm online 12 hours a day and on my site probably 4 of those hours per day. Downtime 2 times in 2 years - total of 45 minutes of downtime in 2 years. I'd say that is pretty good. Good luck.

  12. AITpro
    Member
    Posted 2 years ago #

    Came across this nice snippet of .htaccess code on the AskApache site.

    Fix for infinite loops
    An error message related to this isRequest exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace.or you may seeRequest exceeded the limit, probable configuration error, Use 'LogLevel debug' to get a backtrace or Use 'LimitInternalRecursion' to increase the limit if necessary.

    RewriteEngine On
    RewriteCond %{ENV:REDIRECT_STATUS} 200
    RewriteRule .* - [L]

  13. Pioneer Valley Web Design
    Member
    Posted 2 years ago #

    AITpro? What level of hosting are you using on GoDaddy and do you not think it's important to point that out? For example, is PHP logging available on all shared hosting accounts? Doesn't GoDaddy put too many accounts on shared servers and run a horrid load balancing scheme on them also?

    As for attempting to approve many comments at once, there are also limits on the number of queries and writes to the db on these accounts, yes? including limits on how long they can take?

    BTW, PHP 5.3.6 updates the Max Memory and Max Script Timeout among other php.ini related items on GD. Yes, when you upgrade to PHP 5.3.6 you will be migrated to a new data center...

    As for others with down time of late on GoDaddy or elsewhere, please read up on the XSS issue patched by WP3.3.1 and also on timthumb.

    IMHO, what hosts need to do is shut down old insecure installations (so easy - just force a .maintenace file that is not removable by the client, until they update, with info on what needs to be done and contact info etc.). It would also help if they ran the latest secure servers.

  14. AITpro
    Member
    Posted 2 years ago #

    I try to be as general as possible and not try to write a book over here (been there done that here - it only leads to having to explain the last thing you said and then the last thing you said and then the last thing............. ;) LOL It's not like anyone would get what I was saying any way if I went Mega Nerd here. ha ha ha

    Well it may be that other people are not as lucky as i have been with GD. Not really sure because all I have to go by are my personal sites and about 200 client sites hosted on GD in the last couple of years. When i refer to "my sites" i am grouping the 200+ sites together under the phrase. And i have tried about 10 different Hosts myself over the years and have migrated clients from about 60 Hosts to GD and I have probably looked under the hood on somewhere in the neighborhood of 100 web hosts. So it's not like i am just guessing that GD is better then what I have seen or found or experienced elsewhere. ;)

    In my professional experience - 9 times out of 10 the Host is blamed when the problem is actually on the client end - poor coding, misconfiguration, making silly mistakes, etc. In a World where everything is so automated now a days it seems that peeps have gotten lazy about using standard basic debugging troubleshooting steps and are quick to try and blame someone else instead of completely ruling out that the problem could be on their end first.

    Yeah well it is never a good idea to force clients to make an upgrade. Unfortunately, everyone in the biz knows that you have to leave some stale moldy cheese somewhere in the deal - hopefully tucked way out of site so only the last lingerers nibbling on that moldy cheese will find it. ;)

    And on a personal note i am dying to switch from Optimizer to Guard, but right now Zend Guard does not work correctly for what i am doing. I am trying to recode things in steps to see if i can compensate for these issues, but so far i cannot use Guard and still have a stable site. bummer.

  15. Pioneer Valley Web Design
    Member
    Posted 2 years ago #

    You have not answered the question: What level of hosting are you using on GoDaddy and do you not think it's important to point that out?

  16. AITpro
    Member
    Posted 2 years ago #

    Which hosting account are you referring too? I have Shared, VPS and Dedicated Hosting accounts, some experimental ASP and Windows setups and about 10 other types of set ups. So what would i mention here???

  17. Pioneer Valley Web Design
    Member
    Posted 2 years ago #

    Can you go re-read the original post above - she is on shared hosting on Godaddy...which is quite different than dedicated servers or VPS...not even apples and oranges are as different, which is my whole point.

    Do you work for GoDaddy or are you a spokeperson for them?

  18. AITpro
    Member
    Posted 2 years ago #

    I was no longer attempting to troubleshoot her miscellaneous issue. She is a college student so she will find her way back here again when time permits in her schedule. We have worked out some other problems she had in the past. ;) I just happened to come across a snippet of code that i thought would be useful for debugging loops if anyone else happened to find this thread - the error messages are similar and this would just be one more thing to rule out or debug with.

    Are you a jerk or an a$$ - please do not comment in my plugin area again. Thank you.

  19. Pioneer Valley Web Design
    Member
    Posted 2 years ago #

    Your plugin area?

  20. AITpro
    Member
    Posted 2 years ago #

    Yes this post / thread was started under the BulletProof Security plugin >>> http://wordpress.org/tags/bulletproof-security?forum_id=10

    This is not a general forum and is supposed to be a forum designated to solving direct issues with BPS either by me or anyone else who understands BPS well enough to provide a solution. in this case her problem is not directly related to BPS, but i will still assist her when she posts back here again. You are welcome to try and assist her as well, but please do not make any more direct request at me. I will not answer them as this is going in a very childish direction. Thank you.

  21. Pioneer Valley Web Design
    Member
    Posted 2 years ago #

    This post is in the WordPress Forums and has the following Tags...

    500 internal server error
    500-error
    approve comments
    bulletproof-security
    Dedicated Server
    godaddy
    hostgator

    Not sure what upset you, was not my goal, just trying to be clear for ALL who are going to read this post and not just you and the OP.

  22. AITpro
    Member
    Posted 2 years ago #

    oh my mistake. i thought this was only a direct post in BPS. not upset at all. just thought the discussion was going in a pointless direction. my apologies. Thanks.

  23. Pioneer Valley Web Design
    Member
    Posted 2 years ago #

    No prob...

  24. Hema Latha
    Member
    Posted 2 years ago #

    ///////////////////////////////////////////////////////////////////////////////////////////////////////////////////

    Hello AITpro ..

    My blog is working great
    And now I'm able to all approve comments in few seconds (Zooom ..)
    BPS Plugin is having no issues with Hostgator.
    Thanks a lot for such a wonderful plugin.

    (If there is any way on this forum to rank u, I will definitely do;
    But I have ranked your plugin 5 Star & Marked it works with v3.3.1)
    I'm really thankful to you for the exceptional help you provided.

    ///////////////////////////////////////////////////////////////////////////////////////////////////////////////////

  25. AITpro
    Member
    Posted 2 years ago #

    Hi Hema,

    Glad your're rockin and rolling again Yeah!!!!

    So what was the problem and how did you fix it? Thanks for the 5 Star Rating and the very kind words. :) :) :)

    Best Regards,
    Ed

  26. Hema Latha
    Member
    Posted 2 years ago #

    Hello AITpro,

    I want to be very true.
    I really don't know. I'm not a techsavvy.
    I just followed ur instructions. It worked.
    Thanks for ur support.

    :) :) :)

  27. AITpro
    Member
    Posted 2 years ago #

    Cool. Thanks again for the 5 star rating. ;)

Topic Closed

This topic has been closed to new replies.

About this Topic