WordPress.org

Ready to get started?Download WordPress

Forums

WP Uber-Slow when running on alternate port behind router (11 posts)

  1. moosefuel
    Member
    Posted 2 years ago #

    Hi all,

    I recently decided to create my own server and run it from home. My ISP blocks port 80 so I used port 8888. From my local area network I can load my blog fine (ie: 192.168.0.10:8888) but from the WAN (I logged on from my wife's 3G phone to get myself outside of my local WIFI network) the page takes forever to load, and when it does load, it is missing the CSS, and all text appears in Times New Roman left-justified. I have no problem serving simpler pages from this port (try http://66.131.16.14:8888/info.php).

    The WP site I am trying to serve to the www is: http://66.131.16.14:8888/index.php

    These are actual links, you can try them. I have made sure I did the following:

    • Set up port forwarding on my router to allow port 8888 to pass to my server,
    • Change WP's config so that it's default address is 192.168.0.10:8888, the same as my server's local address,
    • Set up Lighttpd (my web server running on debian linux) to serve on port 8888

    Has anyone had a similar problem, or can anyone suggest a solution?

    Thanks.

  2. cloptic
    Member
    Posted 2 years ago #

    I am having the exact same issue, and its driving me nuts. On the local network, my WP is super fast. Externally, my regular pages are pretty fast, but WP is ultra slow, missing pics and CSS. anyone with a solution?

    Thanks

  3. moosefuel
    Member
    Posted 2 years ago #

    I've been working on this issue a little bit, but I currently am without a way to test my solution (I work from home and was using my wife's 3G to check it from outside my network, but alas, she is at work).

    If anyone is interested, what I tried was in settings, leaving my wordpress address as my local ip (192.168.0.10:8888), and changed my website address to my world wide web adress, which is 66.131.16.14:8888.

    If someone out there could click on the 66.131.16.14:8888 address and tell me if my site loads with CSS, images, etc., that would be great. I tried using a proxy like hidemyass.com, but it doesn't do port no.s.

  4. cloptic
    Member
    Posted 2 years ago #

    well, I tried your link and it loaded pretty slow with no CSS, so I would say that fix is a no-go.

  5. moosefuel
    Member
    Posted 2 years ago #

    Well rats. Thanks anyway.

  6. cloptic
    Member
    Posted 2 years ago #

    by the way, port # has nothing to do with it, as I am on a standard port 80 with the same issue.

  7. moosefuel
    Member
    Posted 2 years ago #

    Very peculiar. Are you also behind a firewalled router? I also wonder if it is the ISP's fault, but static pages seem to work fine, which makes me suspect something about my own configuration.

  8. cloptic
    Member
    Posted 2 years ago #

    Yes, I am behind a firewall. just for giggle Im going to restore WP from a backup and restart the server, Ill post how it goes.

  9. cloptic
    Member
    Posted 2 years ago #

    ok. found something. If you go into WP settings you will see a setting for wordpress address, this needs to be set to your external IP for outside traffic to see it properly. unfortunately, when I changed this setting, it reversed the issue, now viewing WP from internal network is no CSS, etc.....

  10. moosefuel
    Member
    Posted 2 years ago #

    That's really good news. I supposes the next thing to figure out would be how to make WordPress recognize both ip addresses, internal and external. I did a quick google and saw some info on this under the WP multisite configuration. I'll read on.

  11. moosefuel
    Member
    Posted 2 years ago #

    I'm pleased to report some preliminary success with this article: http://codex.wordpress.org/User:Westi/Hosting_WordPress_Behind_NAT

    Basically, I opened up the /etc/hosts file on my Mac (not the server, which is Debian Linux), and added this line:

    192.168.0.10 moosefuel.dyndns.org

    Basically I am telling the computer that when I navigate to my dyndns (a service which changes ips into human-readable names) address, it should access the server directly from inside the local network, but do it in such a way that it is as if it is doing it externally.

    At least that's my limited understanding of it.

    The downside is that you have to do this on all the computers, iPhones, Androids etc. in your local network.

Topic Closed

This topic has been closed to new replies.

About this Topic