WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] WP Touch not working (18 posts)

  1. monkeykiddo
    Member
    Posted 2 years ago #

    Hi all,
    I've had wptouch installed for a while but it doesn't seem to be giving me a mobile version on the iphone. When I use an iphone simulator I just see my site as it is on the pc but it's not a scaled down version so subsequently does not fit in the screen, there are also no apple icons and according to market.grader.com I have no meta view port or apple icons. I thought this is what wp touch was supposed to do. Is there something I am missing in the settings or does anyone have an alternative plugin that works for them?
    Thanks
    http://www.englandculturalhomestay.com

  2. hakaner
    Member
    Posted 2 years ago #

    Remove selection from "1st visit mobile users will see desktop theme" option and add user-agents into wp super cache plugin.

  3. monkeykiddo
    Member
    Posted 2 years ago #

    Thanks I've done this but still the same issue.

  4. monkeykiddo
    Member
    Posted 2 years ago #

    I deselected 1st visit mobile users... but then it just displays the home page with a random image, not my logo and there is no option to navigate around other pages. Any ideas? Anyone? Thank you.

  5. hakaner
    Member
    Posted 2 years ago #

    I tested with iphone user-agent for take ss and your mobile theme is seems fully working.

    your site:
    http://i.imgur.com/DuDKg.jpg
    with wptouch:
    http://i.imgur.com/9cDca.jpg
    and navigation bar:
    http://i.imgur.com/iQ4RT.jpg

    This theme will be different from your regular theme. Because, it is a "second" theme for mobile devices.

  6. monkeykiddo
    Member
    Posted 2 years ago #

    That's great, thanks for doing that.
    I just have a few questions.

    Do you know how I get my logo (as seen on site) into the header of the iphone version?? At the moment it is a random image from my site?

    Also, despite the site running fine now on the iphone, when I run my site through martket.grader it still says I have no apple icons or metaviewport.
    Any idea on how to rectify this? Thanks a lot for your time.

  7. hakaner
    Member
    Posted 2 years ago #

    You must create a logo icon first for your home logo (59x60px png)
    Then upload your icon under "Default & Custom Icon Pool" option (via "Upload Icon" button) and refresh your wptouch settings page. Finally, select your uploaded icon name from "Logo / Home Screen Icon & Default Menu Items" option (located at the bottom of the listed items).

  8. monkeykiddo
    Member
    Posted 2 years ago #

    Perfect thanks for all your help.

  9. hakaner
    Member
    Posted 2 years ago #

    You're welcome, glad to help.

  10. shenry
    Member
    Posted 2 years ago #

    I am having the same problem with WPtouch. I have created all of the settings but when I view my site http://www.hydeparkatx.com on my iphone (by going to the url via Safari) it looks the same as it does on the desktop. I've created the 59x60 icon, but don't know where it is supposed to show up on the mobile app. I also called up the previous inquirer's website, http://www.englandculturalhomestay.com, on my iphone and also saw a desktop-style website, it didn't look like a WPtouch or mobile site on my iphone. Do you know what I might be doing wrong?
    Thanks.

  11. BraveNewCode Inc.
    Member
    Posted 2 years ago #

    Hi Shenry,

    englandculturalhomestay.com has "1st visit mobile users will see desktop theme". So that is why you're seeing the desktop version, but you'll see the switch link in the footer area. However, it looks like monkeykiddo needs to configure W3 Total Cache to work with WPtouch Pro by adding the list of mobile user agents WPtouch supports to the 'rejected user agents' area of W3TC.

    I'm currently not seeing any issues on your website. If the issue persists on your side, scroll down to the bottom and look for the switch link. Tap on it and see if you're then taken to the WPtouch theme. As far as I can tell, you're not running a cache plugin. So also make sure it's not a local cache issue by clearing the cache and cookies on your device.

  12. shenry
    Member
    Posted 2 years ago #

    got it. thanks!

  13. monkeykiddo
    Member
    Posted 2 years ago #

    Thanks brave new code. It might help if I enable my options. :)
    I didn't even notice. Is working perfectly now.
    Thanks again.

  14. essteffan
    Member
    Posted 2 years ago #

    Hy all
    I watch this posts, and i did what it says there, but in my case does not work
    My website is http://www.programesoft.ro

    Thanks in advance for helping me.

  15. monkeykiddo
    Member
    Posted 2 years ago #

    Brave new code - I still don't seem to have wptouch working. I checked my site on my friends android phone but still it is not giving me the option to switch to compatible viewing. I just set the user agents to pass through my theme - is this correct? However when I viewed it through online iphone tester nothing had changed. I don't have a smartphone to view it.
    Any advice would be appreciated to this ever increasing isssue.
    Thanks a lot.
    http://www.englandculturalhomestay.com

  16. BraveNewCode Inc.
    Member
    Posted 2 years ago #

    essteffan,

    It looks like you're running WPtouch Pro successfully on your website. If you have any questions regarding WPtouch Pro, please login with your Pro account at http://www.bravenewcode.com/support and our support team will gladly assist you there.

    monkeykiddo,

    We responded to your e-mail about this issue previously. Let us know if you're still having trouble.

  17. lukelee
    Member
    Posted 2 years ago #

    Hi, monkeykiddo:
    Can you please share the solution of viewport and mobile issue on marketing.grader.com with me?
    My site: http://luke.dreamupdating.com.au/ just couldnt get it right.
    I have installed WPTouch, and works well on mobile device, just couldn't pass marketing.grader

  18. monkeykiddo
    Member
    Posted 2 years ago #

    Hi Lukelee,
    I ended up contacting market.grader. They said it was working fine but the grader scans the webs files for certain code strings in the php files and they were missing. They told me what strings needed to be added although I can't find the original email with that information so it'd be best to contact them. They said it was purely aesthetic as wptouch was working but it just bumps up your score with market grader if they can trawl and find the stings on your site. Hope this helps. Sorry I can't find where or what the code strings are but I remember it was very simple to and they answered back very quickly.
    Good luck.

Topic Closed

This topic has been closed to new replies.

About this Topic