WordPress.org

Ready to get started?Download WordPress

Forums

WP to Twitter
[resolved] wp to twitter: Your server time is not in sync with the Twitter servers (8 posts)

  1. declaracioneside
    Member
    Posted 1 year ago #

    Hi

    In wordpress (http://declaracioneside.org/~declarac/blog/wp-admin): In WP to Twitter (ver. 2.4.13): I have checked the switch to http connection, set the proper timezone in general settings,

    In my hosting service: I've put date.timezone = "Europe/Belgrade" in php.ini, and when run a script reading hosting server time, this gives me the same time as twitter server

    But in wordpress when trying to connect wp to twitter, it still reads one hour prior to twitter server time

    Any suggestion? Please help

    http://wordpress.org/extend/plugins/wp-to-twitter/

  2. btetrault
    Member
    Posted 1 year ago #

    I'm also still having this same problem with the server times not matching and giving errors. Even with the 'Enable http' checked (to bypass https). I'm on version 2.6.9

    Been trying lots of different combos of things and get the OAuth error every time.

  3. Joe Dolson
    Member
    Plugin Author

    Posted 1 year ago #

    What is the specific error you're getting?

  4. btetrault
    Member
    Posted 1 year ago #

    When I try to connect I get 2:

    OAuth Authentication Failed. Your server time is not in sync with the Twitter servers. Talk to your hosting service to see what can be done.

    and

    Twitter requires authentication by OAuth. You will need to update your settings to complete installation of WP to Twitter. (which is always present)

    Site is http://lensprotogolabs.com

  5. Joe Dolson
    Member
    Plugin Author

    Posted 1 year ago #

    Then that's really a question you need to raise with your hosting service -- Twitter requires that the server time of the client application be in sync with their server time, and they enforce that. Any time difference greater than about 5 minutes will be rejected automatically.

    You'll need to talk to your host and see if they can correct the time on your server.

  6. btetrault
    Member
    Posted 1 year ago #

    Ok, thanks. I was under the impression that changing to http from https would bypass that but I will check with my server. Thanks much!

  7. Joe Dolson
    Member
    Plugin Author

    Posted 1 year ago #

    If the problem was that your server could not contact Twitter at all, then changing to http might have helped. But if your server actually has an incorrect time, that change won't help.

  8. btetrault
    Member
    Posted 1 year ago #

    I actually contacted my server and there was an issue with the 'ntp service on the host machine my VPS is on'. They made the change and it did the trick. Thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic