WordPress.org

Ready to get started?Download WordPress

Forums

WP thinking it's in main directory (12 posts)

  1. khlara
    Member
    Posted 9 years ago #

    Here's my problem.
    On the index page, every single link goes back to my main directory. Nothing is actually linked to the subdirectory in which I put my WP in, which is quella. So I either come up with being taken to the front of my website, or get a "Page cannot be found" error. (I can understand the error, the page isn't there because it's over in quella!)
    So how do I get wp to understand it's in a subdirectory and not in my main directory?

  2. XeroCool
    Member
    Posted 9 years ago #

  3. khlara
    Member
    Posted 9 years ago #

    That just tells me how to move from domains. This is just a subdirectory problem. Nothing's changed for the wp-config.

  4. khlara
    Member
    Posted 9 years ago #

    Also, I'm basically wanting to make it so I have my individual site (www.tagnout.com) and then my wordpress in a subdirectory and completely in just that directory. (Which is the quella subfolder within tagnout.com) and therefore I can link all the wordpress to tagnout.
    I have no php or sql admin abilities, I have to go through my host for that, and I use FileZilla to upload everything and to deal with my page.

  5. moshu
    Member
    Posted 9 years ago #

    What do you have in the Options > General for WordPress URI and Blog URI?
    Should be http://tagnout.com/quella

  6. khlara
    Member
    Posted 9 years ago #

    I just changed them both to the adress. I'm assuming I put the address in the ( ) that's there. I uploaded and still nothing, it links back to the main directory.
    I looked at the index.php for both using the source under "view source" and everything is indeed linking back to the main tagnout folder. Looking into the individual index.php (the actual coding) lots of links are using './bip.php' and so I tried going into the main index.php and changed it to 'quella/wp-blog-header.php' and now everything went blank, so I'm not sure if I need to go in and change every link or if there's some master in-line link changer that WP has so it can all link back to the subdirectory.

  7. moshu
    Member
    Posted 9 years ago #

    As I see your site doesn't recognize index.php as index for a directory. I had to type it maually to get to the index page.

    I don't really understand what did you do with the URIs? What "( )" are you talking about?
    Go to your admin panel, click Options and under the General tab you will find two fields wher you have to type in the address I suggested above. Then down in the bottom right corner of the page click Update Options.

  8. khlara
    Member
    Posted 9 years ago #

    I know I should've mentioned this. I logged in the first time, and made it so I could just pass up the login screen to get into the admin, however the wp-admin gives me: Directory Listing Denied
    This Virtual Directory does not allow contents to be listed. as an error.
    My bf suggested it's a permissions problem. I really don't know.

  9. moshu
    Member
    Posted 9 years ago #

    Nope. It's a not-so-clever server setting. See above what I said about not recognizing index.php as (one of the) deafult index.

    (not a user-friendly host you have there... I'd look for a better one)

  10. khlara
    Member
    Posted 9 years ago #

    My host changed it to recognize index. I was able to login to the options and change it. It works now.
    Thanks!
    Yay! I have a WordPress!

  11. vkaryl
    Member
    Posted 9 years ago #

    khlara, you're a great example of "stick-to-it-iveness". You've hung in there through a lot of dreck, and now you're blogging. Great job!

  12. khlara
    Member
    Posted 9 years ago #

    Thanks. ^_^

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.