WordPress.org

Ready to get started?Download WordPress

Forums

WP Theme Switcher problem (7 posts)

  1. wurlocke
    Member
    Posted 9 years ago #

    I am running three themes on my blog over at http://so-phobic.com

    My problem is that whenever someone chooses a template aside from OrangeSky, the other pages still display the content in the default theme!

    I've been pulling my hair out for the past 4 hours and I don't understand why it's happening!

    Please... help?

  2. jwurster
    Member
    Posted 9 years ago #

    How are you switching themes? I just tried OrangeSky and then stanch. I tried the archives using each theme and that displayed correctly.
    jim

  3. jennmiller
    Member
    Posted 9 years ago #

    I'm with jwurster, works perfectly :) You may need to clear your cache, perhaps?

  4. RosieMBanks
    Member
    Posted 9 years ago #

    I just tried it. I switched to Orange Sky and tried About, Archive, Links, etc. and all was well within Orange Sky.

    Then I tried Stanch and went to the About page but it popped me right back into the Falling Dreams theme. I tried Orange Sky again, hit the About page and I got popped into the Kubrick theme. I tried it again and it worked the way it should: all Orange Sky.

    Stanch seems to have the least staying power of the three themes. Hitting all the pages always takes me to Falling Dreams. I also got Kubrick several times.

    Something is definitely amiss but I don't know enough to tell you why it's happening, just confirm that it is. Sorry!

    Edited to add:

    Oh, wait... your photo gallery is supposed to be in Kubrick, right? It's not a page, but another site altogether. So forget the Kubrick comments!

    Heh! I should stay out of this trouble-shooting stuff!

  5. wurlocke
    Member
    Posted 9 years ago #

    Hey Rosie!

    Yep, the Gallery is a separate site, but you got the same problem that I do regarding the other themes. The only one that seems to work is OrangeSky.

  6. ImTa2d
    Member
    Posted 9 years ago #

    Wurlocke do you have
    <?php require_once('./wp-blog-header.php');
    get_header(); ?> at the top of each of your pages? I don't know if that's the problem, but my themes all work on my pages with that bit @ the top.

  7. wurlocke
    Member
    Posted 9 years ago #

    Isn't that supposed to be listed in the main index.php file?

    Yes, I have that there

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.