WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: wp-table-reloaded] wp-supercache error Unexpected character in input (5 posts)

  1. logart
    Member
    Posted 4 years ago #

    Hello,

    I have noticed that IE users are having problems where the page I have the table posted at appears as a blank page. Here are the error log entries:

    [Fri Mar 19 10:03:01 2010] [error] [client 127.0.0.1] PHP Warning: Unexpected character in input: '\x1e' (ASCII=30) state=1 in /docs/wp-content/cache/supercache/localhost/products/index.html.gz on line 49, referer: http://localhost/
    [Fri Mar 19 10:03:01 2010] [error] [client 127.0.0.1] PHP Parse error: syntax error, unexpected T_STRING in /docs/wp-content/cache/supercache/localhost/products/index.html.gz on line 49, referer: http://localhost/

    Line 49 in my source is:

    @import url("http://localhost/wp-content/plugins/wp-table-reloaded/css/plugin.css?ver=1.7");

    Any ideas on why that line is causing an error in wp-supercache?

  2. TobiasBg
    Member
    Posted 4 years ago #

    Hi,

    wow, that's another odd issue. And again, I have no clue where it could come from :-(

    I sounds like a character encoding issue (I really start to hate this encoding topic...), but I'm not sure. Are you using any unusual encoding for your site, or the DB?

    But what even more confuses me, is: Why is the index.html.gz file acutally parsed by PHP? That does not make sense at all to me. Shouldn't that be a static file that is just send to the browser statically, to speed up things? Is there any PHP in it actually?

    However, you could try it again with that mentioned line 49 removed.
    The easiest way for this is to uncheck the CSS inclusion checkboxes on the "Plugin Options" screen of WP-Table Reloaded.
    That line should then no longer be there and eventually you should not receive that parsing error.
    Then you could try adding the line again, but instead of having it inserted automatically (which is a result of the checked checkboxes), you should include it manually by adding it to the "Custom CSS" textarea, i.e. type the exact code that was removed in to that textfield. (The typing is the important part, as it would remove any character encoding issues that might arise from copy&pasting it.)

    Sorry that I'm not yet a real help to your two problems, but unfortunately you are the only one so far reporting such issues...

    Best wishes,
    Tobias

  3. logart
    Member
    Posted 4 years ago #

    Actually, I do have some php code inside the table cels. Would that make a difference?

  4. TobiasBg
    Member
    Posted 4 years ago #

    Hi,

    with PHP in the table cells, you mean, you are using the Extension from my website?
    I'm not sure actually, if that could create issues with the caching, but it is very well possible. On the other side however, the PHP probably only generates HTML or text, too, so it should actually not be a problem. Unless maybe that the PHP really needs to be executed on each page load...

    One suggestion (don't know if it is possible): Can you tell WP-Supercache to exclude that page with the table from the caching? I doubt that you would lose much performance by that, but it should remedy that issue (if it indeed is related to the PHP).

    Have you made any progress on the first issue, with the unexpected character in the input?

    Best wishes,
    Tobias

  5. logart
    Member
    Posted 4 years ago #

    I will try to exclude it and see what happens.

Topic Closed

This topic has been closed to new replies.

About this Topic