WordPress.org

Ready to get started?Download WordPress

Forums

[WP-Table Reloaded] Serious lag when importing table (4 posts)

  1. dmatranga
    Member
    Posted 4 years ago #

    Hey Tobias,

    Sorry to bug you again, but I'm having another issue. I have a table in CSV format that has 411 rows and 12 columns. Whenever I try to import it, it takes about 15-20 minutes, and it only imports about half of the rows and adds a bunch of blank columns. I can't use Firefox at all while it's importing either.

    Here's some other info/symptoms that might help:

    • Firefox looks like it's freezing up, and I can't access any other open tabs or windows.
    • View table interface appears, but you can tell it's still trying to think and interpret all those cells.
    • Changed the parameter 'max_execution_time' in 'php.ini' from '60' to '0' because 0 allows for no limit.
    • Used Microsoft Excel 2007 to export table as CSV file, then imported it into wp-table reloaded.
  2. TobiasBg
    Member
    Posted 4 years ago #

    Hi,

    I really have no clues, how to get rid of this problem. Sorry :-(
    I can only guess that it is caused by the many input fields (in your case more than 4000). I suppose that the browsers just have problems with that because it uses up so much memory.

    It should not be a server issue, because the server does not have a whole lot to do when importing, just parse the CSV and save it to the database.
    The slowdown is simply caused by the browser.

    Looks like I really need to re-model the interface, just have no real clue how to. And actually not very much time :-(

    Best wishes,
    Tobias

  3. dmatranga
    Member
    Posted 4 years ago #

    I *kind of* fixed it by addressing an issue with the CSV export from Excel. I opened up the CSV file in Notepad to see what it really looked like and saw that Excel was adding a bunch of commas after each line.

    So I explicitly deleted all those columns in Excel, and then re-exported the CSV file. That fixed the problem with the extra blank columns, and cut down on the time it took to parse the data into WP-Table Reloaded's cells, but it did still take about 10-15 minutes and I saw that it was taking up about 400MB of Windows' memory. Luckily I have 8 gigs of RAM, hehe.

    So anyway, when I re-imported that CSV file, since I had changed that parameter in the php.ini file, it eventually loaded all the fields. Now the only issue is whenever I make updates to the table, I'll have to wait another 15 minutes for it to finish 'thinking'.

    I'm setting this up for a client to do data entry, but I think I'm going to have to eventually find an alternative. Any suggestions of alternatives for a novice user to enter data into a table would be much appreciated.

    Thanks for this plug-in though, and for all your hard work, seriously. And I promise to make a donation whenever I get paid for this project! :)

  4. TobiasBg
    Member
    Posted 4 years ago #

    Hi,

    that's good to hear.
    There was probably some content in that Excel file to the right of your data. That could have led to those additional empty lines.

    Best wishes,
    Tobias

Topic Closed

This topic has been closed to new replies.

About this Topic