WordPress.org

Ready to get started?Download WordPress

Forums

[wp-table-reloaded] borders (17 posts)

  1. mugger
    Member
    Posted 5 years ago #

    How might I hide borders, or change color, for one or for all tables?

  2. TobiasBg
    Member
    Posted 4 years ago #

    Hi,

    you'll need to change the CSS.
    Please have a look at the documentation of the plugin, where you'll find the needed CSS selectors.

    I could also help better, if you provided the URL of your post/page with a table and tell me, what exactly you want to achieve there.

    Thanks!
    Tobias

  3. kkellish
    Member
    Posted 4 years ago #

    I've been trying to hide the borders too. I've been changing the colors and even added border-collapse with no solution. I'm no coder I admit it but hopefully you can help me fix this. My current CSS is:

    .wp-table-reloaded {
    	background-color:#ffffff;
    	margin:10px 0px 15px 0px;
    	font: Icon;
    border: 1px Solid ThreeDShadow;
    background: Window;
    color: WindowText;
    border-collapse: collapse;
    }
    .wp-table-reloaded th {
    	background-color:#ffffff;
    	padding:4px;
    }
    .wp-table-reloaded td {
    	color:#666666;
    	padding:4px;
    	background-color:#FFFFFF;
    	vertical-align:top;
    }
    .wp-table-reloaded .even td {
    	background-color:#FFFFFF;
    }
    .wp-table-reloaded .odd td{
    	background-color:#ffffff;
    }
    .wp-table-reloaded .header {
    	background-image:url(http://stupidworld.net/wp-content/plugins/wp-table-reloaded/img/bg.gif);
    	background-repeat:no-repeat;
    	background-position:center right;
    	cursor:pointer;
    }
    .wp-table-reloaded .headerSortUp {
    	background-color:#ffffff;
    	background-image:url(http://stupidworld.net/wp-content/plugins/wp-table-reloaded/img/asc.gif);
    }
    
    .wp-table-reloaded .headerSortDown {
    	background-color:#ffffff;
    	background-image:url(http://stupidworld.net/wp-content/plugins/wp-table-reloaded/img/desc.gif);
    }
  4. TobiasBg
    Member
    Posted 4 years ago #

    Hi,

    you say that you want to hide the borders, but the first CSS contains an extra border to be inserted? I'm confused :-)

    Generally, to remove borders, this is known to work:
    Add border:none!important; to the CSS declarations of any table, tr, th and td of the plugin's CSS (in the Plugin Options).
    If that's still not doing it (might be the case with IE7) try adding cellspacing="0" as another parameter to the shortcode that displays the table in the post/page.

    Best wishes,
    Tobias

  5. kkellish
    Member
    Posted 4 years ago #

    I warned you I'm no coder :) I made these changes with no fix yet, I still get a grey border around the table:

    .wp-table-reloaded {
    	background-color:#ffffff;
    	font: Icon;
            border: none!important;
            cellspacing="0";
    }
    .wp-table-reloaded th {
    	background-color:#ffffff;
    	border: none!important;
            padding:4px;
    }
    .wp-table-reloaded td {
    	color:#666666;
    	border: none!important;
            padding:4px;
    	background-color:#FFFFFF;
    	vertical-align:top;
    }
    .wp-table-reloaded .even td {
    	background-color:#FFFFFF;
    }
    .wp-table-reloaded .odd td{
    	background-color:#ffffff;
    }
    .wp-table-reloaded .header {
    	background-image:url(http://stupidworld.net/wp-content/plugins/wp-table-reloaded/img/bg.gif);
    	background-repeat:no-repeat;
    	background-position:center right;
    	cursor:pointer;
    }
    .wp-table-reloaded .headerSortUp {
    	background-color:#ffffff;
    	background-image:url(http://stupidworld.net/wp-content/plugins/wp-table-reloaded/img/asc.gif);
    }
    
    .wp-table-reloaded .headerSortDown {
    	background-color:#ffffff;
    	background-image:url(http://stupidworld.net/wp-content/plugins/wp-table-reloaded/img/desc.gif);
    }
  6. TobiasBg
    Member
    Posted 4 years ago #

    Hi,

    no problem :-)

    Ok, you got me wrong on the cellspacing="0" part. That does NOT go into the CSS. Instead it's a parameter to your shortcode.
    So, [table id=1 /] becomes [table id=1 cellspacing="0" /] for example.

    If you post the URL of your site (a page with a table), I'll check it to see if there something else that needs to be done.

    Best wishes,
    Tobias

  7. kkellish
    Member
    Posted 4 years ago #

    I tried changing the table id incl but still no fix. I threw it live quick for you to see...I was kind of working on it in the background until I could get this fixed. here's the link: http://stupidworld.net/?page_id=272

  8. TobiasBg
    Member
    Posted 4 years ago #

    Hi,

    ok, I looked at your site.
    Your theme's style.css includes a small line that is adding the border.

    But the good news is that we can override it easily :-)
    Just add the following to the CSS of WP-Table Reloaded in the Plugin Options:

    .wp-table-reloaded tr {
    border:none!important;
    }

    That should remove the border :-)

    Best wishes,
    Tobias

  9. kkellish
    Member
    Posted 4 years ago #

    That worked, borders are now gone. I moved it to the real site but now for some reason it looks fine in IE, but in FF the rows don't line up. The picture sits above the row in the second column. I'd show the url but my client doesn't allow it public until approval. I was thinking it was a padding issue, that didn't change, changed the sizes of the pics, that didn't fix it. Is there a way to change the table size to automicatically switch depending on the persons screen size? and/or format the table itself to hold smaller? It must just be too wide to fit in their template. I have tried adding:

    table.wp-table-reloaded-id-3 .column-2
    {
    	width: 150px;
    }

    but it didn't do the trick. I usually have IE issues not FF so this is a first for me. any ideas?

  10. TobiasBg
    Member
    Posted 4 years ago #

    Hi,

    I don't know where this comes from, probably some CSS inconsistency.

    Can you email me the URL to the page? Then it is not public, but I might be able to help you? (My address is the file wp-table-reloaded.php in the plugin folder).

    Best wishes,
    Tobias

  11. kkellish
    Member
    Posted 4 years ago #

    email sent. Thank you so much for still dealling with me :)

  12. ironman27
    Member
    Posted 4 years ago #

    Can anyone help me align my picture to the right? I have been able to remove the borders but I have been unsuccessful at moving my picture to the right with descriptive words surrounding the picture. Either it splits a sentence apart or it has to be separated by leaving it under the picture. This is the site:

    This is the html code I have for now: <rel="lightbox[pics1] <img src="http://godliving.com/wp-content/uploads/2010/05/Me121.jpg"> <p><img class="attachment wp-att-112 alignright" alt="" width="76" height="82"/>

    Can you tell me what I am missing?

  13. TobiasBg
    Member
    Posted 4 years ago #

    Hi,

    try this for the image:

    <img src="http://godliving.com/wp-content/uploads/2010/05/Me121.jpg" alt="me" style="float:right;margin:5px;" />

    Remove the other <img> (which won't show one, because no "src" is specified).
    Then, in your text, there's a line break after "I am", which you probably want to remove.

    Best wishes,
    Tobias

    P.S.: For future questions, please open a new topic here in the forums, instead of appending your question to old ones. Thanks.

  14. ironman27
    Member
    Posted 4 years ago #

    Thanks so much for the advice! I greatly appreciate it. Alswiedersehen!

  15. kellyhicks
    Member
    Posted 4 years ago #

    I tried both fixes to remove the border on my table and neither worked... could you help? my site is kellyhicksdesign.com/portfolio

  16. TobiasBg
    Member
    Posted 4 years ago #

    Hi,

    what you are seeing is actually not a border but the table's background color. To remove that, just add this to the CSS:

    .wp-table-reloaded {
      background-color: #ffffff!important;
    }

    Best wishes,
    Tobias

  17. kellyhicks
    Member
    Posted 4 years ago #

    Sweet that worked great! Thanks so much!!

Topic Closed

This topic has been closed to new replies.

About this Topic