WordPress.org

Ready to get started?Download WordPress

Forums

WP SuperCache Not Cacheing (18 posts)

  1. I installed the WP-Super Cache plugin last night and it doesn't seem to be caching anything. I've made the correct changes to my WP-Config file and I've also checked the .htaccess file and the rewrite instructions appear correct in both .htaccess files. As I browse through my blog, then click on regenerate cache statistics, nothing is showing up. Any idea what the problem could be? And yes, I have enabled both WP-Cache and SuperCache.

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. Monika
    Member
    Posted 6 years ago #

    since the new version there are now changes at wp-config necessary

    regenerate cache statistics delete all cached file - so I'll found out ;)

    regards
    Monika

  3. Donncha O Caoimh
    Member
    Posted 6 years ago #

    jeffr0 - were you browsing while logged in? Pages are only cached by the super cache if you're logged out, and don't have any cookies for your blog. You should have seen the old style WP-Cache2 html comments on your page at the very least.

  4. dnorman
    Member
    Posted 6 years ago #

    I'm seeing this too - logged out, and all cookies from my domain are deleted (and testing from a browser I don't normally use). Pages appear to be generated fresh each time (Dynamic page served in 1.3 seconds, etc...) with no mention of caching in the outputted HTML. This is with the latest WP 2.3.2, and WP-SuperCache 0.5.4

    any ideas? the performance of Dreamhost sucks badly enough to make SuperCache a necessity.

  5. Nalco
    Member
    Posted 6 years ago #

    Funny, I have never had problems figuring things out when it comes to wordpress. I would scoff at the endless posts I read about people not getting this to work when the instructions are so plain and easy to follow.

    I couldn't get this thing to serve cached paged either. I messed with it for about an hour, and gave up.

    The rewrite rules are in my htaccess, I edited my wp-config file, WordPress is not in a subdomain and everything was enabled. At one point I threw security to the wind, and chmoded to 777, and nothing. WP-cache would cache files fine, supercache cached 2, but everytime it would load a dynamic page, though right below the Dynamic page served in .0075 seconds, it would have a supercache gz line.

    I tried this on both Firefox and IE both completely logged out and all cookies deleted, no cache page served.

    The only way I could get a cache page served message, was when I disabled the plugin and left the "define" rule in my wp-config file.

    I might try later, but I am thoroughly disgusted with myself right now. I know it works, I just cant figure out how.

    Version I tried was 0.5.4

  6. Well, I've checked and then rechecked everything and I still can't get the plugin to cache anything what so ever. I've upgraded the plugin and have checked my htaccess file and it matches the one you provide in the readme file. Not sure what else to do besides contact my indian tribe and beat some drums around a fire pit hoping magic will make this thing work.

    I've even disabled super cache so WP-Cache can work on it's own and that doesn't even work.

    At one time, I did have WP-Cache installed and that did cache things. When I did the super cache install, I deleted all the remnant files from WP-Cache.

  7. ObsessiO
    Member
    Posted 6 years ago #

    I did everything. I think correctly setup it, but the same thing. But the same issue.

    It doesn't seem to be caching anything.

    any suggestions? what I will use for caching or should I use cache plug-in?

  8. Man, I would of used the wp-cache plugin but there wasn't anyway to keep the comments section from being cached. I'm still messing around and I can't get this plugin to work.

  9. ryanmclaughlin
    Member
    Posted 6 years ago #

    jeffr0 do you happen to use 1and1 for your hosting?

    I have the same problem as you, where no matter what I do, I can't get the redirect to the SuperCache files to work.

    I've narrowed it down to this line in the htaccess file:

    RewriteRule ^(.*) /wp-content/cache/supercache/%{HTTP_HOST}/$1index.html [L]

    (line break added by this post)

    And it doesn't seem to be working correctly with my host.

  10. Nope, I'm using ANHosting. Not sure if I'm having the same issue as you or not, but this thing doesn't want to cache anything.

  11. aetchells
    Member
    Posted 6 years ago #

    I am seeing a situation where caching is working everywhere but on my homepage. Of course that's what I would like to cache most.

    I assume this has something to do with it being http://mydomain.com/
    If I go to http:/mydomain.com/index.php that page caches as expected.

    Is there a way around this?

  12. Dexterp37
    Member
    Posted 6 years ago #

    I'm having your very same problem :| WP Super Cache isn't caching at all on my web site (a2p.it), even if I get a lot of page views :|

  13. sojweb
    Member
    Posted 6 years ago #

    I had this problem, too, but was able to get it working again. You've probably already tried this, but I deactivated the plugin, removed it from the plugins directory, and deleted: advanced-cache.php, the cache directory, and wp-cache-config.php from the wp-content directory. Then I just reinstalled the plugin. Hope that helps.

  14. Dexterp37
    Member
    Posted 6 years ago #

    That's strange: I did that, and it still wasn't working. Then I opened wp-cache-config.php file and changed $sem_id value to a random one... the plugin panel now reports WP-Cache is caching some pages. I guess that's better than before, but still ... but still Superacache isn't caching. Is this simply a coincidence?

  15. s2j
    Member
    Posted 6 years ago #

    It looks like this is more than just an isolated event. It is my belief that what we actually have here is a plugin that needs to be properly tested before being used in real-world scenarios.

  16. SpeKopuZ
    Member
    Posted 6 years ago #

    The problem for me it's a little strange... the plugin panel reports that WP-cache and Super cache are caching some pages but when I see the source code on the pages i can't see the comments at the very last. Domebody having the same problem?

  17. Donncha O Caoimh
    Member
    Posted 6 years ago #

    s2j - it works fine for far more people than have problems with it.

  18. ryanmclaughlin
    Member
    Posted 6 years ago #

    Just an update, I switched hosts away from 1and1 and now to a dedicated server, and this plugin has been working terrifically.

Topic Closed

This topic has been closed to new replies.

About this Topic