WordPress.org

Ready to get started?Download WordPress

Forums

WP-Supercache Blocks NexGen Gallery (4 posts)

  1. BlakkJakk
    Member
    Posted 6 years ago #

    Recently I uninstalled WP-Cache and installed WP-Supercache because I read good things about it and it is being acitvely supported. I ran into two problems both as it fails to work with the NexGen Gallery.

    1) At first I started to get CPU exceed problems once a day. I didn't become aware of it until it happened to me. After viewing the logs a week later. What I finally figured out was that Supercache was not caching my NexGen Gallery. So once enough hits were happening at once, CPU Exceed and site gets turned off by Bluehost for 2-5 minutes.

    2. Tried 1 Blogger Cache, the other currently supported fork after WP-Cache. Started to get CPU exceeds as much as three times a day but did cache my gallery.

    3. Uninstalled and tried Supercache again. Now its blocks my gallery. I can get to the Gallery front page but when I tried to click on album it just stays on the gallery page.

    4. Uninstalled Supercache and re-installed WP-Cache and things seem to be fine for now.

    Anyideas as two why Supercache does not play well with NexGen Gallery?

  2. BlakkJakk
    Member
    Posted 6 years ago #

    I am hoping this is something that can be fixed with a mod rewrite rule but I have no clue where to start. I tried the newest versions of Supercache and NexGen, did a clean install of Supercache but it still blocks the subpages with the NexGen Gallery.

    When I select disable Supercahce but keep WP-Cache running it works fine. But the minute I enable both options, it blocks all of the sub gallery pages.

    Any ideas?

  3. BlakkJakk
    Member
    Posted 6 years ago #

    I still have not found a solution for this. Right now I am running Supercache with the Supercache function disable (just WP-Cache enabled), ironic, no?

    Can anyone point in the right direction?

  4. BlakkJakk
    Member
    Posted 5 years ago #

    Just a follow up. I solved this problem.

    Not sure exactly what was wrong but I did find that after I moved servers, when I went to do a fresh install with import on my old content, I rebuilt the gallery using the permlink option from the start and used the internal page building options. Now Supercache plays nicely with it and no problems.

    Of course a nicer permalink structure (based on cats or tags would be nice) but can't have it all. ;)

Topic Closed

This topic has been closed to new replies.

About this Topic