WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
WP Super Cache & Woocommerce cache issue (7 posts)

  1. opjacht
    Member
    Posted 1 year ago #

    Hi,

    I really can't seem to fix the following issue. I have the following set-up:
    - WP 3.5.1
    - Woocommerce 2.0.6
    - WP Super Cache

    I use the dynamic cart functionality in the header of the page (please check: http://mijncosmetica.nl). When accessing the page you see that the cart will show cached info for 1 or 2 seconds. Info of cached information.

    I'm seeking for a solution to disable this section of the page from beeing cashed. I also used the info shared on Woocommerce (http://docs.woothemes.com/document/configuring-caching-plugins/)

    Thanks in advance for you time and knowledge!

    Regards,

    Jeroen

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. opjacht
    Member
    Posted 1 year ago #

    Mentioned link must be: http://mijncosmetica.nl

  3. opjacht
    Member
    Posted 1 year ago #

    Hi,

    After some testing I actually found what is causing this problem but I don't know how to fix it. It is still not resolved.

    What is causing this
    When I empty the cache all is working fine. I now go to the store and add a product page and add that specific product into the shopping cart. The shopping cart in the header is know showing x item and € x. When I now go to a page that not yet has had any traffic the cart information is being cached along whit the other content. When going to that specific page in an new session the cached cart info will briefly been shown.

    What can I do to resolve this?
    I want to prevent the cart area in the header from being cached. But how? Can anybody help excluding the header cart from cache (definitely preferred option).

    Thanks in advance,

    Jeroen

  4. jellio
    Member
    Posted 1 year ago #

    Hi,

    In WP Super cache, under the advanced tab, click the check box for

    Late init. Display cached files after WordPress has loaded. Most useful in legacy mode.

    Seemed to work for me

  5. opjacht
    Member
    Posted 1 year ago #

    Hi,

    I think any solution to resolve this is by rejecting the following cookie for page cache: wc_session_cookie

    Is there a possibility to reject cookies in WP Super cache?

    Thanks in advance!

    Jeroen

  6. vipete
    Member
    Posted 1 year ago #

    Try this:

    Go to your dashboard and click on Database Cache in the performance settings.

    In the ignored query stems field, make a new line and add:

    _wc_session_

  7. toniodobrasil
    Member
    Posted 8 months ago #

    @opjacht
    Hi,
    HAve you figured out your issues?
    If yes, I'm quite interested in knowing your solution ;-)
    Thanks in advance
    regards

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic