WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
WP Super Cache with CDN use causes problem on Mac (10 posts)

  1. flxkid
    Member
    Posted 3 years ago #

    So I'm having a very odd problem. My site is served just fine to Windows PCs. When the same site is served to a Mac none of the CSS files seem to be loading. If I turn off WP-Super-Cache it is served to either OS fine. The problem seems to be exclusive to Mac's. I can serve the files to an iPad perfectly. Note that I'm using Amazon S3 in WP-Super-Cache.

    Any clues?

    OLIVER

  2. Donncha O Caoimh
    Member
    Plugin Author

    Posted 3 years ago #

    Something to do with how your css files are served to Macs, obviously. Someone else had this issue and posted on this forum about it. I think it was the way he uploaded the files to S3.

  3. Pete_PT
    Member
    Posted 3 years ago #

    Any more help on this, I cannot seem to find another post similar - am getting the same problem.

  4. Pete_PT
    Member
    Posted 3 years ago #

    Perhaps I should be more specific.

    I recently activated WP Super Cache on my site - http://www.peteluxford.com After some tweaking I got it working for NOn -loged in users and it experienced a nice boost in page load times.

    I then investigated using Amazon s3 as a CDN.

    Using CDN Sync plugin, I pulled all the necessary files onto the Amazon server, they all showed up on the Amazon manager.

    My site loaded perfectly from a PC, but on my Mac it was only the raw html text with no styling at all.

    I also had the same problem accessing it by mobile phone.

    All the files are there, and the server is serving them properly as I can prove from the PC, so any ideas what the problem is?

  5. Donncha O Caoimh
    Member
    Plugin Author

    Posted 3 years ago #

    I recall it was something about making sure the files uploaded were binary or text. I don't use S3 so I don't know. Have you tried loading the css file by loading it manually in your browser? Checked the content type on it?

  6. Inposure
    Member
    Posted 3 years ago #

    Works fine on my Mac (Safari, Chrome, Firefox). Clear your cache and see if that helps.

  7. Pete_PT
    Member
    Posted 3 years ago #

    Thanks for the replies. liangzai. Could you try again please, as I may have disabled it by the time you looked at it.

    Many thanks

  8. Inposure
    Member
    Posted 3 years ago #

    curl -I "http://luxford-pt-1.s3-website-eu-west-1.amazonaws.com/wp-content/themes/arras/js/superfish/superfish.js"
    HTTP/1.1 404 Not Found
    x-amz-error-code: NoSuchWebsiteConfiguration
    x-amz-error-message: The specified bucket does not have a website configuration
    x-amz-error-detail-BucketName: luxford-pt-1
    x-amz-request-id: 76D0504B142C188E
    x-amz-id-2: yL9TVWmtk6PncutS/Jb9bh0tDoqWBTLBesSze4JHKiJNy7XvXy73RpZtT4QXnbVM
    Transfer-Encoding: chunked
    Date: Fri, 04 Mar 2011 23:20:30 GMT
    Server: AmazonS3

    This means that your CDN configuration is wrong. There is no such website configuration, and therefore no files to get.

    I guess your PC browsers used cached versions.

  9. Pete_PT
    Member
    Posted 3 years ago #

    Ahh thank you.

    There is an option on S3 to give a bucket website configuration. I have selected this, but then it wants an index document.

    I put in index.html as that is what supercache creates. The site now loads, but a lot of images are missing.

    Wonder if its the image resizing that goes on. http://www.peteluxford.com

  10. Pete_PT
    Member
    Posted 3 years ago #

    Thank you for your help. Not all the uploads folder had synced. Force sync has sorted it. Also drew my attnetion to how many files are in there that are no longer used. Delete time.

    Once again, you have been most kind, and your help is appreciated.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic