WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache: Warning! wp-cron.php not found! (3 posts)

  1. padreed123
    Member
    Posted 2 years ago #

    I get "Warning! wp-cron.php not found!" when setting up WP Super Cache. After reading into it,it says:

    Garbage collection of old cache files won't work if WordPress can't find wp-cron.php. If your hostname resolves to 127.0.0.1 it could be preventing the garbage collection from working. Check your access_logs for wp-cron.php entries. Do they return a 404 (file not found) or 200 code? If it's 404 or you don't see wp-cron.php anywhere WordPress may be looking for that script in the wrong place. You should speak to your server administator to correct this or edit /etc/hosts on Unix servers and remove the following line. Your hostname must resolve to the external IP address other servers on the network/Internet use. See http://yoast.com/wp-cron-issues/ for more. A line like "127.0.0.1 localhost localhost.localdomain" is ok.

    127.0.0.1 myhostname.com

    The problem is that I host from home and I have my router pointing all http://www.mysite.com requests to the ip of my servers local address so I can see/test my site within my locsal network. I use a tomsato router that has dnsmasq in the options.

    dnsmasq options I added:

    address=/mysite.com/192.168.2.3
    address=/www.mysite.com/192.168.2.3

    Everything works great except super cache. So what should I do? Find another cascheing method? or find a better way to redirect my local traffic?

  2. okay456okay
    Member
    Posted 1 year ago #

    OK , I encountered the same problem with you. My website is 我爱打扮网 . I fixed it by adding an line into /etc/hosts file, just add a dns record into this file, like:
    127.0.0.1 your.domain.com

    Hope this can help you.

  3. padreed123
    Member
    Posted 1 year ago #

    Thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic