WordPress.org

Ready to get started?Download WordPress

Forums

iThemes Security (formerly Better WP Security)
[resolved] Better WP Security incompatible with WP Super Cache (22 posts)

  1. maximan
    Member
    Posted 2 years ago #

    I did a clean WP install (3.4.1), installed WP Super Cache (1.1) and Bulletproof Security (.47.2). Caching works normally. I then installed and activated Better WP Security (3.4.2). Caching stops. Looking at WP Super Cache list of caches files shows a cached page for a brief second then no cached pages. When I deactivate Better WP Security caching resumes. Clearly there's incompatibility between WP Super Cache and Better WP Security.

    http://wordpress.org/extend/plugins/better-wp-security/

  2. lth8284
    Member
    Posted 2 years ago #

    yeah me too. i'm not sure but after i install Better WP Security and setup, my website is offline. i dont understand! i can't login admin page!

  3. maximan
    Member
    Posted 2 years ago #

    Try using an FTP client and go to your site, navigate to wp-contents/plugins and delete the Better WP Security directory. Hopefully that will allow you access.

  4. maximan
    Member
    Posted 2 years ago #

    I see there are similar reports on the WP Super Cache support forum. I posted a cross link there to this forum:

    http://wordpress.org/support/topic/plugin-wp-super-cache-wp-super-cache-and-better-wp-security-conflict?replies=2#post-3065293

  5. Thanks for the reports. I will fix the super cache issue in the next version.

  6. maximan
    Member
    Posted 2 years ago #

    Just installed update 3.4.3 and caching works normally. Thanks for the fast fix.

  7. maximan
    Member
    Posted 2 years ago #

    I guess I spoke too soon. Caching sorta' works, for a while, then cached filed are removed from the caching list. I've deactivated BWPS and now back to normal.

  8. maximan
    Member
    Posted 2 years ago #

    Well, I tweaked WP Super Cache setting and updated, again, Mod_Rewrite Rules and now it seems the two plugins are playing nicely together. Sorry for the misinformation earlier!

  9. ryansales
    Member
    Posted 2 years ago #

    I'm using PHP and it's still not working. :(

  10. phirefly
    Member
    Posted 2 years ago #

    Im having similar problems & not sure it is related - I have disabled BWPS, however caching still does not work :(

  11. ryansales
    Member
    Posted 2 years ago #

    I found out that clearing the logs in BWPS dumps the supercache files. So that is one thing that is affecting things.

  12. Thanks @ryan. I will fix that. I must say however I don't know what you mean by "I'm using PHP and it's still not working."

    @phirefly that should be a different issue. The problem others are experiencing is because BWPS will clear the caches on a number of situations. In the case of Super Cache I was far too aggressive in the clearing.

  13. maximan
    Member
    Posted 2 years ago #

    Why would BWPS be clearing cached files? Surely that is outside the scope of protecting a site. Because my site is primarily "look up" and not interactive I have cache timeout to one day. I couldn't figure why cache would empty after one day so I deactivated BWPS and that stopped the problem. I don't think BWPS should be overriding cache user settings.

  14. @maximan...

    ...There are a few reasons. For one, if cached and a plugin conflict is present the site owner may not notice it as quickly if the page is cached after an options save which can cause further headache later. In addition, with database and opcode caching features such as lockouts and awaymode restrictions can actually be cached making even their manual removal difficult to detect until the cache clears. Therefor, on an options save the plugin will clear all caches and for certain other situations opcode and query caching is cleared.

  15. joneiseman
    Member
    Posted 2 years ago #

    I have the following option checked in WP Super Cache:
    Don’t cache pages for known users. (Recommended)
    Therefore, I will see the option changes right away. So, it's not really necessary for Better WP Security to clear the cache when changing an option. Can you add an option to control the cache clearing?

  16. Let me see if I can detect that state @joneiseman. That should make it easier.

  17. ryansales
    Member
    Posted 2 years ago #

    @Bit51 - disregard. I was using PHP mode for my Super Cache (not Mod_rewrite, and was having problems with my cache. I believed it may have been an issue with PHP mode for super cache. (as maximan seemed to be having success with Mod_rewrite). However, at the same time, I was also doing a lot of investigating with some site updates etc, and was regularly clearing my logs in BWPS, which was in fact what was causing my Super Cache issues.

    There are a lot of threads with this cross issue between Super Cache and BWPS, so my apologies, as we were kind of troubleshooting the issues and talking about two plugins.

  18. Thanks Ryan.

  19. gr8web
    Member
    Posted 1 year ago #

    @Bit51 - I had a similar problem with my site becoming inaccessible after installing your plugin an then emptying page cache. However, I'm using W3 Total Cache. Does your latest bug fix not address any compatibility issues with this caching plugin? Am I better off switching to Super Cache at this point?

    Thanks.

  20. robotcake
    Member
    Posted 1 year ago #

    Hello, may I ask if now better wp security is camatible with wp super cache yet? I see:

    You do not have sufficient permissions to access this page.

    after I cleared the cache is the super cache

  21. tubo
    Member
    Posted 1 year ago #

    @Bit51 Can I use WP Super Cache with BWPS now? or how can we get faster websites with BWPS enabled? do you have any recommendations about this important need?

    Thanks in advance :-)

  22. Steve Powell
    Member
    Posted 1 year ago #

    WP 3.5.1
    WP Super Cache 1.3.2 in (PHP mode) (have "do not cache for known users" enabled)
    Better WP Security 3.5.3

    This combination caused a whitescreen on /wp-admin/admin.php?page=better-wp-security ON INITIAL LOAD until we went into WP Super Cache and cleared the cache completely.

    The error in the log was

    PHP Fatal error: Maximum function nesting level of '100' reached, aborting! in /var/www/vhosts/domain.com/httpdocs/wp-includes/formatting.php on line 1381

    Would it be possible to watch for this in this plugin and warn users to clear their cache before trying to use this the first time?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic