WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache sometimes ignites a blank Home Page! Need to restart Apache (29 posts)

  1. camillomiller
    Member
    Posted 5 years ago #

    Hi all,

    here's my problem:

    with Super Cache enabled, the home page of my site sometimes gets completely blank. I can't find what triggers this behavior, it may happen twice a day, sometimes more than that. When this thing happens, the rest of the blog is loading super correctly and in a very fast way. The problem is limited to the home page.

    If I turn OFF Super Cache (not disabling the plugin, just selecting OFF from the panel) the home page goes a little nuts. It loads again but it stops before loading the sidebars and the footer.

    Here's the way I solve the problem (but it doesn't prevent the problem from happening again, obviously):

    I log into my server administration panel (The site is on a dedicated server) and I restart the Apache webserver. After that, it's all back to normal.

    Sometimes when I restart just after discovering the blank page, with Wp-SuperCache still ON, the Apache restart isn't enough and the white page persists.

    In that case i Turn OFF Wp Super Cache (the home page goes nuts) I restart Apache, (the site goes back to normal) and then I turn Wp Super Cache ON again.

    So, someone has a hint of what's going on here?

  2. marcrue
    Member
    Posted 5 years ago #

    Hi camillomiller,

    I have the same problem, but to temporally solve the problem just clear the cache and the homepage will be ok.

    Still nobody has the answer to this issue, but there are aldready some topics: topic 1, topic 2. About this.

    Hope we'll a fix soon.

  3. ggrapes
    Member
    Posted 4 years ago #

    I had a similar problem recently. Every single page of my blog turned up blank when I tried to access it, even wp-login and admin so I had no way of getting to the dashboard. I hadn't touched to blog for about a week and I didn't do any upgrades recently so this came totally by surprise. It took me an hour to find the cause which was wp-cache. I had to use ftp to deleted that plugin and the cache, everything went back to normal afterwards.

  4. Donncha O Caoimh
    Member
    Posted 4 years ago #

    Was your blog hacked? Did anything show in your error_log?

  5. arekwolski
    Member
    Posted 4 years ago #

    I just had the same issue - blank page everywhere (additionally no www. enforcing), had to restart Apache. Everything works fine now.

    I'm using WP2.9.1. with a lot of plugins and Apache/2.2.9 (Debian) PHP/5.2.6-1+lenny3

    I turned my php error logging "On", so if anything shows up I'll let you know next time. I get a feeling it'll happen again.

  6. nmjackson
    Member
    Posted 4 years ago #

    I've been having this problem for a while now. And our site was heavily Digg'd yeserday, nearly 100k pageviews in a few hours, I had foregone installing supercache because it was serving blank pages daily, multiple times per day. But because of the spike we needed it, once again it only took like 3-4 hours for blank pages to appear. Makes me sad we can't seem to work it out or figure it out. Any resolution would be great! It worked this summer, but now, no dice... ;(

  7. arekwolski
    Member
    Posted 4 years ago #

    dear diary,

    today blank page bug strikes again, no dashboard access
    other sites on the server work fine
    can't find anything in the logs
    cant sleep ;)

    this time instead of restarting apache right away I cleared active_plugins field in the database wp_options table - it disabled all plugins so I can enable them back again - site works fine now

    for now I'm turning /etc/init.d/apache reload every 10 minutes - can't think of anything else to do

    will keep you posted on php.log contents

  8. arekwolski
    Member
    Posted 4 years ago #

    dear diary,

    before I start reloading apache from cron every 10 minutes I decided to try what he did: http://www.shoutmeloud.com/wordpress-blank-page-super-cache-plugin-problem-solved.html

    since I was migrating wordpress from a subdomain test site to my root domain, maybe the path change affected wp super cache plugin in some way...

    so I uninstalled the plugin and deleted all its traces, then installed it again and turned on the logging option (didn't see it there before)

    current desperation level = Log level 5
    disabled e-mail notifications after 300 messages in 3 minutes
    enabled file logging

    will keep you posted

  9. arekwolski
    Member
    Posted 4 years ago #

    dear diary,

    today blank page bug strikes yet again, same thing - had to restart apache - the last log message before going blank:
    Writing meta file: /www/wp-cache-xxxxxxxxxxxxxxx.meta

    from time to time I also get another fatal "error establishing a database connection" message for no apparent reason - have to restart mysql

    bugs come in pairs?

  10. Donncha O Caoimh
    Member
    Posted 4 years ago #

    They're not related. Is your server running out of disk space?

  11. Donncha O Caoimh
    Member
    Posted 4 years ago #

    arekwolski - try the development version on the download page. That may help, especially if you have "coarse file locking" enabled (which I don't advise any more)

  12. arekwolski
    Member
    Posted 4 years ago #

    donncha, I have 67G of disk space free and "Coarse file locking" is disabled

    I'll try the development version

  13. arekwolski
    Member
    Posted 4 years ago #

    donncha, I just unintalled the 0.9.8 version according to your readme-instructions and and installed the "development version" downloaded from the bottom of this page http://wordpress.org/extend/plugins/wp-super-cache/download/ - everything seems to work well so far

    in the readme.txt I can see Changelog info for 0.9.9 version and in the Changelog.txt the last modification is "2010-01-29 10:40 donncha" but WordPress installed-plugins-list says it's a 0.9.8 version - is that all right? (I'm a bit paranoid, sorry)

    in the meantime I'd like to express how much we appreciate your work - thank you so much

  14. Donncha O Caoimh
    Member
    Posted 4 years ago #

    arekwolski - that's fine. I can't change the version info until the new version is ready. I think it's 99.99999% there but I'm going to wait until next week before putting it out there.

    Thanks for trying the development version!

  15. arekwolski
    Member
    Posted 4 years ago #

    unfortunately the problem persists

    here you can see blankpage-periods followed by apache restarts from cron repeating throughout the day: http://i48.tinypic.com/2llzwh4.png

    i switched wp-super-cache half-on, we'll see how it goes from here

  16. barthulley
    Member
    Posted 4 years ago #

    wow, what a waste of time - installed the plugin then lost my site! Deleting the wp cache entry in the config file brought it back up.

  17. Max Chirkov
    Member
    Posted 4 years ago #

    Upgraded WP yesterday to 2.9.1 and WP Super Cache to 0.9.9 - was getting blank pages on everything. Turned the plugin OFF without deactivating and everything seemed to start working. Found this thread and decided to keep the plugin off for a bit until the issue is resolved. But when I came to the office this morning I was greatly disappointed to find my site loading blank pages. Only home page was loading fine - the rest were blank. Restarted Apache - no go. I de-activated the plugin - no go. Re-activated it again without turning it on - the pages re-appeared. Nothing in the httpd error log.

    Any ideas on what's going on? Should I clear cache tables?

  18. Donncha O Caoimh
    Member
    Posted 4 years ago #

    max - I don't know what's going on there unfortunately. Can you try debug it with the functions in the admin page? Turn on caching again then.

    You should see if log the cache serving process. Maybe there's something in there..

  19. Max Chirkov
    Member
    Posted 4 years ago #

    Thanks for the quick reply, Donncha.

    I set the debug to 4 and here is what I have (in ascending order):
    Output buffer callback
    404 file not found not cached
    Created output buffer
    Created output buffer
    Output buffer callback
    Output buffer callback
    Output buffer callback
    Created output buffer
    404 file not found not cached
    Buffer is blank. Output buffer may have been corrupted by another plugin or this is a redirected URL. Look for text 'ob_start' in the files of your plugins directory.
    Created output buffer
    Output buffer callback
    Output buffer callback
    Created output buffer
    No closing html tag. Not caching.
    Buffer is blank. Output buffer may have been corrupted by another plugin or this is a redirected URL. Look for text 'ob_start' in the files of your plugins directory.
    ...

    I noticed it mentioned that URL might be redirected. Does it matter if the root directory of the site is actually a symlink? Or this is irrelevant?

    Thank you!

  20. Donncha O Caoimh
    Member
    Posted 4 years ago #

    The symlink shouldn't matter, the redirect is a web redirect. A 301 or 302 usually.

    Have you looked for the ob_start function in your plugins directory?

    Are there files being created in wp-content/supercache/HOSTNAME/ ... ? Are they 0 byte/empty files? That might explain why you're seeing blank pages. It shouldn't happen because of existing checks but perhaps I need to check for that.

  21. bask43
    Member
    Posted 4 years ago #

    I had the same experience
    So I left debugging logs.

    12:43:06 / Cookie detected: comment_author_e118a5144ffaddbfed4914cc1c278eea
    12:43:06 / Cookie detected: comment_author_email_e118a5144ffaddbfed4914cc1c278eea
    12:43:06 / Cookie detected: wordpress_test_cookie
    12:43:06 / Cookie detected: wordpress_logged_in_e118a5144ffaddbfed4914cc1c278eea
    12:43:06 / No wp-cache file exists. Must generate a new one.
    12:43:06 / Cookie detected: comment_author_e118a5144ffaddbfed4914cc1c278eea
    12:43:06 / Cookie detected: comment_author_email_e118a5144ffaddbfed4914cc1c278eea
    12:43:06 / Cookie detected: wordpress_test_cookie
    12:43:06 / Cookie detected: wordpress_logged_in_e118a5144ffaddbfed4914cc1c278eea
    12:43:06 / In WP Cache Phase 2
    21:43:06 / Setting up WordPress actions
    21:43:06 / Created output buffer
    21:43:06 / Cookie detected: comment_author_e118a5144ffaddbfed4914cc1c278eea
    21:43:06 / Cookie detected: comment_author_email_e118a5144ffaddbfed4914cc1c278eea
    21:43:06 / Cookie detected: wordpress_test_cookie
    21:43:06 / Cookie detected: wordpress_logged_in_e118a5144ffaddbfed4914cc1c278eea
    21:43:06 / scheduled wp_cache_gc for 10 seconds time.
    21:43:10 / Output buffer callback
    21:43:10 / Output buffer callback
    12:43:10 /favicon.ico Cookie detected: comment_author_e118a5144ffaddbfed4914cc1c278eea
    12:43:10 /favicon.ico Cookie detected: comment_author_email_e118a5144ffaddbfed4914cc1c278eea
    12:43:10 /favicon.ico Cookie detected: wordpress_test_cookie
    12:43:10 /favicon.ico Cookie detected: wordpress_logged_in_e118a5144ffaddbfed4914cc1c278eea
    12:43:10 /favicon.ico No wp-cache file exists. Must generate a new one.
    12:43:10 /favicon.ico Cookie detected: comment_author_e118a5144ffaddbfed4914cc1c278eea
    12:43:10 /favicon.ico Cookie detected: comment_author_email_e118a5144ffaddbfed4914cc1c278eea
    12:43:10 /favicon.ico Cookie detected: wordpress_test_cookie
    12:43:10 /favicon.ico Cookie detected: wordpress_logged_in_e118a5144ffaddbfed4914cc1c278eea
    12:43:10 /favicon.ico In WP Cache Phase 2
    21:43:10 /favicon.ico Setting up WordPress actions
    21:43:10 /favicon.ico Created output buffer
    21:43:10 /favicon.ico Cookie detected: comment_author_e118a5144ffaddbfed4914cc1c278eea
    21:43:10 /favicon.ico Cookie detected: comment_author_email_e118a5144ffaddbfed4914cc1c278eea
    21:43:10 /favicon.ico Cookie detected: wordpress_test_cookie
    21:43:10 /favicon.ico Cookie detected: wordpress_logged_in_e118a5144ffaddbfed4914cc1c278eea
    21:43:13 /favicon.ico Output buffer callback
    21:43:13 /favicon.ico 404 file not found not cached

  22. Donncha O Caoimh
    Member
    Posted 4 years ago #

    bask43 - the last message for / is "Output buffer callback" - do you have one of the "do not cache" checkboxes enabled on the admin page?
    Do you have coarse file locking enabled?

  23. Max Chirkov
    Member
    Posted 4 years ago #

    Doncha,

    I don't have "do not cache" option enabled. Also, there are no files in the cache folder at all (the folder is writable). And I have 13 ob_start() functions in different plugins.

  24. Donncha O Caoimh
    Member
    Posted 4 years ago #

    Unfortunately it could be one of those plugins that's causing the problem. You could either disable them one by one and test when it works or look up the ob_start command in the php manual (use Google) and try to fix them yourself.

    You could also edit wp-cache-phase2.php and find the "Output buffer callback" message and add more debugging around there and in the functions called from there to discover where the plugin is stopping.

  25. grantp
    Member
    Posted 4 years ago #

    I'm having a similar problem and it appears to have something to do with wp-cache-base.php in the supercache directory. I've been adding echos to various parts of the code to see how far everything executes, and nothing seems to happen after this line in wp-cache-phase1.php:
    include( WPCACHEHOME . 'wp-cache-base.php');

    wp-cache-base.php just declares a $known_headers array and the CacheMeta class if it doesn't already exist. That's it. Putting echos in this file seemed to fix the blank page problem for a while (!!!) so it's hard to tell how this file is affecting things, if at all. Strange. Once a page was loaded properly after adding an echo, the file could be set back exactly as it was and everything worked fine. Again, for a while. I'm waiting for this to happen again.

  26. Donncha O Caoimh
    Member
    Posted 4 years ago #

    grantp - are you using xcache, APC, Eaccelerator or another PHP compiler/optimizer? I've seen problems like this happen when the compiled PHP bytecode just refuses to work, sometimes. It is very hard to debug.

  27. cfclol
    Member
    Posted 4 years ago #

    Same issue here. Occassionally a blank home page will be served up. Refreshing fixes but am now getting crawl errors from googleBot when a page it accesses is blank (I assume) I have deactivated the plugin for now and that has fixed the issue.

  28. coplan
    Member
    Posted 4 years ago #

    I'm having the same issue, but slightly different. I'll occasionally get the white pages thing, but if I do nothing...the pages come back in about 4-5 minutes. It seems to be in correlation to the garbage collection and expired files timeframe. I'll keep track, but every time the pages come back, it seems as though garbage collection and expired files were just cleaned a minute or two before. For now, I have set expiration to 86400 (a day). We'll see how that works.

  29. Donncha O Caoimh
    Member
    Posted 4 years ago #

    Coplan - is your site running on a slow disk like NFS? It shouldn't matter because files are written to temporary files first, then renamed to the final filename. Should be super fast.

    On the other hand, if it's something to do with cache cleanup, are you seeing these files as a logged in user or anonymous user?

Topic Closed

This topic has been closed to new replies.

About this Topic