WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
WP Super Cache RSS Feed Content Type Issue (5 posts)

  1. dvmorris
    Member
    Posted 3 years ago #

    I'm having trouble with RSS feeds while running WP Super Cache on WP 3.0.1. It seems that with an empty cache folder, WP Super Cache creates a cached copy of the RSS feed being requested and serves up the file with a different Content Type. When viewing a fresh (yet to be cached) RSS feed in Firefox, it displays with the default XML file style and says this at the top of the page:

    "This XML file does not appear to have any style
    information associated with it."

    The bottom of the feed in FF displays the WP Cache messages:

    <!-- Dynamic page generated in 4.672 seconds. -->
    <!-- Cached page generated by WP-Super-Cache on 2010-09-20 15:46:44 -->

    When I refresh the page again, it displays as a proper RSS feed in FF. I also notice that the content type is "application/xhtml+xml". However, on the first load, the content type seems to be text/xml.

    I have read other posts that discuss issues like this, that pinpoint the use of output buffering. Some of the feeds I'm experiencing this issue with do in fact use output buffering, but some do not. The thing that confused me about this issue is that no one ever describes what the specific issue with output buffering is. They simply say that it's related to output buffering. Does this mean that output buffering can't be used at all, or does it mean that there's a specific way it must be used to be compatible with WP Super Cache?

    I can go into more detail, but I would love to see if anyone else out there has experienced this issue and has done a deeper diagnosis before I write too much more here.

    Thanks for your help,

    Dave Morris

  2. Donncha O Caoimh
    Member
    Plugin Author

    Posted 3 years ago #

    It's harmless if Firefox doesn't render an RSS feed with a style, as that file isn't supposed to be read by a browser. The content type on my own blog is always text/xml and has never caused a problem.

    The content type of feeds on WordPress.com is the same.

    You can always tell the plugin not to cache feeds on the settings page under "Accepted Filenames & Rejected URIs".

  3. dvmorris
    Member
    Posted 3 years ago #

    Thanks so much for your reply! It is true that this issue does not affect RSS reading applications. I guess I go hung up on it because one of our testers reported it yesterday and the behavior was really confusing me.

    While I have your attention, do you know why Super Cache might be causing a user who posts a comment to be redirected to the home page of that blog rather than the blog post page.

    Then, when the user visits the blog post page where they just left a comment, they see their comment as expected, but the "Post a Comment" form is pre-filled out with the following information:

    Name: Sulemaw
    Mail: zspfrul@mail.ru
    Website: http://zspf.ru/content.php?id...

    Or some other random user's info. I confirmed that this user's information exists in a different blog's wp_*_comments table, if that helps clear things up. It's as though super cache is throwing a cookie out there that has the random comment information in it.

    It's very intermittent and difficult to reproduce consistently, especially in a VM environment.

    Thanks for your help,
    Dave

  4. Donncha O Caoimh
    Member
    Plugin Author

    Posted 3 years ago #

    I've heard of that happening, but it happens very rarely and I can't think how it does because the cache file is keyed off the user's cookie. If it happens a lot the best thing to do is disable caching for known users. That's a recommended setting now anyway as there's little point caching pages for them.

  5. dvmorris
    Member
    Posted 3 years ago #

    Thanks so much for your reply. I will look into turning caching off for known users.

    Thanks,
    Dave

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic