WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
WP Super Cache not updating cache (5 posts)

  1. Diesel12
    Member
    Posted 3 years ago #

    We're using WP Super Cache on a multisite install.

    We realized that page caches are not updating / garbage collection is not occurring, regardless of the gc expiry time. Cached pages will have timestamps that are days and weeks old until we manually delete the cache ....

    My first thought was that there might be an issue with WP-Cron not running, but scheduled posts and other plugin activities that require wp-cron aren't showing any issues, so it doesn't look like that is the issue....

    Any ideas on where we might start troubleshooting?

  2. Donncha O Caoimh
    Member
    Plugin Author

    Posted 3 years ago #

    What's your expiry time? It's on the Advanced Settings page. If it's zero then garbage collection is disabled.

  3. Diesel12
    Member
    Posted 3 years ago #

    Hiya. It's usually 3600, but we've even tried putting it to 60 seconds for troubleshooting purposes with no luck ....

  4. Donncha O Caoimh
    Member
    Plugin Author

    Posted 3 years ago #

    Are you using any suphp, mod_security or other "security" modules on your site? Maybe something there is causing a problem?

    Have you tried the debugging system in the plugin?

  5. Diesel12
    Member
    Posted 3 years ago #

    @donncha: learned a few things by debugging, but since we recently migrated to a bigger box, I figured I would use the "Restore Default Configuration" button to start fresh and sure enough that did the trick. It didn't occur to me that a setting or something may not have migrated well from the old server, but now I know for future reference. :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic