WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] WP Super Cache mod_rewrite rules disappears (3 posts)

  1. kak
    Member
    Posted 6 years ago #

    I'm running WP 2.3.3 and WP Super Cache 0.6 on my site. I'm able to update the .htaccess file with the "Update mod_rewrite rules" button on the options-page to WP Super Cache. But something very strange happens when I visit the "Permalinks" options-page. Then my .htaccess automaticly is overwritten without the WP Super Cache-mod_rewrite rules. And I'm NOT pushing the "Update Permalink Structure" button.

    I've also experienced that this thing happens without visiting the "Permalinks" options-page. When I'm visiting the "Permalinks" options-page only the .htaccess file on that spesific site is updating. But when I've experienced it without visiting the "Permalinks" options-page, the .htaccess file on both my WordPress-pages is updated. The WP Super Cache mod_rewrite rules always disappears.

    Why does this happen when I'm not clicking the "Update Permalink Structure" button? And most of all, what can trigger this update of the .htaccess files when I'm not even visiting the "Permalinks" options-page?

    After finding someone else with a similar problem, I was moving the WP Super Cache mod_rewrite-rules out from the "# BEGIN WordPress"-"# END WordPress-area of the .htaccessf-file. The WP Super Cache mod_rewrite-rules doesn't disappear now, but now the "Mod Rewrite Rules"-section of the WP Super Cache options-page is asking me to add the mod_rewrite-rules to my .htaccess.

    But both the WP Cache and WP Super Cache-part of the WP Super Cache seems to work perfectly. It's just a annoying reminder to put the mod_rewrite-rules into my .htaccess. Since I've experienced the mod_rewrite-rules disappear so much, I'm checking the files all the time. It's rather annoying.

    I've btw placed the WP Super Cache mod_rewrite-rules between "# BEGIN WP Super Cache" and "# END WP Super Cache" now. It seems that WP Super Cache options-page not "find" the mod_rewrite rules when it's not betweeen "# BEGIN WordPress" and "# END WordPress".

    You can check out if the WP Super Cache works on my two WP-sites:

    http://blog.kak.net/
    http://car.kak.net/

    Is this the correct solution for my problem, or is it a better one?

    (I decided to do a complete write-up, since it maybe could help others with the same problem. I was really struggling to find the "put the mod_rewrite-rules outside "#BEGIN WordPress""-tip.)

    Thanks in advance!

  2. Donncha O Caoimh
    Member
    Posted 6 years ago #

    That's a known problem. Unfortunately to make sure the super cache rewrite rules were above the WordPress ones I had to put them into the same section of the .htaccess.

    If it happens again, visiting the supercache admin page and updating the .htaccess will fix it.

    Longterm I'll have to replicate WP's .htaccess routines and insert the rules above the WordPress ones.

  3. kak
    Member
    Posted 6 years ago #

    Okay, thanks donncha! I'm looking forward to a more permanent solution for this problem in the future! :)

    WordPress is still updating the .htaccess-files of mine, but is not touching the "WP Super Cache" section.

Topic Closed

This topic has been closed to new replies.

About this Topic