WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
WP Super Cache is omitting the content area (9 posts)

  1. Sparksinfo
    Member
    Posted 11 months ago #

    Not sure what to do.

    WP Super Cache is omitting the content area when it is turned on.

    I've tried all of the caching options with no change in symptoms.

    Symptoms:
    All posts and pages display widgets and <h2> element only.
    The header, nav and footer are all displaying as usual.
    Blog page is unaffected and is displaying the truncated posts as usual.

    I've also completely uninstalled and reinstalled the latest version.

    All current active plugins in use:

    Ad Injection | Version 1.2.0.16 | By reviewmylife
    Akismet | Version 2.5.7 | By Automattic
    Google Analytics for WordPress | Version 4.3.3 | By Joost de Valk
    Jetpack by WordPress.com | Version 2.2.4 | By Automattic
    WordPress SEO | Version 1.4.7 | By Joost de Valk
    WP Super Cache | Version 1.3.2 | By Donncha O Caoimh

    Theme:
    Canvas 5.0.9 | Framework 5.5.5 | by Woo Themes

    Anyone with ideas?

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. Michael Madison
    Member
    Posted 11 months ago #

    Same issue here. If I disable either WP Super Cache or Ad Injection, my posts appear. If both are enabled, the post title and comments appear, but there's no actual post content.

    This behavior was first noticed after Super Cache 1.3.2 update.

  3. Donncha O Caoimh
    Member
    Plugin Author

    Posted 11 months ago #

    Have you enabled dynamic caching on the advanced settings page? You'll need to change to PHP mode to do it.

  4. polins
    Member
    Posted 11 months ago #

    This sounds like a conflict with the Ad Injection plugin.
    Donncha is working on a new version of WPSC to address the need for dynamic content on cached pages (thanks, Donncha, you are a marvel, and deserve to be paid handsomely by the hosting companies for all the wasted computer cycles you have saved!).
    In the mean time, until we see how this works out, I have found that the "Ads by datafeedr.com" plugin is an excellent alternative for displaying dynamic ads, since it relies on Javascript rather than mfunc (based on my admittedly limited technical knowledge).

  5. BTTeditor
    Member
    Posted 11 months ago #

    To "Polins"... Thanks very much for the update. And THANKS to Donncha for the upcoming version of WP Super Cache.

    I am experiencing the same problems as the initial poster "SparksInfo" and am also using the same plugins as him except for JetPack.

    ADDITIONAL CONFLICT NOTE:

    When I use the WP Super Cache recommendation of "Use mod_rewrite to serve cache files. (Recommended)"... it TURNS OFF my BPS Security plug-in every time I open the WP Super Cache screen. NOTE: I have been successfully using the WP Super Cache "mod rewrite" option and the BPS Security plug-in with no problems for more than a year.

  6. Donncha O Caoimh
    Member
    Plugin Author

    Posted 11 months ago #

    BTTeditor - try PHP mode, you probably won't even notice any difference in speed!

  7. polins
    Member
    Posted 11 months ago #

    Thanks, Donncha, I'll try this, too.
    Forgive my lack of technical expertise, but I got the impression that you were deprecating the use of mfunc in your upcoming versions. If so, then finding alternatives to other plugins which rely on mfunc becomes critical to some of us.

    Le dea-mhéin

  8. Donncha O Caoimh
    Member
    Plugin Author

    Posted 11 months ago #

    Yeah, I am. It's being replaced by a more secure filter based system. I wrote a blog post on the replacement for mfunc with more info.

  9. ebedgert
    Member
    Posted 9 months ago #

    I've had this same problem, but it strikes (seemingly) random posts.

    PHP mode did not help.

    I don't have Ad Injection on my site. Are there any other known plugin conflicts that cause this?

Reply

You must log in to post.

About this Plugin

About this Topic