WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
WP Super Cache - I see no imporvement in response time (9 posts)

  1. JohnChandlerEdmonton
    Member
    Posted 3 years ago #

    We need help.

    The WP Super Cache does not improve response time.

    What is wrong? What do we do?

    I have turned it on. If I go "view source" I see the comments at the end, e.g.:

    <!-- Dynamic page generated in 18.149 seconds. -->
    <!-- Cached page generated by WP-Super-Cache on 2011-02-07 20:49:26 -->

    If I go to the settings page I see that the pages are in the cache, e.g.:

    Cache Contents
    WP-Cache (0KB)
    0 Cached Pages
    0 Expired Pages

    WP-Super-Cache (595.02KB)
    16 Cached Pages
    0 Expired Pages

    So I'd expect it to serve up some pages at a rate that is noticibly faster than if the cache was off. But it doesn't.

    It is still slow as a turtle:
    http://dogsport.org/spectrum/

  2. Ron Rennick
    MultiSite Guru
    Posted 3 years ago #

    My first suggestion is look at what plugins you can remove from your site to improve your page generation time. If you remove some of them and your page generation time doesn't improve significantly, I'd suggest upgrade your hosting account or consider moving to another host.

    A default install on my dev server takes about 0.12 seconds to generate the homepage. 18 seconds is 150 times as long.

  3. qdinar
    Member
    Posted 3 years ago #

    it creates cache file on every request, because time of creation in comment in bottom in source is changed after every request.

  4. Donncha O Caoimh
    Member
    Plugin Author

    Posted 3 years ago #

    I think you should use the debug system in the plugin as it's not configured or installed correctly. I just checked the headers on your front page and didn't see any mention of Supercache and saw the "X-pingback" header inserted by WordPress instead.

  5. JohnChandlerEdmonton
    Member
    Posted 3 years ago #

    Thanks for the responses everyone.

    Donncha, thanks. I've now raised a problem call with the host provider to look into it. I also let them know I get error messages when I try to upgrade the plugin to a newer version. Once we get that working we'll reinstall the whole thing from scratch. (the plugin was already there when the wordpress site environment was purchased and created. evidently they did the set up incorrectly in their install routine)

    I didn't see a debug option. Do I have to edit the code to turn that on?

  6. JohnChandlerEdmonton
    Member
    Posted 3 years ago #

    Our host provider (Network Solutions) has been providing suggestions as to how to speed up the site without the plugin. Nothing has worked.

    I have notied that regular html pages are fine.
    And also the phpadmin application that is used to browse/maintain the underlying MySql database also runs extremely fast. Phpadmin is written in php and accesses the MySQL database... WordPress does exactly the same thing phpmyadmin is fast. WordPress is slow.

    There must therefore be some setting (perhaps a maximum limit to used memory?) that is affgecting the wordpress blog and which is not set so low for phpadmin. Does anyone know if this sounds reasonable as an explanation? If so then it could form the basis of a request to Network Solutions to get them to do something that would make things better.

  7. Donncha O Caoimh
    Member
    Plugin Author

    Posted 3 years ago #

    In the Supercache settings page one of the tabs says "Debug". That's what you're looking for. Make sure you're using the latest Supercache though.

  8. Ron Rennick
    MultiSite Guru
    Posted 3 years ago #

    @JohnChandlerEdmonton - It's quite possible that phpMyAdmin is not running on the same web server as your website. Ergo, its speed may not be reflective of your website's server speed.

    I've never worked on NetSol, but many of the larger hosts run their control panels on separate boxes from the websites.

  9. JohnChandlerEdmonton
    Member
    Posted 3 years ago #

    Just a quick update on this.

    We changed hosts.
    (from Network Solutions to Bluehost).

    Now everything works perfectly.
    Other errors we were getting with wordpress are also no longer occuring too.

    All the best and many thanks for the advice and comments.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic