WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] WP Super Cache & Disable Canonical URL Redirection (2 posts)

  1. piotr82
    Member
    Posted 2 years ago #

    Hello,

    This is the problem that i have.

    I use those two plugins:
    WP Super Cache & Disable Canonical URL Redirection

    http://guistyles.com/ - main static html site
    http://guistyles.com/index.php - wordpress

    to make this work i need to use Disable Canonical URL Redirection, if i disable it all pages redirect to http://guistyles.com/, wordpress URL goes to http://guistyles.com/

    now with both plugins on, main site is ok but when i click on category,archive or whatever i see this error:

    Warning: Cannot modify header information - headers already sent by (output started at /home/sites/guistyles.com/public_html/wp-content/plugins/disable-canonical-redirects.php:12) in /home/sites/guistyles.com/public_html/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 79

    When i disable wp super cache everything is working good.

    Please help to solve this one out.

  2. piotr82
    Member
    Posted 2 years ago #

    wrong coding on disable-canonical-redirects.php file

Topic Closed

This topic has been closed to new replies.

About this Topic