WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
WP Super Cache conflict with WPtouch (4 posts)

  1. ymf
    Member
    Posted 1 year ago #

    Hi. I have WP 3.5.1, WPtouch 1.9.6.1 and WP Super Cache 1.3.1 plugins, Atahualpa 3.7.12 theme. The problem is:
    - Desktop browser sometimes shows a mobile version of the site (if that page was previously visited from a mobile device);
    - Mobile device sometimes shows a mangled (without CSS) desktop version of the site (if that page was previously visited from a desktop browser).

    The problem occurs with any of WP Super Cache's three caching methods: "Use mod_rewrite to serve cache files. (Recommended)," "Use PHP to serve cache files," or "Legacy page caching."

    To reproduce the problem:

    Test #1:
    (1.1) WP Super Cache Settings -> Easy -> Delete Cache; log off.
    (1.2) Visit a post from Windows desktop Firefox 17.0.1 (displays desktop version as expected);
    (1.3) Then visit same post from a mobile device (displays a mangled, without CSS, desktop version).

    Test #2:
    (2.1) WP Super Cache Settings -> Easy -> Delete Cache; log off.
    (2.2) Visit a post from a mobile device (displays WPTouch mobile version as expected);
    (2.3) Then visit same post from Windows desktop Firefox 17.0.1 (displays WPTouch mobile version!).

    Any advice? I "think" I set up WP Super Cache as recommended for it to work together with WPtouch, but I may be missing something...

    My WP Super Cache settings are:

    WP Super Cache Settings -> Advanced: I checked the following
    - Cache hits to this website for quick access.
    - Use mod_rewrite to serve cache files //I also tested the other two caching methods
    - Compress pages so they’re served more quickly to visitors
    - Don’t cache pages for known users.
    - Cache rebuild. Serve a supercache file to anonymous users while a new file is being generated
    - Mobile device support.
    - Extra homepage checks.

    WP Super Cache Settings -> Plugins:
    - WPTouch "Enabled"

    I also made sure to do WP Super Cache Settings -> Advanced -> Update Mod_Rewrite rules.

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. jah
    Member
    Posted 1 year ago #

    That's a known problem; WPtouch tells you how to fix it on their support site. You should check the compatibility tab for WPtouch. Basically, if you are using the Pro version of WPtouch, you have to turn off WPtouch support in Super Cache / plugins, and turn on mobile support in Advanced.

  3. ymf
    Member
    Posted 1 year ago #

    I re-posted the original question to WPtouch support forum (link).

  4. BraveNewCode Inc.
    Member
    Posted 1 year ago #

    You may configure your caching plugin not to cache mobile pages nor to serve cached pages when mobile devices are detected. To do so, enter the user agents found under Advanced Options > Custom User-Agents to the "rejected user agents" areas in your caching plugin's settings. Remember to clear your plugin, browser, and device caches before retesting.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic