WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache - Caches Category Page Instead of Home Page (67 posts)

  1. davidecd
    Member
    Posted 5 years ago #

    Sometimes for certain users/browsers WP Super Cache serves the wrong cached page for the home page. Instead of serving the home page it serves a cached version of the first category page. It's hard to reproduce the problem but we're seeing it more or less daily.

    Any suggestions?

    Below are the plugins we have installed:
    Akismet 2.2.3
    All in One SEO Pack 1.4.6.16
    Breadcrumb Navigation XT 1.8.0
    Dagon Design Sitemap Generator 3.15
    Robots Meta 3.0.11
    Secure and Accessible PHP Contact Form v.2.0WP B20070213
    SEO Friendly Images 2.3.1
    TinyMCE Advanced 3.2
    Viper's Video Quicktags 6.1.15
    Wordpress Automatic Upgrade 1.2.2
    WP Super Cache 0.8.8

    David

  2. Shakhawat
    Member
    Posted 5 years ago #

    Upgrade your WP Super cache to latest version 0.8.9 from http://wordpress.org/extend/plugins/wp-super-cache/

  3. davidecd
    Member
    Posted 5 years ago #

    Same problem. It's serving different cached versions of the home page to different user agents/browsers. Anybody else seen this?

  4. punkelstein
    Member
    Posted 5 years ago #

    I have the same problem.
    It caches the first category it finds (sorted by name) as the home page.

    I have
    Headspace2
    Akismet
    Redirection
    and a few others installed

    Deleting the cache fixes the problem for an indeterminate period of time.

    Must be a pretty easy bug to fix? Just cache the right page!

  5. remotay
    Member
    Posted 5 years ago #

    I have the SAME exact problem, i've been searching for a fix everywhere, without any luck =[

    If someone found a fix, PLEASE post it!

  6. Donncha O Caoimh
    Member
    Posted 5 years ago #

    You'll have to help me debug it. Use error_log() to check the $cache_key created in wp-cache-phase1.php
    Check the cached file in your cache directory. Is the cached file in supercache/hostname.tld/index.html the right one?

  7. remotay
    Member
    Posted 5 years ago #

    Thanks Donncha for offering to debug it. This issue is driving me mad. I'm at the point where I have to manually clear cache every 3 hours, otherwise the glitch happens. I tried a few older versions as well, and the older versions have the same issue. Tried 9.3 / 9.2

    Once this is fixed, You'll be getting a small donation from me. Love your plugin, just this one little issue is nagging me.

    As now now, after clearing the cache, the correct index.html is indeed in the supercache folder, but it should switch over to the wrong one in a few hours.

    I just cleared the cache manually, so once the problem pops up again, which it will in a few hours, I'll give you the info you need. But it's 5AM now, so I'll need some shut eye first :).

  8. remotay
    Member
    Posted 5 years ago #

    Ok what happens is it has the correct index.html in the Cache area, but after the problem arises, the index.html becomes the index for the Category page rather than the homepage.

    Im not sure how to run the error log command, but I went into the wp-cache config and removed the comments from the debug reports, so it reads '$wp_cache_debug = "remotay@gmail.com";'
    Meaning, I should get debug emails, which should help you find the issue, right?

    If you'd like, I could grant you FTP access to my site, and you can see exactly what's happening. I'd rather not waste your time, so I can tell you exactly when the problem is happening, so you can hop and see it for yourself right then and there. Let me know.

  9. remotay
    Member
    Posted 5 years ago #

    See http://wordpress.org/support/topic/237415?replies=5

    donncha posted there and is offering to debug. I've been having the exact same problem to guys. Every 5-10 hours it would happen. Btw, what hosts are you guys on?

  10. remotay
    Member
    Posted 5 years ago #

    Whoops wrong thread, meant to post it in another.

  11. remotay
    Member
    Posted 5 years ago #

    Ugh this problem is still driving me insane. donncha is there a way for me to upload the CORRECT homepage onto the supercache MANUALLY, and make the supercache plugin NEVER rewrite that file? Just for the homepage. This would instantly fix the issue for me.

  12. remotay
    Member
    Posted 5 years ago #

    I tried setting the expiration to something like 20 days, but the file still gets replaced with the wrong one.

    Is there a way to automatically COMPLETELY clear the cache every hour or so? This would also fix the problem. This is really hurting my rankings, as googlebot is seeing the wrong page as the homepage every now and then.

  13. remotay
    Member
    Posted 5 years ago #

    I'm about ready to pay someone to fix this. If anyone wants to earn $50 via paypal, Contact me and if you can fix this issue its yours

    aim: Limon Kolonya
    msn: remotay@gmail.com
    yhoo: remotay

  14. jimbocook
    Member
    Posted 5 years ago #

    Same problem here. Seems to affect Safari and Explorer but not FireFox. And Google has indexed the category page as the home page.

  15. Donncha O Caoimh
    Member
    Posted 5 years ago #

    Can you edit the .htaccess in the root of your installs and remove the supercache rules. Now let the plugin regenerate them again. Do you still see the problem?

  16. jeuxflash
    Member
    Posted 5 years ago #

    +1 , if someone could be find a solution. I have the same problem, but it seems random.

  17. Donncha O Caoimh
    Member
    Posted 5 years ago #

    jeuxflash - did you read my last post? Check it out here. Does that help?

  18. remotay
    Member
    Posted 5 years ago #

    Im having the problem now on two sites. Im actually moving to a new host due to this issue. [From Mosso cloud hosting to a dedicated server]

    Will post here if my problem gets fixed or not

  19. shoaib786
    Member
    Posted 5 years ago #

    Thanks for getting some good informative knowledge to me and to others..

  20. blakekr
    Member
    Posted 5 years ago #

    I'm just tagging onto this because I want to know when it's safe to upgrade SC. My old version is a bit threadbare but fortunately, it doesn't serve up the wrong page as the home page. I see a link from donncha above that might address this but it isn't working for me.

  21. Donncha O Caoimh
    Member
    Posted 5 years ago #

    blakekr - which version works for you? If I know that I may be able to figure out what is causing this.

  22. blakekr
    Member
    Posted 5 years ago #

    Hi Donncha, I downgraded to 0.7.1. I don't know if that's the last version that avoids the home page problem, but someone said it worked so I used it, and it's been working for me too.

  23. remotay
    Member
    Posted 5 years ago #

    0.7.1? I'm going to have to downgrade to it because this problem is still happening, even after I switched hosts. I'm on a dedicated machine now and this problem sucks.

    Currently I have ACTools running a macro to clear my cache every 20 mins [As I need to do that to avoid this issue].

  24. robreact
    Member
    Posted 5 years ago #

    I'm seeing this as well. I'll take a shot at downgrading, but it would be a real issue if that doesn't work. I have a dev machine synched with the same configuration that I'm going to hit to try to recreate it.

    If it helps (and since someone else mentioned it) I'm on mosso (rackspace cloud)

  25. remotay
    Member
    Posted 5 years ago #

    It can't be related to the cloud hosting, because I moved servers and the problem still occurs. Actually happens on TWO of my sites. Moved both over from cloud hosting to regular hosting and reset my htaccess rules to the default and no fix.

  26. Donncha O Caoimh
    Member
    Posted 5 years ago #

    As an experiment I'm running my own blog today with a static page as the front page at http://ocaoimh.ie/ and I'm monitoring it with a script that grabs the front page every 5 seconds.

    The script looks for the text "you came here expecting posts and stuff" and if it doesn't find it it will email me. So far it's been running for several hours without a hitch.

  27. robreact
    Member
    Posted 5 years ago #

    I should be able to replicate it for you next week. We want to try to replicate it in our staging environment, in order to therefore test the downgrade workaround.

    It happened twice, that I know of, within the first 24 hours of the site where this occurred going live, so simulating some traffic should get it to happen on our staging box.

  28. Donncha O Caoimh
    Member
    Posted 5 years ago #

    Still no sign of it happening on my blog right now and it's hours later.

    When you do see it happening take a look at your logs and try to find a pattern, please! :)

  29. Donncha O Caoimh
    Member
    Posted 5 years ago #

    9 hours later and my site is still working fine.

    It must be something to do with the local configuration or the set of plugins you use. This is really annoying.

  30. robreact
    Member
    Posted 5 years ago #

    My guess is it's got to be a configuration issue, because the only plugin I'm using that crosses over with the first poster is Akismet. And obviously, that's not the issue or else everyone would be seeing it.

Topic Closed

This topic has been closed to new replies.

About this Topic