WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache - Caches Category Page Instead of Home Page (67 posts)

  1. Donncha O Caoimh
    Member
    Posted 5 years ago #

    Must be alright. My monitoring script is still running fine and only reported an error when the system cron restarted Apache as part of it's daily tasks this morning.

    ocaoimh.ie is running on a fastcgi setup. I'll try the same on my photoblog. It's using a more conventional mod_php setup.

  2. Donncha O Caoimh
    Member
    Posted 5 years ago #

    Bah. My photoblog is using /%postname%/ as it's permalink structure so the static front page thing doesn't work.

  3. CrazySerb
    Member
    Posted 5 years ago #

    Try having your blog use /%category%/%postname%/ as it's permalink structure... that's what's messing all my blogs up. And yes, I have the same issue as everyone else.

  4. remotay
    Member
    Posted 5 years ago #

    ^^ I have the same permalink structure as you serb.

    I actually disabled the super cache aspect of wp-super cache and I'm running fine. Would like the super cache, but I can live without it.

  5. Donncha O Caoimh
    Member
    Posted 5 years ago #

    CrazySerb - my photoblog is acting up, even with your permalink structure I can't convince it to use a static front page. Have configured ocaoimh.ie to do it though and it's been fine for the last 3 hours or so.

    Maybe the advice for anyone suffering with this problem is to use half-on mode. You won't notice any difference in speed!

  6. CrazySerb
    Member
    Posted 5 years ago #

    Yeah, I went with half-on and no problems... yet.

  7. robreact
    Member
    Posted 5 years ago #

    I think we've got a trend. I'm using the same /%category%/%postname%/ permalink structure.

    How many people are using half-on mode successfully?

  8. Donncha O Caoimh
    Member
    Posted 5 years ago #

    robreact - that permalink structure is probably it, although I've been using it with a static front page on ocaoimh.ie for the last 20 hours or so and it's been fine. There has to be another mitigating factor.

    Apart from the two above using half-on mode I know another big site using it too and he hasn't seen any problems. I'll add a FAQ about this to the docs.

  9. BrianSummers
    Member
    Posted 5 years ago #

    We're seeing very similar problems to the ones reported in this thread.

    We have WP Super Cache 0.9

    It's odd because we haven't touched it for weeks but over the last two days (5th Aug 2009 - 6th Aug 2009) 'something' has been corrupting the generated index.html page every four hours or so. This mangles our home page which is very bad news :-(

    Actually we've had to disable WP Super Cache for now pending some kind of solution.

    If anyone finds a solution we'd be very grateful to hear about it !

    Another point... we had to disable the WP Super Cache compression a while back as well because it seemed to be incompatible with some recent browser updates (or vice versa if you prefer). Is there any solution to this problem also?

    Thanks,
    Brian

  10. Donncha O Caoimh
    Member
    Posted 5 years ago #

    BrianSummers - try the cache in half on mode. That should work better!

  11. BrianSummers
    Member
    Posted 5 years ago #

    Thanks for your response.

    Before I try that, (I'm nervous because it's a live system), could you explain why that might help and offer any reason why it was breaking in the full on mode?

    I've no idea whether there was a change to the machine I run my system on (eg. some kind of operating system patch update for example) but I don't think there was... hence I'm really puzzled why this has suddenly started to happen.

    Thanks again.

  12. Donncha O Caoimh
    Member
    Posted 5 years ago #

    I can't explain why except that it fixes the problem for everyone who tries it. I can't reproduce the problem on my own servers so I can't debug it.

    You won't notice any speed difference in your site though. It's perfectly safe to do.

  13. Remkus de Vries
    Member
    Posted 5 years ago #

    I'm having the same issues as well.. Setting is the half modus fixed the trick, but I have not had this issue for a long time. Yesterday I upgraded to the latest version of WPSC (0.9.6.1)and this morning I discovered the site was only showing the view of the first available category. FWIW.

  14. chrissss
    Member
    Posted 5 years ago #

    I can confirm this issue too, setting the cache to "half mode" helps, but I'm pretty sure that wordpress stats don't work any more after I activated the "half mode"...

  15. BrianSummers
    Member
    Posted 5 years ago #

    Thanks for your responses.

    We switched to Half-Mode as suggested and I'm pleased to report that we haven't had problems all morning.

    However, I'm not sure if we're seeing any benefits... (?)

    On each page I see at the bottom:

    "Dynamic Page Served (once) in n.nn seconds"

    It seems to be generating the pages every time - it doesn't appear to be using the cache at all (?)

    On the disk I can see the static html files that were created under my cache directory but these are not being updated... so maybe there is some caching going on here.

    Maybe it is working and I just don't understand it...

    My RewriteCond rules only refer to the supercache directory not the cache directory above... Should these rules be changed for Half-On mode?

    Thanks.

  16. mantis108
    Member
    Posted 4 years ago #

    Hi all,

    Wanted to jump in to confirm we are having same experiences as others here with our blog, and the remedies are the same for us -- setting to half-mode or leaving it fully on and clearing the cache manually via FTP (which works for a day or two until the problem recurs).

    We will try downgrading to 0.7.1 and see if that helps. If there's any information we can provide to help diagnose this Donncha let us know, we'd be happy to help as we'd like to run the latest version in full mode!

    Thanks...

  17. Donncha O Caoimh
    Member
    Posted 4 years ago #

    I've given up trying to fix this bug as I don't have time to arrange getting logins, ftping files, editing and tracking changes to the front page. "Half-on" mode is practically as fast so unfortunately it'll remain the only fix for this stubborn but elusive bug.

    If you want to debug it yourself:
    1. Monitor the front page of your blog by firing a request at it every few seconds.
    2. Search for a string that is on the category page that sometimes shows up.
    3. If that string is found send an email to yourself.
    4. Check your access logs for the period between the last check and the one that alerted you for any suspicious requests (for any value of "suspicious", I don't know what it is)
    5. Try setting it off yourself using a not logged in browser and the requests that were recorded preceeding the alerting check.
    6. Email me when you know how it happens and I'll fix it.

    I gotta rename "half-on" mode to "PHP mode" or something. There's negligible difference between it and static caching.

  18. mantis108
    Member
    Posted 4 years ago #

    Kinda sad to hear that but oh well.

    Donncha, one question: what is faster in your estimation... 0.7.1 in full mode or the current version 0.9.6 in full mode?

  19. Donncha O Caoimh
    Member
    Posted 4 years ago #

    I doubt there's much difference. Maybe milliseconds because of the extra mobile user agent checks? Certainly not measurable.

  20. blakekr
    Member
    Posted 4 years ago #

    Good question, Mantis, I was wondering the same thing.

    Donncha, this might not be much help but I never saw the problem myself until Google misindexed the home page and others complained. All my browsers that had a site cookie set behaved fine, it was only total strangers (aka virtually everyone else) that saw the bad home page.

  21. Donncha O Caoimh
    Member
    Posted 4 years ago #

    blakekr - milliseconds, if any. they're the same speed.

    What you saw is what others have seen. Only users seeing the supercached pages get the wrong cached page. I don't know why that happens :(

  22. Lazarevac
    Member
    Posted 4 years ago #

    I almost switched to WP after even worse issues in Joomla, but you are making me think again now. In order to have SEF URLs, we had a component issue creating URLs that were actually non existent so that Google indexed non existing pages and kept reporting 404 error each crawling. It was building up to more than 900 pages and we finally decided to kill the component to be SE friendly again. Now, since mattcutts talked me into WP here is an issue that I would hate to face, so please report here if anyone cured this problem. Thanks.

  23. Donncha O Caoimh
    Member
    Posted 4 years ago #

    Lazarevac - out of tens of thousands of blogs using WP Super Cache this happens to a handful and is fixed by switching to half on mode that is just as fast.

    I can't reproduce it on any of my sites so I'm going to have to depend on someone else tracking down why it happens. If it was a common problem that would happen.

  24. aseem1234
    Member
    Posted 4 years ago #

    I'm having this same problem and I have to say that I'm not necessarily sure this happens to just a "handful of blogs". Personally, I think it could be happening to a lot of blogs, but they just don't know it.

    For example, on my website, I didn't see this problem on any of my home computers or office computers. Only when I traveled to another city and loaded my website on a friends computer did I see the category page as the home page.

    Also, after a couple of hours, the problem disappeared on that computer. This problem is so hard to reproduce and to detect that it could easily have been happening to my site for months without me having any idea.

  25. Donncha O Caoimh
    Member
    Posted 4 years ago #

    aseem1234 - I disagree, I think it's a few. I couldn't reproduce it but I included a warning in the readme.txt. It only affects users who have configured WordPress in a particular way, and even then, only some of them.

    When I configured ocaoimh.ie that way I set up a script that monitored the blog every minute and for several days it never once occurred on my blog.

    Unless someone with a blog that it affects can find a solution, the only solution is to use the plugin in half-on mode (which is the same thing that every other single page caching plugin for WordPress does so it's pretty good!)

  26. aseem1234
    Member
    Posted 4 years ago #

    Hi Donncha, so how do you know how many users have blogs that are configured in this certain way that causes the problem? If you don't know what configuration is causing the problem in the first place, how can you know how many people actually have this configuration for WordPress?

    Maybe you could write up a questionnaire and send that to all the people you know are having this issue and then see what is possibly common between them. I would think this might get you the answer quicker than us trying random stuff. (What plugins is everyone using, permalinks or not, shared hosting or dedicated, etc, etc)

  27. Donncha O Caoimh
    Member
    Posted 4 years ago #

    aseem - see the section titled "A category page is showing instead of my homepage" in the readme.txt. That's the configuration that everyone who has had this problem has. It's not a common one.

    That doesn't matter anyway because I can't replicate it, and the people who do have the problem don't have the skills required to fix it. :(

  28. aseem1234
    Member
    Posted 4 years ago #

    Ahhh OK, that makes more sense, there is an underlying reason for it. Hmm, so my having /category/post-title is what causes this issue.

    What exactly do you need to do in order to debug this? What skills are required to fix it? Maybe I can help. I have a tech friend who knows Linux, Apache, PHP and WordPress very well (what my server is running).

  29. Donncha O Caoimh
    Member
    Posted 4 years ago #

    Do you have a static page for your front page too?

    Skills? Just general PHP and WP skills. Someone who knows how to use error_log or can use the debug functions in supercache and the patience to track down the error.

    Grab the development version from the download page - it has an advanced debug setting that monitors the front page of your blog once a minute and reports and/or clears the cache when the front page goes wrong. Try that and examine your access log to see if anything unusual triggers the problem. (No, I don't know what something unusual is!)

  30. aseem1234
    Member
    Posted 4 years ago #

    No I don't have a static front page, just the permalinks structure you mentioned. I will go ahead and try to see if I can find anything! Thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic