WordPress.org

Ready to get started?Download WordPress

Forums

[wp-super-cache] Bug: Warning! /home/...../public_html/ is writable. (6 posts)

  1. AhmedWorld
    Member
    Posted 5 years ago #

    Hi,,

    I use WP Super Cache from month, and no problem, but yesterday I found strange thing. I got this message!

    Warning! /home/...../public_html/ is writable. Please make it readonly after your page is generated as this is a security risk.

    And I know the default Permissions are:
    public_html: 750
    Files: 644
    directories: 755

    And that's Permissions in my site.
    http://img30.imageshack.us/img30/4542/5302009105222.png

    I think that's a bug in wp super cache,
    Regards..

  2. orbalon
    Member
    Posted 5 years ago #

    super cache uses chmod in one place in the script from what I remember and running it on your public_html folder was not what it was doing. I think it was in there as a fail safe in case the file couldnt be edited.

    Also note, typically the main html dir your site is in is also chmod 755. At least on my server. I run a self managed dedicated machine, so unless I dont remember changing it, it came like that out of the box.

    Are you sure its not complaining about "wp-content"? Check that file...

  3. LindaRRR
    Member
    Posted 4 years ago #

    Warning! /home7/thesmas1/public_html/ is writable. Please make it readonly after your page is generated as this is a security risk.

    I just received this message after deactivating all my plugins on the recommendation of simplescripts so I could update some security thing.

    Obviously I am not a techie. So the above message mean nothing to me. How do I make my public_html safe as a read only??

  4. theobroma
    Member
    Posted 4 years ago #

    I have just noticed the same message.

    Yet my website's directory permissions are set to 755, which is, I believe, the correct setting: Read-Write-Execute for the User, and Read-Execute for Group and World.

    If I restrict it more, my site displays a 403-forbidden page.

    I think this is a bug, but would like to hear from a techie, as I not one either....

  5. Donncha O Caoimh
    Member
    Posted 4 years ago #

    lutetia - your Apache server is probably running as the same user that owns the directory. You can ignore the message.

  6. theobroma
    Member
    Posted 4 years ago #

    Great, thanks for clarifying that.

Topic Closed

This topic has been closed to new replies.

About this Topic