WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
WP Super Cache and ?ver parameter (4 posts)

  1. John Sturgeon
    Member
    Posted 1 year ago #

    I'm setting up wp supercache on my web site, and I'm having a problem with Sermon Browser. It seems that it refuses to cache my pages because of this:
    /sb-style.css?ver=1367856126 Supercache caching disabled. Only using wp-cache. Non empty GET request.

    sb-style.css is adding 'ver' as a parameter to GET request which is slowing my caching, but the 'ver' parameter does not change (except, of course, between versions). Is there a workaround to that problem?

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. jondaley
    Member
    Posted 1 year ago #

    See the "advanced" setting:

    Don’t cache pages with GET parameters. (?x=y at the end of a url)

  3. John Sturgeon
    Member
    Posted 1 year ago #

    So, super cache cannot cache a page with a GET parameter *even if the get parameter doesn't change*?

  4. jondaley
    Member
    Posted 1 year ago #

    I am not exactly sure what you mean.

    If you have the "don't cache page with get parameters" setting checked, it won't ever cache any page with any GET parameter.

    If you have the "don't cache page with get parameters" setting unchecked, supercache will ignore the GET parameter, and will cache the page the first time it is visited, and then deliver that version from then on.

    So, it will work fine if you just have a "?ver=123" (except that when you update your file and the 123 changes to 234, supercache will still deliver the original version).

    It will not work if you have /search?term=jondaley and then visit /search?term=johnsturgeon, as both pages will show the jondaley page.

    Is your sb-style.css a static file? If so, supercache isn't involved at all, as supercache doesn't cache static files, as that would be redundant.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic