WordPress.org

Ready to get started?Download WordPress

Forums

Autoptimize
[resolved] wp super cache and autoptimize (12 posts)

  1. conservativeread
    Member
    Posted 1 year ago #

    I also have had issues using both wp super cache and autoptimize I will try this and report back . 1 other thing is I am on cloudflares network and have there minify enabled which is a weak minify. I disable cloudflares and still have minify issues using both wp super cache and autoptimize together my website is http://conservativeread.com running on swift premium theme
    update: ok so all I can use from autoptimize is html compression css and java break my theme. any suggestions?

    http://wordpress.org/extend/plugins/autoptimize/

  2. Frank Goossens
    Member
    Plugin Author

    Posted 1 year ago #

    hi conservativeread; quick question (two actually) are there imports in the CSS (bug I'm working on) and is some of the -inline- javascript in "IE hack" tags?

  3. Frank Goossens
    Member
    Plugin Author

    Posted 1 year ago #

    update; I just committed a new version (of what is to become 1.6.3) to the SVN trunk a number of fixes. You can download that build from http://downloads.wordpress.org/plugin/autoptimize.zip.

    I'm very interested to hear if this solves your problem!

  4. conservativeread
    Member
    Posted 1 year ago #

    can you see my source code http://conservativeread.com , as i said html is activated only and the site is running faster but i wanted css and java minify as well. maybe some themes and configs dont need these plugins oh and same promlem with wp minify so it is not uniqe to autoptimize. im not that code savvy so bear with me. hope you can se what is going on in the source code. thank you chris

  5. Frank Goossens
    Member
    Plugin Author

    Posted 1 year ago #

    OK, could you download and activate the new version and see if that changes anything?

  6. conservativeread
    Member
    Posted 1 year ago #

    i tried the dev vers. same problems some worse with jave minify enabled i had java script scattered all over my home page i will wait for another release, thank you, chris

  7. Frank Goossens
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Chris, there's an update of the development version, with some more fixes (mostly for CSS minimizing). Can you download it and see what happens?

  8. conservativeread
    Member
    Posted 1 year ago #

    updated plugin to dev. trunk i enabled css and html and so far no problems everything else is unchecked including java. running on wp 3.6.1 beta, keep up the great work,chris see source code and advise what i can do... update: i tried java minify it broke java on my site , so i unchecked it and left css and html minify enabled with yui compression for css enabled. it is faster...

  9. Frank Goossens
    Member
    Plugin Author

    Posted 1 year ago #

    Next step: trying with option "Only look for JavaScript in head" and/or excluding scripts from being optimized. This is a bit of trial-and-error I'm afraid, but in most cases this allows the successful optimization of almost all JavaScript.

  10. conservativeread
    Member
    Posted 1 year ago #

    I will try it but my pagespeed score says im good as is , I will report what happen , do you know anything about (Removing query strings from static resources) gmetrix says this is a problem on my site ?

  11. Frank Goossens
    Member
    Plugin Author

    Posted 1 year ago #

    Query strings can be added to static resources to ensure that the correct version is downloaded. To accomplish this the querystring will change if the static resource changes, breaking most (but not all) caching. That way querystrings for static resources serve an important purpose that -as far as I'm concerned- outweighs the performance "impact".

  12. conservativeread
    Member
    Posted 1 year ago #

    ok java enabled is working all 4 options are checked in jave minify

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags