WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
WP Super Cache advanced settings not visible when using Cloudflare (28 posts)

  1. skippybosco
    Member
    Posted 3 years ago #

    We recently started using CloudFlare (http://cloudflare.com) to protect a few of our websites. One side effect we've found is that the WP Super Cache Advanced settings are not displayed. The tab and available options are displayed, but all of the settings are unselected. Setting them and pressing save returns them all to the unselected state.

    Bypassing Cloudflare (direct.mydomain.com), all of the Advanced settings are displayed properly.

    I'm bringing this up as an issue with WP Super Cache, as opposed to CloudFlare, as it is the only plugin that I'm having the issue with.

    Is there something different about how configuration values are read by WP Super Cache that may be impacted by the introduction of a reverse proxy like CloudFlare?

  2. skippybosco
    Member
    Posted 3 years ago #

    A follow up to this as I found another anomaly which may indicate the issue is with the multisite code creating the weirdness when accessing the site from CloudFlare (either that or a completely different issue :-p)

    Visiting the site from direct.mydomain.com (basically just a virtual host to mydomain.com which bypasses cloudflare and hits my server directly), the content tab shows a completely different number of cache contents when I refresh than if I visit from mydomain.com.

    Example:

    From direct.mydomain.com:

    WP-Cache (32.99MB)
    503 Cached Pages
    154 Expired Pages

    WP-Super-Cache (0KB)
    0 Cached Pages
    0 Expired Pages

    From mydomain.com:

    WP-Cache (37.60MB)
    566 Cached Pages
    173 Expired Pages

    WP-Super-Cache (54.39MB)
    502 Cached Pages
    442 Expired Pages

  3. Chris Langille
    Member
    Posted 3 years ago #

    I'm using CloudFlare and having the same issue with the Advanced Settings not staying selected.

  4. scotttswan
    Member
    Posted 3 years ago #

    I'm also having exactly the same problem

  5. Sean
    Member
    Posted 3 years ago #

    Have the same issue here as well using CloudFlare. I was wondering why my settings were never staying selected, at least now I know what is causing it.

    Another thing I've noticed with CloudFlare enabled, when I press the "Test Cache" button in WP Super Cache it says the "The pages do not match! Timestamps differ or were not found!" - but with CloudFlare disabled it works fine.

  6. Donncha O Caoimh
    Member
    Plugin Author

    Posted 3 years ago #

    I just re-enabled CloudFlare on one of my sites and the advanced settings page is ok. I can change settings and they are ok. The cache tester works ok too.

    I could of course be something to do with DNS so I'll come back to this later.

  7. john_roberts
    Member
    Posted 3 years ago #

    I work at CloudFlare, and I'd like to make sure we do everything possible so there's no hiccups.

    Questions:

    1) Do any/all of you have the CloudFlare WordPress plugin installed, or (even better) mod_cloudflare installed for Apache? The point is to make sure that your server or application "sees" the original visitor IP, not the CloudFlare IP ranges. I don't know whether WP Super Cache code cares, but it's a good idea anyway, and might eliminate variables. http://www.cloudflare.com/wiki/Log_Files

    2) For the three of you who mentioned settings not staying selected... any other issues to report, or just that? Do you have any CloudFlare beta features enabled? (Rocket Loader or minification of JS/CSS/HTML?)

    John
    CloudFlare

  8. Sean
    Member
    Posted 3 years ago #

    John,

    1) I do not have the CloudFlare WordPress plugin installed (i'm trying to keep my plugins to a minimum and didn't think it was necessary). I am on Dreamhost shared hosting so I'm gonna guess no to the mod_cloudflare apache question.

    2) Haven't noticed any other issues besides this (settings not staying selected). I have "Auto Minify" beta feature turned on and all three checkboxes (JS/CSS/HTML) selected to be minified. So it must be that, because I never enabled Rocket Loader on my sites and still have this issue.

    I am using the latest versions of WordPress (3.2.1) and WP Super Cache (0.9.9.9) by the way, if that matters.

  9. scotttswan
    Member
    Posted 3 years ago #

    1: i'm using the cloudflare wordpress plugin. Haven't tried or heard of the apache mod. will look into it.

    2: its the Auto minify html that is causing this problem. i turned it off and the checkboxes are working now.

  10. john_roberts
    Member
    Posted 3 years ago #

    @Sean - The CloudFlare WP plug in is not required. It's useful if you don't have access to Apache, for the purpose stated: making sure that WP "sees" the visitor IP, which is often used in comment moderation, analytics, etc.

    I'd be curious if you tried turning the Auto-Minify features off and on selectively and see if one or more of them might be related to the problem of settings not staying selected.

    I've asked a colleague to install WP Super Cache on one of our WP demo sites to see if we can replicate problems, once we have it narrowed down a bit.

  11. john_roberts
    Member
    Posted 3 years ago #

    @scotttswan - if you're using CloudFlare WordPress plugin, the Apache mod does the same thing, just at the server level instead of the application (WP) level. So, up to you if you want to take the extra step.

    Useful to hear that Auto-Minify HTML was the problem for you. @Sean, maybe focus your attention on trying that single setting first to confirm?

  12. Sean
    Member
    Posted 3 years ago #

    Thanks John, I will look into the WP plugin.

    I selectively disabled the auto-minify stuff in CloudFlare and can report the same results as scottswan - it's definitely the HTML minify feature that is causing the problem.

    Once I disabled that checkbox in CloudFlare, everything in WP Super Cache works as normal again.

  13. Chris Langille
    Member
    Posted 3 years ago #

    @john_roberts:

    First of all, thank you for responding and shedding some light on this issue.

    I checked with my host (Omnis) and they do not support the mod_cloudflare for Apache. So your saying the plugin will do what mod_Apache does?

    Also, how useful is HTML minify? Does that make a big difference in performance?

    I have selected Auto-Minify for JS/CSS/HTML as well as RocketLoader. I am also running the latest version of WordPress and WP Super Cache, and have had no other issues besides the Advanced Settings not staying selected.

    I just downloaded the Cloudflare plugin. Should I disable WP Super Cache before configuring it, or just turn it on now?

    Thanks again John

  14. Donncha O Caoimh
    Member
    Plugin Author

    Posted 3 years ago #

    clangille - I'd say compression is more important than minifying HTML, but one aspect of minification is reducing multiple css or js files into one which saves requests.

  15. john_roberts
    Member
    Posted 3 years ago #

    @clangille - yes, the WordPress plugin for CloudFlare will do what mod_cloudflare does -- for WordPress alone. The only advantage of mod_cloudflare is if you run multiple applications, like a wiki or forums or anything else, then you only need to make one change. But for WordPress alone, the plugin does the job.

    CloudFlare gzips automatically, so compression is taken care of. The benefits of minification will vary based on your content.

    The WP Super Cache plugin and CloudFlare plugin should have zero impact on each other, so won't matter during configuration.

    Try disabling just the Auto Minify for HTML and see if your results mirror those of others in this post.

  16. Chris Langille
    Member
    Posted 3 years ago #

    Thanks John, I went ahead and disabled the Minify HTML, and sure enough, everything is working inside WP Super Cache.

    Thanks again for your input on this!

  17. john_roberts
    Member
    Posted 3 years ago #

    OK... three consistent results is pretty clear. One of my colleagues is going to look at this specific issue. I'll report back when we have a fix, and hope the helpful trio here can confirm we've gotten it right then. Until then, disabling the HTML selection of Auto Minify is a good workaround.

  18. Chris Langille
    Member
    Posted 3 years ago #

    Thanks John! Looking forward to hearing back from you and the CloudFlare team. You guys rock!

  19. Chris Langille
    Member
    Posted 2 years ago #

    Hey John,

    Any progress on this front? Just thought I'd check back in.

    Thanks a lot!

  20. john_roberts
    Member
    Posted 2 years ago #

    @clangille (and others) --> We've made several updates to Auto Minify code in the past 2 weeks. In our tests, with Auto Minify (JS, CSS, and HTML) and Rocket Loader enabled, everything saves correctly and remains saved.

    Please turn on Auto Minify and report back, please.

    John

  21. Chris Langille
    Member
    Posted 2 years ago #

    Thanks for getting back to us John. I have since switched from WP Super Cache to W3 Total Cache which as you probably know has built in support for CloudFlare. Everything seems to be working fine with W3TC, so I'll have to leave it up to the other folks here to report on WPSC.

    Thanks again

  22. skippybosco
    Member
    Posted 2 years ago #

    John, Just tested and it out and looks like it is displaying and save settings correctly with Auto Minify enabled.

    Thanks for the team's efforts!

  23. john_roberts
    Member
    Posted 2 years ago #

    @skippybosco - thanks for confirming.

    I encourage anyone and everyone using WP Super Cache to also try CloudFlare. They complement each other in many ways.

  24. Chris Langille
    Member
    Posted 2 years ago #

    I encourage anyone and everyone using WP Super Cache to also try CloudFlare. They complement each other in many ways.

    Does the same go for W3 Total Cache?

  25. john_roberts
    Member
    Posted 2 years ago #

    @clangille - yes, CloudFlare also complements W3 Total Cache.

  26. kevin-green21
    Member
    Posted 2 years ago #

    I'm trying to get supercache to play along with cloudflare. Site is much slower since I switched to Cloudflare. Mediatemple my ISP said to disable then re enable Supercache, since somehow the cache wasn't actually being accessed. I'm getting the Time stamp don't match error message above.

    Is there some documentation out there anywhere as to how to get these 2 to work together?

  27. john_roberts
    Member
    Posted 2 years ago #

    @kevin-green21 certainly not the experience anyone would want, or expect...and not one we've heard about before.

    There's no official documentation at this point, although it's a good idea.

    http://support.cloudflare.com is where you can get more help directly from our support team, too.

    John

  28. boatgalley
    Member
    Posted 2 years ago #

    John --

    This is sort of an old thread, but I'd like to second the request for a step by step guide to using Super Cache and CF:

    1. Exactly what to install for a typical site (CF plugin, SuperCache, etc.)

    2. Any changes to be made manually

    3. And -- really importantly -- what settings IN EACH (CF and Super Cache, plus anything else) to start with, then what to move to after seeing that's stable, etc.

    4. It's extemely confusing if you're "just a blogger" and really techy on the caching side of things.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic