WordPress.org

Ready to get started?Download WordPress

Forums

WP strips my uploaded HTML :-( (10 posts)

  1. WPChina
    Member
    Posted 8 years ago #

    I have a website that I send a weekly email newsletter out to my users. I created a WP template that was basically empty so that I could upload the email newsletters and just use the RSS.

    Anyway, the point is that I am pasting all the HTML code form the newsletter into WP and then clicking "Publish". However every time afterwards, WP strips out lots of HTML and causes my email newsletter to be all screwed up. My template has no CSS--it is an empty template. It really just looks like WP is stripping out lots of background colors, tables, and td/tr tags in the email newsletter.

    I tried copying/pasting the HTML using both the WYSIWYG editor and without that editor--both have the problem, so it seems to be a problem with how WP parses and stores the HTML.

    Is there a way around this? I'd like to be able to upload the HTML and have it unchanged by WP.

    Many thanks for your assistance.

  2. WordPress doesn't strip any tags from posts. It's gotta be whatever e-mail thing you're using.

  3. WPChina
    Member
    Posted 8 years ago #

    Hi,
    Thanks for the quick reply.

    It hasn't anything to do with email exactly. I have a webpage that I create in Dreamweaver that I will email to users eventually. However I copy and paste that HTML into WP and code disappears. WP strips the <head>, which I understand needs to happen, but within the body of the html doc that I copy/paste into WP other tags disappear as well.

    The code that disappears seems arbitrary--I have tried on different HTML pages and the same thing happens each time.

    Any idea what could be going on?

    thanks for your help :)

  4. WPChina
    Member
    Posted 8 years ago #

    Ok, I have pinpointed a problem with WP. I am pasting my html into the window, and it is adding
    tags at all the line breaks, which it should not be doing. If I can figure out how to paste HTML directly into the window, then i think it will work fine.

    Is pasting HTML possible?

  5. Bonnylad
    Member
    Posted 8 years ago #

    Not sure whether this is the same type of thing, but I cant paste or create a web address without using the dummy 'link / unlink' buttons, which also leave me wanting to scream as I try and format it properly.

    I find it much easier to fully type out a html link or paste one into a post, yet when I publish the item the html link is unclickable. I then have to go back in and link it to the address, it's a pain.

    Couple this with the image thumbnail uploads problems in numerous other threads is making posting more of a chore than a joy.

    Surely I should be able to write posts the way that I want rather than what WP forces me to?

  6. WPChina
    Member
    Posted 8 years ago #

    right, it seems like part of the same problem.

    I hope there is a way to enable the upload of all HTML without it being parsed and changed. :(

  7. Bytescout
    Member
    Posted 8 years ago #

    Maybe you should try to install "TextControl" plugin so you will be able to turn off default HTML reformatting.

  8. WPChina
    Member
    Posted 8 years ago #

    Ahhhhh... relief!! Yes, it works perfectly. Thank you! :->

  9. Bonnylad
    Member
    Posted 8 years ago #

    Will give it a try, cheers Bytescout :)

  10. Bytescout
    Member
    Posted 8 years ago #

    BTW I found the similar problem with posts added via XML-RPC. WP 2.00 reformatting posts added via XML-RPC automatically and here is a solution:

    http://wordpress.org/support/topic/54927

    Maybe this can help you too.

Topic Closed

This topic has been closed to new replies.

About this Topic