WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] WP. still down (8 days) - Zend optimiser? (29 posts)

  1. arch1
    Member
    Posted 3 years ago #

    Firstly, I have a back up database on Go Daddy and made some on my Wp. db. plugin but cannot access these because my blog is down. I have tried to restore the Go daddy back up on a new WP set up in my databaes on Go Daddy, however, while I can export the database to notepad and save in my docs Im having problems importing it back into the new WP. I get this message:

    unsupported compression
    You attempted to load file with unsupported compression (application/zip). Either support for it is not implemented or disabled by your configuration.

    Secondly, I have tried everything to get my old blog running to no avail.Heres what go daddy support say:

    I have reviewed the entirety of this incident. It is the customers responsibility to maintain their website and keep backups of their information. We will not be able to restore your account free of charge. If there is a problem with the actual server we would be more then happy to assist in this issue. However, nothing indicates there is a problem with the server. Your other sites appear to be functioning without issue. The only site with a problem appears to be the one you attempted to edit and make configuration changes. Changing the domain name within the WordPress Administration panel will bring down the site and make the content appear out of the ordinary. Changing the password for the database will break the connection the site has to the database server. To resolve this you must update your configuration file to the new password.( I have resolved this issue)

    Reviewing the site it does not appear that the current issue is related to these updates. You are now receiving an Internal Server error. To determine the cause of this error you need to review your Error Logs. I have reviewed the error logs and they indicate the below error message.

    Zend Optimizer requires Zend Engine API version 20021010.
    The Zend Engine API version 20050606 which is installed, is newer.
    Contact Zend Technologies at http://www.zend.com/ for a later version of Zend Optimizer.

    This is a scripting issue and we have limited support for scripting related issues. Again we can only verify the server is functioning properly. You can use the previously provided instructions to update and install the latest version of Zend. However, this error is probably caused by a plugin or theme on your site. You can disable all themes and plugins on your site to attempt alleviate the error. You can then enable each one individually to determine the cause of the error. At that time you can either no longer use the plugin or you can follow the instructions to update Zend. The php.ini file should be located within your hosting account. If you do not have one you must create one. If you need information on how to create one you will need to use your favorite search engine to locate more information on this.

    Please let us know if we can assist you in any other way.

    ......................

    I have removed theme and plugins.

    I have changed scrip in php.ini

    Still no joy

    I would appreciate any assistance

    Thanks

  2. keesiemeijer
    moderator
    Posted 3 years ago #

    Can you login here: http://arch1design.com/blog/wp-login.php

    Did you already try:

    - switching to the default theme by renaming your current theme's folder in wp-content/themes using FTP or whatever file management application your host provides.

    - resetting the plugins folder by FTP or whatever file management application your host provides. Sometimes, an apparently inactive plugin can still cause problems.
    - re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress?

    -back up your .htaccess file and then delete it of your server.

  3. arch1
    Member
    Posted 3 years ago #

    yes i can log in http://arch1design.com/blog/wp-login.php

    It goes by default to Twenty Ten 1.1 by the WordPress team

    I've removed all plugins

    I did try -back up your .htaccess file and then delete it of your server. a few days ago but did not work so reinstalled it

    Ive tried uploading database in Go daddy but keep getting

    unsupported compression
    You attempted to load file with unsupported compression (application/zip). Either support for it is not implemented or disabled by your configuration.

    when I try to upload from my docs

    so I suppose ill get the same message if I re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress?

    keesiemeijer I appreciate your help, at least I can get onto admin panel even though I still get Internal Server Error when I want to view posts on there

  4. keesiemeijer
    moderator
    Posted 3 years ago #

    Try putting your permalinks to the default structure or re-saving your permalink structure at Settings >Permalinks in your admin panel.

    Check the "WordPress address (URL)" and "Site address (URL)" under Settings > General

    I will check what the supported compression for database backups is.

  5. arch1
    Member
    Posted 3 years ago #

    Ive just tried to go into Permalinks in my admin panel but just get blank page after a few minutes. All the other pages are ok in settings just pemalinks doesn't show.

    Ive checked the "WordPress address (URL)" and "Site address (URL)" under Settings > General the address in both panels is http://arch1design.com/blog/. One thing I cannot make any changes now, maybe this has something to do with adding some code from codex advice a few days ago

  6. keesiemeijer
    moderator
    Posted 3 years ago #

    If you have the "WordPress address (URL)" and "Site address (URL)" defined in your wp-config.php you cannot alter these in the wp-admin anymore. remove them from your wp-config or change the values there without the last slash: http://arch1design.com/blog

  7. arch1
    Member
    Posted 3 years ago #

    ive change the values to define('WP_HOME','http://arch1design.com/blog');
    define('WP_SITEURL','http://arch1design.com/blog');

  8. keesiemeijer
    moderator
    Posted 3 years ago #

    I see your wp-admin is working again: http://arch1design.com/blog/wp-admin Before it was: http://arch1design.com/blog//wp-admin
    I also don't get the 501 error server message anymore but just a blank page

    Now try the Setting > Permalink page again. Also let's troubleshoot with no plugins active and the default theme.

  9. arch1
    Member
    Posted 3 years ago #

    I still keep getting blank page for pemalink page

  10. arch1
    Member
    Posted 3 years ago #

    I remember changing file in php.ini from original to old zend script should I change back to original zend script?

  11. keesiemeijer
    moderator
    Posted 3 years ago #

    Can you show us what is in your .htaccess file.

  12. keesiemeijer
    moderator
    Posted 3 years ago #

    I don't know what the zend script does exactly, but you can alway's try. But I think this is more a wordpress permalink issue or something with the godaddy server.

  13. arch1
    Member
    Posted 3 years ago #

    # BEGIN WPSuperCache
    # END WPSuperCache

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /blog/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /blog/index.php [L]
    </IfModule>

    # END WordPress

  14. keesiemeijer
    moderator
    Posted 3 years ago #

    That looks ok to me. Now check the file permissions of the wordpress files on the server.
    All directories should be 755 or 750.
    All files should be 644 or 640. Exception: wp-config.php should be 600 to prevent other users on the server from reading it.

    you can see and change the file permissions with the file management application of godaddy: http://help.godaddy.com/article/2323

  15. arch1
    Member
    Posted 3 years ago #

    I'm trying to find file permissions, however Ive got to pick my son up from school and baby, may be a bit difficult to concentrate, will try and get back later or tomorrow. Thanks for your help. If you have any more ideas in mean time post.
    Thanks Ann

  16. keesiemeijer
    moderator
    Posted 3 years ago #

    I have changed scrip in php.ini

    Where and how did you change it?

    Ok, see you later

  17. arch1
    Member
    Posted 3 years ago #

    I went into - my hosting account - hosting control center - File manager - under htlm file name php.ini click on php.ini

    it reads -

    register_globals = off
    allow_url_fopen = off

    expose_php = Off
    max_input_time = 60
    variables_order = "EGPCS"
    extension_dir = ./
    upload_tmp_dir = /tmp
    precision = 12
    SMTP = relay-hosting.secureserver.net
    url_rewriter.tags = "a=href,area=href,frame=src,input=src,form=,fieldset="

    [Zend]
    zend_extension=/usr/local/zo/ZendExtensionManager.so
    zend_extension=/usr/local/zo/4_3/ZendOptimizer.so

  18. arch1
    Member
    Posted 3 years ago #

    still having difficulty finding file permissions in go daddy

    tried ....

    Open a Web browser and go to:
    https://ipaddress:9999/

    Where ipaddress is the IP address of your dedicated server.

    no luck

    tried

    Absolute Hosting Path:

    just get Firefox can't find the server at ipaddress.

  19. arch1
    Member
    Posted 3 years ago #

    I have found file permissions options. They give

    Set permissions for selected files and/or folders.
    Web Visible Allows users to browse files and directories using the Web.
    Executable Allows users to execute files as scripts.

    All directories are web visable and not executable

    The files all vary web visable and some executable

    I have changed wp-config.php to non web visable but still executable

    However there is another option ie advanced permissions

    Web user permissions

    Read Write Execute(Directory)
    Removing the directory execute permission prevents access to the directory's contents.
    Owner permissions

    Read Write Execute(Directory)

    I have left these alone

  20. keesiemeijer
    moderator
    Posted 3 years ago #

    to get rid of the zend errors you can try this the solution here: http://community.godaddy.com/groups/web-hosting/forum/topic/site-keeps-giving-500-errors/

  21. arch1
    Member
    Posted 3 years ago #

    I tried the code earlier

    [Zend]
    zend_optimizer.optimization_level=15
    zend_extension_manager.optimizer=/usr/local/Zend/lib/Optimizer-3.3.3
    zend_extension_manager.optimizer_ts=/usr/local/Zend/lib/Optimizer_TS-3.3.3
    zend_extension=/usr/local/Zend/lib/Optimizer-3.3.3/ZendExtensionManager.so
    zend_extension_ts=/usr/local/Zend/lib/Optimizer_TS-3.3.3/ZendExtensionManager_TS.so

    My server uses
    PHP Version: PHP 4.x

    I`ve tried again and put code back in

    but no luck.

  22. keesiemeijer
    moderator
    Posted 3 years ago #

    Are you sure your server is using php 4? Otherwise try renaming it to php5.ini
    did you create the php.ini or was it already there?
    is the php.ini in the root folder of your website http://arch1design.com/php.ini ?
    Can you delete or rename your .htaccess once more

  23. arch1
    Member
    Posted 3 years ago #

    Not at the moment.

    I tried to log on to my hosting control center and received this message:
    .............
    Current Hosting Account Status: Pending Account Change

    There are changes pending on your hosting account.

    As part of a continuing effort to provide the highest quality service for our valued customers, your hosting account has been migrated to a new server that will provide you with increased performance and reliability. Please note that it can take up to 24 hours from the time the update was completed for any newly-published content to be visible on your Web site.

    ...................

    I will let you know what happens when the process is completed

  24. arch1
    Member
    Posted 3 years ago #

    update..

    They have now moved me to a different hosting account not because of my blog being down but because of a different related matter ......

    It has come to our attention that your hosting account for arch1design.com is causing an overload of the shared resources on this server. This, in turn, affects the server performance for other customers. We have migrated your site to a new server to provide you time to resolve the issue.

    Please note: until this migration completes, your /chinaforum directory will be suspended in order to protect the overall health of the server. This inconvenience is necessary to protect the overall health of our servers.

    .................

    This seems odd as my forum stats read Most Online Today: 1. Most Online Ever: 10 (May 26, 2009, 12:29:15 PM) It could be spam related I recently been having issues with spam posts so I made it read only.

    However, there may be an unrelated issue because as you know I have been experiencing issues with my WP blog. In trying to resolve the issue both Go Daddy and WP support recommend I remove all plugins and themes, as this may be causing the issue.

    Among a plugin I disabled was WP. super cache. I know before the blog went down, from stats, that the blog was experiencing a lot of hits, the day before the it achieved its highest record, around 125 at one given moment.

    Even though the blog is down will this effect things?

    Do I reinstall the plug in ? because the last message I received regarding the blog being down from Go Daddy support was:

    Dear Ann,

    Thank you for bringing this to our attention. The issue you have been experiencing is being worked on by our technicians. Service will return to normal as soon as possible. Unfortunately, we are unable to give a specific time frame for this resolution. We appreciate your patience and understanding in this matter and we apologize for any inconvenience.

    I do not want to hinder progress by reistalling the plugin but at the same time I dont want them to suspend my account?

    Do I just wait?

    Also I dont know if this has anything to do with matters but today I received this message:

    This is a system generated alert to let you know the nameservers were changed/initiated by yourself or an authorized user. If this is a change initiated without your approval, please respond back to us immediately.

    I'm not sure what this means but I told them this was an error?

  25. keesiemeijer
    moderator
    Posted 3 years ago #

    Read the readme.txt from the wp super cache to properly install or uninstall wp super cache.

  26. arch1
    Member
    Posted 3 years ago #

    update...

    yesterday the whole website was down along with the blog

    Go Daddy support sent this.....

    Due to its complex nature, your issue has been relayed to our Advanced Technical Support Team. Our most skilled technicians will be working to resolve your issue quickly and completely. You will be notified promptly upon resolution......

    a few hours later....

    While we cannot advise you how to prevent spammers from negatively affecting your domain, you may wish to use your favorite search engine to review terms such as 'how to block IPs .htaccess'. In regards to the previous emails, in regards to previous issues with your account, I am not seeing anything server related at this time.
    Forrest A.

    Hosting Support Technician
    ............

    So it loks like im back to square one.

    I can get onto my Wp Admin panel
    http://arch1design.com/blog/wp-login.php?redirect_to=http%3A%2F%2Farch1design.com%2Fblog%2Fwp-admin%2F&reauth=1 but cannot access any posts

    I changed zend script now I just get get blank screen.

    The error logs now read

    [Wed Feb 23 00:30:54 2011] [error] [client 62.84.6.211] Premature end of script headers:
    /var/chroot/home/content/a/r/c/archoni/html/blog/index.php
    sh: line 1: host: command not found
    sh: line 1: host: command not found
    sh: line 1: host: command not found
    sh: line 1: host: command not found
    sh: line 1: host: command not found
    sh: line 1: host: command not found

    sh: line 1: host: command not found

    Any ideas?

  27. keesiemeijer
    moderator
    Posted 3 years ago #

  28. arch1
    Member
    Posted 3 years ago #

    Phew..

    I tried above still no luck..

    I then had a rethink and went over the issue again and remembered the blank page in permalinks.

    This was the only issue I had not tried in someway to resolve because I thought it was not showing because it was related to the issue not the cause.

    I did google, found this

    ........

    I found a really simple fix on this forum (via Google of all things) that helped me. It's from a member not a moderator. Thanks, Reginator.

    "...I'll pass along what got my blank pages, posts and permalinks working again. I was trying to use just /%postname%/ as the permalink structure but when I did the whole Permalink Settings page went blank, along with my website. Then after noodling around I did the following and it worked:
    1) Went to phpmyadmin and deleted /%postname%/ from permalink_structure in wp_options. (This brought back my Permalink Settings page in WP)
    2) Set Permalink Structure to Month and name.
    3) Used Custom Permalinks plugin to set my posts link structure."

    .............

    I tried the above, et voilá http://arch1design.com/blog/ has re- emerged from the depths of cyber space black hole albeit with smaller writing down the side bar.

    After the last 2 weeks that's the least of my problems.

    Thanks @keesiemeijer for taking the time to help

  29. keesiemeijer
    moderator
    Posted 3 years ago #

    I'm glad that you solved it and I finally get to see your blog. Well done!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.