WordPress.org

Ready to get started?Download WordPress

Forums

Ultimate TinyMCE
[resolved] WP Spire Plugin Breaks Ultimate TinyMCE (7 posts)

  1. zorosa
    Member
    Posted 2 years ago #

    Hi.

    I just installed Ultimate TinyMCE on my 3rd blog. This must be one of the best plugins I've used. It works really well with the usual plugins I run on my blogs.

    However I have installed WP Spire Plugin along with Ultimate TinyMCE on one of my blogs and when I go to edit or add a new page, the editor isn't loading in the content section.

    If I disable WP Spire Plugin, the editor loads fine and works well.

    Any ideas on what is causing this? I am using the latest versions.

    http://wordpress.org/extend/plugins/ultimate-tinymce/

  2. turkmen
    Member
    Posted 2 years ago #

  3. emazzanti
    Member
    Posted 2 years ago #

    Also breaks with Fancybox Plus and Lightview Plus which are both plugins designed to integrate light box into word press. People with greater design knowledge than I should easily be able to figure out what the conflict is.

  4. Josh (WP Edit)
    Moderator and Editor Customizer
    Plugin Author

    Posted 2 years ago #

    Hmm... I have no idea why a front-end photo viewer would have any affect on ultimate tinymce. Do either of these plugins alter the visual editor in any way? (ie adding a button, or modifying an existing button)?

  5. emazzanti
    Member
    Posted 2 years ago #

    Possibly. That is a logical conclusion. However, when I installed the aforementioned plugins they broke the Ultimate TinyMCE. Therefore I wouldn't know.

  6. zorosa
    Member
    Posted 2 years ago #

    It may be a class conflict similar to what I experienced with Spire.

  7. Josh (WP Edit)
    Moderator and Editor Customizer
    Plugin Author

    Posted 2 years ago #

    Well, I'm the developer of Ultimate Tinymce. I will download one of the above mentioned plugins and see if I can figure out what's going on there.

    Gimme a day or two, and I'll post back here with results.

    I'm not using any classes in Ultimate Tinymce... so I'm not sure that would be the problem.

    My guess is that the mentioned plugins are doing one of the following things:

    1. Trying to add the same button as a button already added via Ultimate Tinymce.
    2. Another plugin is attempting to modify a button already being modified by Ultimate Tinymce.

    Try this in the meantime...

    Activate both plugins... and in the Ultimate Tinymce settings page, disable every single option available.

    Then, see if the visual editor is functioning properly. If it is, you can play around enabling a few options here and there, and watching for the editor to "break". Once it "breaks", you can narrow down the particular button.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic