WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] WP so slow ! (7 posts)

  1. Mario22
    Member
    Posted 5 years ago #

    Hi

    I'm trying to set up a wordpress intranet. The server I use should be strong enough to handle: 15000 rpm hard drive et all.
    Anyway, the site seems reaaly slow. I tried to enable the super cache plugin. It speeds things up a lot, but the administration part is still really slow, and cache expire after an hour so some people will feel the lag.

    I was wondering what is a 'normal' page load time ?
    In the footer comment on my pages I get figures like 45 queries and 3.5 seconds. Does it sound usual ?

    (btw: the server is not online yet so I'm the only user, nothing runs on the machine except apache)

    Thanks.

  2. marvelousstudio
    Member
    Posted 5 years ago #

    My is slow too. Sometimes it works really well. I think there are several issues. One is your connection. The other could possibly be your widgets. They supposedly slow things down. Not sure how to remedy that, but maybe you can find something regarding that. Ask someone on another type of connection to check you blog for you. So if you are on cable, ask someone with dsl.

  3. Mario22
    Member
    Posted 5 years ago #

    Thanks for your inputs, but my server and I are on a local private network, I mean 100Mbs ...
    Actually if I navigate the wordpress from a local firefox (ie firefox running on the same machine as the server) I get the same low performance ..

  4. Mario22
    Member
    Posted 5 years ago #

    I installed WP tuner extension.
    It shows 3 seconds of time spent in widgets_init.
    I disabled every widgets from my site but it did not change anything.
    I mainly use event calendar 3 and next gen gallery. (and I don't use any widget from next gen, only the inline galleries in posts).

    How could I investigate further ?

    I tried to comment out all unneeded calls to widgets_init from the plugins, no success.
    Please help, I'm almost there !

  5. Shane G
    Member
    Posted 5 years ago #

    HI,

    It may be the reason that your server PHP memory is nearer to 100% use so that you may face the issue..so increase the limit of php memory.

    You can do it from PHP.INI file...or you can use plugins for the same and adjust the custom php settings.

    Thanks,

    Shane G.

  6. Mario22
    Member
    Posted 5 years ago #

    Hi Shane, thanks for your input.

    Actually php.ini memory limit is 128M. I raised it to 256 with no effect on page load time.

  7. Mario22
    Member
    Posted 5 years ago #

    !! GOT IT !!

    It was the wp_version_check call. My server doesn't have access to the outside world. I understand there is a plugin to disable this call, but for now a // in front of line 90 in update.php works fine.

    .. phew ..

Topic Closed

This topic has been closed to new replies.

About this Topic