WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] WP-Slimstats Problem (8 posts)

  1. ptvguy
    Member
    Posted 8 years ago #

    I've was setting my site set up and decided to install wp-slimstats for some basic blog stats. However, after I activated this plugin and went to view the new stats, I received the following error:

    Fatal error: Cannot instantiate non-existent class: cachedfilereader in /home/httpd/vhosts/ptvguy.com/httpdocs/wp-includes/wp-l10n.php on line 67
    I went back and deactivated it, but now the whole site is messed up. The main page still looks fine, but clicking links to pages, individual posts, comments, categories, all gets me a 404 error. These all worked fine before. I'm using the Regulus 2.1.3 theme if that makes any difference.

  2. resiny
    Member
    Posted 8 years ago #

    Any chance it did something to your .htaccess file?

  3. ptvguy
    Member
    Posted 8 years ago #

    I didn't even think of that one. I just went and checked and discovered that the .htaccess file was completely removed. I put it back, and now even the home page displays that same fatal error. I tried removing the .htaccess again from the server, but the fatal error still shows up on the home page now. Whatever's wrong is getting worse.

    Addendum: I just reactivated and deactivated the slimstat plugin and got my home page back, but the link problems with the 404 errors are still the same. I would just remove all the slimstat components from my plug-in directory, but I think that part of the activation, included some additions to the database.

  4. resiny
    Member
    Posted 8 years ago #

    Yeah, I don't have much expirience with slimstat, but it does have some issues. You might try contacting the developer (I think it's Shaun Inman, but I can't remember)

  5. ptvguy
    Member
    Posted 8 years ago #

    Thanks, anyway, Resiny. As it turns out, that exact error was covered in the README text file that came with the plugin. I know, it's the first place I should have looked.

    For the curious, you have to open wp-config.php and find this line:

    define ('WPLANG', '');

    and replace it with this line:

    define ('WPLANG', 'en_US');

    Then you have to open the "lang" folder that came with wp-slimstats and rename the file from wp-slimstat-en_US.mo to just en_US.mo. That gets slimstats working.

    However, the rest of the problem (pages, posts, etc. giving 404 errors) is still there. Perhaps it wasn't related to slimstats.

  6. Michael Bishop

    Posted 8 years ago #

    It's not Shaun. He wrote the original code for short stat, but slim stat is a fork. I don't think the author of slimstat wrote the plugin either. The original script can be found here http://wettone.com/code/slimstat and can be used as a stand alone install, with some code in your WP footer (or header) to track the stats.

  7. resiny
    Member
    Posted 8 years ago #

    ah...

    ptvguy: thanks for doing that. Too often people never post what was actually wrong, so people with the same problem come along searching, find all these threads, but never actually find the solution. If everyone did this we'd probably have fewer people unable to find solutions.

  8. ptvguy
    Member
    Posted 8 years ago #

    Well, let me go one better on that, because miklb just answered the other part of the problem in another thread. (http://wordpress.org/support/topic/72243?replies=3) It seems that if you rename a page title and the slug no longer matches the title, it throws everything off. I had to go through my page titles, find the one I renamed, rewrite the slug to match the new name, and {Viola!} everything's fixed and working now. I think that I'm going to like these forums.

Topic Closed

This topic has been closed to new replies.

About this Topic