WordPress.org

Ready to get started?Download WordPress

Forums

WP / Server Permissions problems... (7 posts)

  1. wesburnprimary
    Member
    Posted 4 years ago #

    For four months now, from v2.7.x to now 2.8.4 I am having issues with uploading images onto/through WP. My Serverprovider is mandated, as we are a State school, and they are saying they haven't done anything in that timeline... Argh. Lots of blame-tossing around.

    What happens:
    Uploading text for posts is no problem. Uploading images/video etc reports the problem "Not able to create directory wpcontent\20098 "It's usually about permissions. If I manually create the folder using Filezilla, then WP still can't upload to it. "The uploaded file could not be moved to /{mydetailshere}/wp-content/uploads/2009/08."

    My provider (netspace.net.au) want to blame Wp. It seems that when WP is now creating files/directories it is doing so using the user "Apache Apache", whereas in the past it used our schools username.

    Is there a way to force WP upload scripts to specify the user name when it uploads?

    If this doesn't make sense, ask me more, alternatively if you have any questions I can put to the Server provider staff, please let'em have im! Thank you so much for your time.

    I think it's their issue, but they are asking whether it is possible in WP to force

  2. Shane G
    Member
    Posted 4 years ago #

    Hi,

    Check with these options:

    -> Disable all the plugins and enable it one by one to find out the culprit one
    -> Assign 766 recursive permissions to wp-contents folder of your blog
    -> Make sure that you have set proper path for media upload from wordpress admin area -> settings -> miscellaneous settings.

    Thanks,

    Shane G.

  3. wesburnprimary
    Member
    Posted 4 years ago #

    Thanks Shane, Unfortunately I haven't had any luck with that.
    Permissions are all now at 766, (were at 777 in desperation to solve this)
    Deactivated all plugin-'s and it's still not working.
    I have tried the flash uploader and brwoser uploader.

    No luck, I still get the message
    Unable to create directory /(site)/httpdocs/wp-content/uploads/2009/08. Is its parent directory writable by the server?

    Any ideas? thanks

  4. iridiax
    Member
    Posted 4 years ago #

    See: http://codex.wordpress.org/Using_Image_and_File_Attachments

    Prerequisite for Uploading Files
    In order to use all these tools, you have to change the chmod of wp-content folder to 777. If you have not changed permissions in order to write in wp-content folder, you will not be able to use the uploader.

    If this does not work, try deselecting the "Organize my uploads into month- and year-based folders" option:

    http://codex.wordpress.org/Settings_Miscellaneous_SubPanel

  5. Kailash
    Member
    Posted 4 years ago #

    My provider (netspace.net.au) want to blame Wp. It seems that when WP is now creating files/directories it is doing so using the user "Apache Apache", whereas in the past it used our schools username.

    Is there a way to force WP upload scripts to specify the user name when it uploads?

    Your upload files get Apache:Apache ownership because your provider is not using suPHP and they are running PHP as a DSO (Dynamic Shared Object). There is nothing to do with WP. It is related to server setting. If PHP runs as a Apache user, all files/folders uploaded via PHP script will get Apache ownership instead of user ownership.

    Kailash

  6. wesburnprimary
    Member
    Posted 4 years ago #

    Kailash, thank you!
    I have no real understanding of what this means yet, but I'm sure i will soon, and at least now I can ask the provider some intelligent questions back.
    Many thanks for your help!
    Luke

  7. Jokesta
    Member
    Posted 4 years ago #

    I was having the same problem and searched high and low for a solution.

    In the end setting the user for my entire wordpress installation folder to apache worked like a charm.

    Run this command.

    chown apache -R [wp directory]

    this changes the owner of all the files/directory in the WP install to apache.

Topic Closed

This topic has been closed to new replies.

About this Topic