WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] wp-rss.php invokes download instead of displaying as rss (5 posts)

  1. jpostman
    Member
    Posted 8 years ago #

    Anyone with ideas on the following problem?

    My wp-feed.php displays valid RSS, but others do not. Instead, they invoke a download of a file called "wp-rss.php" which is empty.

    Working:

    http://www.hydeparkassociates.com/blog/wp-feed.php displays valid XHTML RSS feed

    Not Working:

    http://www.hydeparkassociates.com/blog/wp-rss.php

    http://www.hydeparkassociates.com/blog/wp-rss2.php

    I have verified that all of the .php files are at the root level for the blog and that they are not corrupted

  2. TechGnome
    Moderator
    Posted 8 years ago #

    Well something is certanly going on. When I clicked the link to the wp-feed.php page, I got redirected to a different page telling me all about RSS feeds and how to read them. While usefull, not at all what I expected to happen.

    When I clicked the other links, it didn't ask me to d/l any files, but I got a blank page... and I mean NOTHING... even when I View Source... there was nothing there.... So.... it's possible that your RSS files are infact corrupt and are transmitting the wrong content type (causing the browser to attempt a d/l) OR... you've got some content that is breaking it, resulting in the odd-ball antics here.

    -tg

  3. jpostman
    Member
    Posted 8 years ago #

    Sorry, the wp-feed is redirected to Feedburner. I can turn that off in .htaccess. My site validates as strict XHTML, don't know if that matters. I get about 3500 hits a month on the wp-feed page.

    I replaced the other wp-rss.php and wp-rss2.php files from a fresh copy of WordPress 1.5.2, but that doesn't seem to help.

    Do they need to be "enabled" in my header.php or index.php files?

  4. jpostman
    Member
    Posted 8 years ago #

    Hi TechGnome,

    Don't know if you have any other thoughts on this. I turned off the redirect so http://www.hydeparkassociates.com/blog/wp-feed.php displays valid XHTML RSS feed, but the others do not

    http://www.hydeparkassociates.com/blog/wp-rss2.php
    http://www.hydeparkassociates.com/blog/wp-rss.php

    Thanks,

    Joel

  5. jpostman
    Member
    Posted 8 years ago #

    This is fixed. I replaced wp-blog-header.php with an updated version I found at:

    http://fernando.dubtribe.com/archives/2005/05/10/solution-to-wp151-rss-errors/

Topic Closed

This topic has been closed to new replies.

About this Topic