WordPress.org

Ready to get started?Download WordPress

Forums

WP Publication Archive
[resolved] WP-Publication Archive Activation Error (14 posts)

  1. dacinto
    Member
    Posted 1 year ago #

    Can someone help me please? I am getting the error below each time I try to activate WP-Publication Archive plugin and I really have no clue whats going wrong here. I have tried to disable the 2 plugins I have currently installed, ie. WP Filebase and Spectacula Discussion and tried even on a fresh install of WordPress but still had the error pop up. Please assist. Thanks!

    ( ! ) SCREAM: Error suppression ignored for
    ( ! ) Parse error: syntax error, unexpected end of file in C:\wamp\www\washted\wp-content\plugins\wp-publication-archive\lib\class.wp-publication-archive.php on line 765
    Call Stack
    # Time Memory Function Location
    1 0.0015 252696 {main}( ) ..\plugins.php:0
    2 6.9594 12868280 plugin_sandbox_scrape( ) ..\plugins.php:149
    3 6.9609 12885960 include( 'C:\wamp\www\washted\wp-content\plugins\wp-publication-archive\wp-publication-archive.php' ) ..\plugins.php:147

    http://wordpress.org/extend/plugins/wp-publication-archive/

  2. Eric Mann
    Member
    Plugin Author

    Posted 1 year ago #

    Nice catch.

    This was caused by some extra whitespace that somehow made its way in after the closing ?> tag in that file. I've gone through and tightened up the file endings for the whole plugin to fix the issue.

    Update to version 2.5.2 of the plugin and give it another shot.

  3. dacinto
    Member
    Posted 1 year ago #

    Thanks Eric, I went ahead and downloaded the updated version and was faced with similar error during activation, see below. Thanks

    ( ! ) Parse error: syntax error, unexpected end of file in C:\wamp\www\washted\wp-content\plugins\wp-publication-archive\lib\class.wp-publication-archive.php on line 764
    Call Stack
    # Time Memory Function Location
    1 0.0017 252696 {main}( ) ..\plugins.php:0
    2 0.2722 12866352 plugin_sandbox_scrape( ) ..\plugins.php:149
    3 0.2727 12884000 include( 'C:\wamp\www\washted\wp-content\plugins\wp-publication-archive\wp-publication-archive.php' ) ..\plugins.php:147

  4. Eric Mann
    Member
    Plugin Author

    Posted 1 year ago #

    OK, this is strange because I've tested it myself on multiple systems and cannot reproduce the error.

    I see you're using WAMP (from the include line in your call stack). Is this a development system or a live server?

  5. dacinto
    Member
    Posted 1 year ago #

    Eric, this is on a development server and I am using WordPress 3.5. Strangely enough WP Archive Publication version 2.3.3 activates fine without any hurdles.
    Thanks

  6. Eric Mann
    Member
    Plugin Author

    Posted 1 year ago #

    That's because version 2.3.3 is an entirely different thing.

    From the looks of the error message, your system thinks there's extra whitespace after the closing ?> in the wp-publication-archive.php file. To try to fix this, please edit your file to remove the closing ?> entirely.

  7. dacinto
    Member
    Posted 1 year ago #

    Eric, thanks will do that and revert back.

  8. BigFish04
    Member
    Posted 1 year ago #

    Hello Eric,
    I have the same problem (use WAMMP also). I tried do do as you advice but did not help.
    This is the message I receive.

    SCREAM: Error suppression ignored for
    ( ! ) Parse error: syntax error, unexpected $end in C:\wamp\www\Website\wordpress\wp-content\plugins\wp-publication-archive\lib\class.wp-publication-archive.php on line 765

    Call Stack
    # Time Memory Function Location
    1 0.0023 606176 {main}( ) ..\plugins.php:0
    2 0.3883 26119064 plugin_sandbox_scrape( ) ..\plugins.php:156
    3 0.3888 26154392 include( 'C:\wamp\www\Website\wordpress\wp-content\plugins\wp-publication-archive\wp-publication-archive.php' ) ..\plugins.php:154

    I do not know anything about Php..

    Thx for your help
    Frans

  9. Eric Mann
    Member
    Plugin Author

    Posted 1 year ago #

    @BigFish04 Thanks for confirming. This looks to be a WAMP-specific issue, and I'll see what I can do to debug it and get a fix published.

  10. Eric Mann
    Member
    Plugin Author

    Posted 1 year ago #

    I've taken a much closer look at the code and did find an extra space after a closing ?> tag.

    When you can, please update to version 2.5.7 as it contains the fix. I've removed closing ?> tags in general from files where they're not needed in hopes that we can prevent this problem in the future.

  11. BigFish04
    Member
    Posted 1 year ago #

    Hello Eric,
    Thx for your fast service.
    Unfortunately I still received a fatal error.
    Parse error: syntax error, unexpected $end in C:\wamp\www\Website\wordpress\wp-content\plugins\wp-publication-archive\lib\class.wp-publication-archive.php on line 776

    BUT, I tried to look for incosistencies in the file and I found one. in line 427. <? was something I could not find in google help topics, so I tried to <?php. And now it worked......

    I do not know anything about php so I hope I did not mess up the file, but it seems to be working....

    All the best, Frans

  12. Eric Mann
    Member
    Plugin Author

    Posted 1 year ago #

    Wow ... I really messed that up. <? is what's known as a PHP shorttag, it's a developer shortcut so we can be lazy and don't have to write <?php every time.

    I never use shorttags and have my system set up to yell at me if I do (because some servers disallow them). But I turned off my warnings to debug someone else's code and apparently forgot to turn it back on.

    Changing <? to <?php won't break anything, and is the exact fix I'll ship with the next update. Thanks!

  13. Eric Mann
    Member
    Plugin Author

    Posted 1 year ago #

    Shipping version 2.5.7.2 with this fix now.

  14. BigFish04
    Member
    Posted 1 year ago #

    Thx!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic