WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] WP Post Rich Text Editor fails to load (13 posts)

  1. jojo0507
    Member
    Posted 7 years ago #

    I have some kind of problem with WPs editor for posts. Meaning the editor that is used when the blog owner composes a post online from their site.

    Normally I'd see the text input box, and over it, a panel with some formatting buttons, such as Bold, URL, "insert picture" and "view HTML".

    Now I cannot see these anymore.
    It DOES NOT appear to be a settings issue;
    I already checked Options >Write > "Users should use the visual rich editor by default" e in the WP control panel.

    I tried to both settings since I am
    not sure which setting gives me the panel that I want.

    The page appears to try to load the buttons, but then ends up loading empty buttons that are useless.

    I see this behaviour in 4 browsers: FF, IE7 Opera and Seamonkey.

    What could be going on and how can I fix it?
    I need to be able to access the HTML for the posts!

    My site/theme is under development but now 99% complete. It is at http://www.vikingprincess.net

  2. Chris_K
    Member
    Posted 7 years ago #

    I tried to both settings since I am
    not sure which setting gives me the panel that I want.

    It sounds like you want it checked. That would give you the fancy WYSIWYG editor.

    A screen shot of what you DO see would be helpful though.

    Have you installed any new "security suites" on your local computer recently? Or, more useful maybe, have you tried from multiple computers?

  3. jojo0507
    Member
    Posted 7 years ago #

    Hi ! Thanks for responding!

    I have tried both settings.
    None load the buttons anymore. Previously they were loaded by default.

    I have not installed any security settings.

    I have not tried from another computer - I only have access to one at home. But since I tried different browsers, I would have thought I'd pick up any funny settings problem that way? I haven't rebooted the machine though, so I'll do that now.

    I just upgraded (via Dreamhost) to the latest version of
    WP. I think it was 2.0.5.

  4. jojo0507
    Member
    Posted 7 years ago #

    Just to clarify. I upgraded WP specificually because I was hoping it would help solve this problem but there was no difference.

    I just rebooted my machine and there is no improvement.
    Can't think what it could be!
    If the WP installation was corrupted it should have been fixed in the upgrade that I carrried out.

    The problem is that I need that editor to compose posts and edit the HTML in the posts that I make. It is also the only way i am aware of to actually post to a WP blog.

    I am just developing the theme right now and want to try out how different html comes out.

    Not sure what step to take next. Ideally I'd like some help to confirm that the problem occurs on another machine than my own

  5. moshu
    Member
    Posted 7 years ago #

    FYI: the rich text editor (also known as wysiwig) will kill all your html editing.
    If you want your own html - then definitely disable that monster...

  6. jojo0507
    Member
    Posted 7 years ago #

    Haha well I really only used it to add CSS classes to non-text items that I wanted to add to the post, like pics and table. (I hate silly web based wysywyg editors too, but I am not aware of alternatives in this situation? )

    Anyway, I am finding that some other people had similar problems to what I am having. You helped somebody here..
    http://wordpress.org/support/topic/89728?replies=18

    I am researching and trying to understand....The behaviour smells like corruption because it displays the little jpeg icons for various editing tasks, then decides not to load them after all and displays very small buttons with no icons and no associated action.

  7. Chris_K
    Member
    Posted 7 years ago #

    Well, the reason I suggested trying from another computer is that we've found some "security suites" got a little over-zealous and "protect" you from the javascript on the pages (regardless of browser settings).

    You're saying that regardless of if the "Visual Rich Editor" is on or off you don't see any of the editor buttons?

  8. jojo0507
    Member
    Posted 7 years ago #

    Based on a number of posts by a member called Ahhh, I am getting the impression that this must be some kind of bug or bug-like behcaiour in WP. There seemed to be no logic in how and when the problem was happening for that user.

    There is some kind of connection with a setting for RSS feeds, so I'll try toggling a few settings on and off.

    If there are alternative ways of posting to the WP blog while still having access to things like Categories and features on the 'Write " and Edit" post pages from WP I'd really like to know about them.

    Not to keen on that wysiwyg editor

  9. jojo0507
    Member
    Posted 7 years ago #

    "You're saying that regardless of if the "Visual Rich Editor" is on or off you don't see any of the editor buttons?"

    Yes, that's what I am saying.

    It cannot be interference of a security suite.
    I use next to no security on my machine.
    I have worked in IT for quite a while and know what a snake pit such apps usually are.
    Common sense and knowledge protects better, and I do use the Windows firewall.

    I don't use any other security and never have security problems other than dodgy cookies according to online virus scans.

  10. jojo0507
    Member
    Posted 7 years ago #

    I found that there is a setting on the "User" tab in WP admin that is relevant for this problem.

    The setting is

    Personal Options
    Use the visual rich editor when writing.

    If I untick this, a different menu is available in the Write Post tab.

    This meny has buttons for tags instead of Rich type edit style icons.

    I guess that means I CAN manipulate the text I upload to the blog, so it is a step in the right direction.

    I think that the Rich text icons are broken for me, possibly because of some bug in that WP page which that I have triggered.

    The problem occurs regardless of what browser I am in, or what theme I use. It continued after I rebooted.

  11. vkaryl
    Member
    Posted 7 years ago #

    Hey princess - I don't know if anyone ever suggested this: delete the entire wp-includes folder from your installation, and upload an entire new wp-includes folder from a fresh download of the 2.0.5 distro (see top of page, Download link). Dunno if that would help, but couldn't hurt.

  12. jojo0507
    Member
    Posted 7 years ago #

    Hi! Good suggestion! I just did exactly what you suggested and the problem disappeared. Thank you very much! :-)

    Solution:
    Delete the entire wp-includes folder from your installation, and upload an entire new wp-includes folder from a fresh download of the 2.0.5 distro (see top of page, Download link).

  13. vkaryl
    Member
    Posted 7 years ago #

    Very glad it worked! There are times when that doesn't work, but in this case, it did. Have fun!

Topic Closed

This topic has been closed to new replies.

About this Topic