WordPress.org

Ready to get started?Download WordPress

Forums

WP jQuery Lightbox
WP-Polls breaks wp-jquery-lightbox (6 posts)

  1. Paul Kerins
    Member
    Posted 2 years ago #

    Hi ulfben
    I just wanted to let you know that the WP-Polls plugin breaks wp-jquery-lightbox. Also I wanted to say thanks for the great plugin.
    cheers
    Paul
    http://www.paulkerins.com/blog

    http://wordpress.org/extend/plugins/wp-jquery-lightbox/

  2. Wigid Triyadi
    Member
    Posted 2 years ago #

    Hi Paul
    I have same problem with wp-polls and all Jquery features.
    Since wp-poll write additional header to all wp pages and those header generating conflict with all jquery on the system.

    I hope the author notice with this problem.

    I'm trying to localize the problem or event find the solution, ill update you I find the solution.. (I hope soon)

  3. Paul Kerins
    Member
    Posted 2 years ago #

    Hi Wigid
    Thanks for replying. I would be interested in a solution if you find one, let me know. Due to the nature of my blog wp-jquery-lightbox is far more important to me than WP-Polls, so I can live without WP-Polls, but it would be nice to be able to use it to.

  4. ulfben
    Member
    Plugin Author

    Posted 2 years ago #

    ... this seems to be a problem with WP-Polls so you should perhaps tag the thread with the correct plugin?

  5. Wigid Triyadi
    Member
    Posted 2 years ago #

    Hi Paul, because of time constraints, I just had time trying to find a solution of this problem.
    There are two possibilities that causing jquery fails in execution:
    1. If you add the javascript library directly in header.php, there is likely a reference jquery called twice.
    2. Jquery Reference was called after the lightbox or wp-poll javascript , you can check it via view source.

    because my limited skill of javascript management order on the header, then my solution are :
    1. Add the jquery reference into header.php manually.
    After <head> i put <script type='text/javascript' src='/wp-includes/js/jquery/jquery.js?ver=1.7.1'></script>

    2. Modifying/removing scripts that generate jquery reference.
    open wp-polls.php
    line 202 delete wp_print_scripts('jquery');
    line 224
    from wp_enqueue_script('wp-polls', plugins_url('wp-polls/polls-js.js'), array('jquery'), '2.50', true);
    into wp_enqueue_script('wp-polls', plugins_url('wp-polls/polls-js.js'), array('jquery'), true);
    line 243
    wp_enqueue_script('wp-polls-admin', plugins_url('wp-polls/polls-admin-js.js'), array('jquery'), '2.50', true);
    wp_enqueue_script('wp-polls-admin', plugins_url('wp-polls/polls-admin-js.js'), true);

    its not perfect, but hopefully it helps

  6. kn00tcn
    Member
    Posted 2 years ago #

    good stuff, now to find what the other plugin i have that's loading an old jq version

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic