WordPress.org

Ready to get started?Download WordPress

Forums

WP-Piwik
[resolved] WP-Piwik - Statistics Are Not Being Sent (5 posts)

  1. hardraada
    Member
    Posted 7 months ago #

    I have seen some similar posts, but none seems to be my case exactly. I have WordPress and Piwik set up on a separate subdomains (cms.mydomain.com and analytics.mydomain.com). I have WordPress publishing static pages to the root (www.mydomain.com).

    I set Piwik up with a new user that has "view" access to my site (it is pointing at http://www.mydomain.com rather than WordPress). In the WP-Piwik configuration I have added "analytics.mydomain.com" and the token for the new user. I am receiving the error message: "Please check URL and auth token. You need at least view access to one site."

    When I click on the "Support" link, it says that cURL is available and allow_url_fopen is enable. When I run the test script it us successful. When I take the URLs our of the test result and paste them in Chrome with the correct token, they return the same XML messages. When I click on site configuration details, they are successfully and correctly returned except that "ID" is a dash (Site ID is correct). I have tried resetting WP_Piwik settings once to no avail.

    The end result is that Piwik JavaScript is injected into each page and when published, the static pages have it as well but no statistics are showing in Piwik. I have tried surfing the site with a couple of browsers to make sure it is not the ignore cookie. The only thing that I see is that a semicolon is missing from the script WP-Piwik inserts - otherwise it is identical to the one in Piwik. I have copied the Piwik script and manually added it to my footer and disabled WP-Piwik, but there is no difference.

    Any ideas on what I am missing?

    Thanks,
    Erich

    http://wordpress.org/plugins/wp-piwik/

  2. braekling
    Member
    Plugin Author

    Posted 7 months ago #

    Did you try to disable WP-Piwiks caching functionality (see tracking settings) and to reload the Piwik settings page?

  3. ralfjani
    Member
    Posted 7 months ago #

    I have the same error here.

    Disabling the caching function is a nice workaround.
    I think it would be helpful if a error was found to reload the caching data.

    BTW: Thanks for that great Plugin!

  4. braekling
    Member
    Plugin Author

    Posted 6 months ago #

    After you disabled the caching and everything is working again, you can re-enable caching. There is just an annoying bug so the cache won't be cleared after changing the Piwik data. It is fixed in 0.9.7 which I am working on.

  5. braekling
    Member
    Plugin Author

    Posted 6 months ago #

    --- Sorry for double posting ---

Reply

You must log in to post.

About this Plugin

About this Topic