WordPress.org

Ready to get started?Download WordPress

Forums

WP-Piwik
[resolved] WP-Piwik Fails to connect to Piwik install (4 posts)

  1. lakesidechurch
    Member
    Posted 1 year ago #

    I am running wordpress 3.5.2 with a Piwik version 1.12 install. It is running version 0.9.9.6 of wp-piwik. I get the "An error occured: Piwik did not answer. Please check your entered Piwik URL." message on this site.

    I have one site (a wordpress 3.5 install, I haven't updated it yet) running version 0.9.7 of the plugin, and it works great. I have tried copying the URL and my API key from this site to the one that isn't working to make sure the settings are right, but it still gives me the error.

    If I run the test script under the support tab (on the problem site), both tests return "HTTP/1.1 200 OK", so the plugin seems to be able to connect to my Piwik server, but it doesn't think that it is working. The html returned also looks correct, with the first test returning the details on all my sites in piwik and the second test returning the correct site ID.

    I have tried the 0.9.7 version of wp-piwik on the 3.5.2 site that is giving me trouble and it works great. So I assume it is some sort of compatibility problem between WP 3.5.2 and wp-piwik 0.9.9.6. Infact, none of the plugins after 0.9.9.1 work for me (some make nothing but blank pages show, others have activation errors and the later ones [0.9.9.4+] give the same error as I am having with the latest version).

    Any suggestions for things to try to solve this would be really appreciated!
    Thanks,
    Jacob

    http://wordpress.org/extend/plugins/wp-piwik/

  2. braekling
    Member
    Plugin Author

    Posted 1 year ago #

    Did you try to disable the cache? (Settings -> Tracking -> Disable cache)

  3. lakesidechurch
    Member
    Posted 1 year ago #

    I can't find an option for disabling the cache. I went to the settings page for WP-Piwik, went to the tracking tab, and looked for a disable cache option but couldn't see anything about caching. That is where you mean right?

  4. lakesidechurch
    Member
    Posted 1 year ago #

    I was just trying some things, and I uninstalled wp-piwik and reinstalled it using the built in installer method (I just fixed my FTP settings, before I was uploading the wp-piwik folder to a different directory and then moving it in place via SSH). Now it shows the cache setting on the tracking tab!?

    With caching turned off, it works great. I am not sure what happened or why the cache option suddenly showed up, but thank you for the help!

    Jacob

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic