WordPress.org

Ready to get started?Download WordPress

Forums

WP-Pagenavi aint working with Static Page (5 posts)

  1. Elie Herrera
    Member
    Posted 5 years ago #

    Hey everybody!

    Im using a custom theme for my wordpress installation where i have included many plugins like wp-pagenavi. The installation of wordpress is running in my root folder and have configured the permalinks to use a custom structure: /%postname%/

    I have a static page for the frontpage or home and where the reading setting say: Front page display. I have selected my static page and for the posts page a new page called "blog"

    Wp-pagenavi works perfectly in other category than the one selected for the posts in reading settings. When we enter blog page with posts, it shows me 2 pages, when i click next page this one reload page 1.
    Link: http://www.eliements.com/blog/

    What do i have to do to use the plugin with this static page option?

  2. Ian Stewart
    Theme Wrangler
    Posted 5 years ago #

    I'm also having the same problem. You can see it on ThemeShaper.

  3. Lester Chan
    Member
    Posted 5 years ago #

    It will not work with Static Page, the default WordPress Navigation also will not work with Static Pages.

  4. Ian Stewart
    Theme Wrangler
    Posted 5 years ago #

    Actually, it won't work with static pages and a custom permalink of /blog/%postname%/ (in my case). There's a bug fix in trac for 2.8. I changed my permalinks and the plugin works fine.

    Thanks for the awesome plugin, Lester.

  5. Lester Chan
    Member
    Posted 5 years ago #

    Cool thanks for the heads up, I didn't knew about that.

    I normally create templates for Static Pages and it works there, http://forums.lesterchan.net/index.php/topic,3114.0/p,5.html

Topic Closed

This topic has been closed to new replies.

About this Topic