WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] WP Own Directory, need to access General panel (3 posts)

  1. Franksplace2
    Member
    Posted 1 year ago #

    Hi,

    I have re-installed WP and moved it to its own directory (wp)based on the Codex.

    I need to access the General panel but I cannot access the dashboard.

    How do I open the General panel in order to change the URL?

    http://stmichaelspecialschool.com/wp/

    Thanks

    Frank

  2. jonradio
    Member
    Posted 1 year ago #

    Have you tried to login from here?
    http://stmichaelspecialschool.com/wp/wp-login.php

    At first glance, things might be in such a state that you have to use one of the other techniques for changing the URLs. I find this one to work the best:

    If you forget to change the WordPress Address and Blog Address, you will be unable to change it using the wordpress interface. However, you can fix it if you have access to the database. Go to the database of your blog and find the wp_options table. This table stores all the options that you can set in the interface. The WordPress Address and Blog Address are stored as siteurl and home (the option_name field). All you have to do is change the option_value field to the correct URL for the records with option_name=’siteurl‘ or option_name=’home‘.

    ref. - http://codex.wordpress.org/Moving_WordPress#If_you_forget_to_change_the_locations

  3. Franksplace2
    Member
    Posted 1 year ago #

    jonradio,

    I did this:
    "If you have accidentally changed your WordPress site URL

    Suppose you accidentally changed the URIs where you cannot move the files. (but still can access the login page, through a redirection or something)

    wp-login.php can be used to (re-)set the URIs. Find this line:
    require( dirname(__FILE__) . '/wp-load.php' );

    and insert the following lines below:
    //FIXME: do comment/remove these hack lines. (once the database is updated)
    update_option('siteurl', 'http://your.domain.name/the/path' );
    update_option('home', 'http://your.domain.name/the/path' );"

    and it worked! Thank you!

Topic Closed

This topic has been closed to new replies.

About this Topic