WordPress.org

Ready to get started?Download WordPress

Forums

wp-openid 2.8.1 + wp 2.5 + etch adding identity does not work (6 posts)

  1. crosser
    Member
    Posted 6 years ago #

    I have WP 2.5 installed on Debian etch (PHP4). Installed and enabled wp-openid 2.1.8. Settings -> Wp-Openid shows this status:

    Status information: All Systems Nominal (Toggle More/Less)
    
    [INFO] Include Path
        /var/www/htdocs/blog/wp-content/plugins/openid/
        /usr/share/php/
        /usr/share/pear/
    [INFO] WordPress version
        2.5
    [INFO] MySQL version
        5.0.32
    [INFO] PHP version
        4.4.4-8+etch4
    [INFO] PHP memory limit
        32M
    [OK] Curl Version l. SSL: l. zlib: l. Supports: l.
    [FAIL] library: GMP compiled into in PHP
        GMP does not appear to be built into PHP. This is highly recommended for performance reasons.
    [OK] library: BCMath compiled into in PHP
    [INFO] Cryptographic Randomness Source
        /dev/urandom
    [INFO] Plugin Revision
        svn-37878
    [INFO] Plugin Database Revision
        Plugin database is currently at revision 24426.
    [OK] Overall Plugin Status

    When trying to add openid identity to my account, the openid provider is being queried (I need to enter userid/password to the provider), and then I am taken back to "users" page. No identity is added to the account. In the tables, wp_openid_associations gets one row, but wp_openid_identities and wp_openid_nonces are empty.

    If I turn on WP_DEBUG, and try to add identity, I get this:

    Notice: Undefined index: admin_menu in /var/www/htdocs/blog/wp-includes/plugin.php on line 583
    
    Notice: Undefined index: activate_openid/core.php in /var/www/htdocs/blog/wp-includes/plugin.php on line 583
    
    Notice: Undefined index: deactivate_openid/core.php in /var/www/htdocs/blog/wp-includes/plugin.php on line 583
    
    Notice: Undefined index: wp_authenticate in /var/www/htdocs/blog/wp-includes/plugin.php on line 583
    
    Notice: Undefined index: preprocess_comment in /var/www/htdocs/blog/wp-includes/plugin.php on line 583
    
    Notice: Undefined index: comment_post in /var/www/htdocs/blog/wp-includes/plugin.php on line 583
    
    Notice: Undefined index: option_require_name_email in /var/www/htdocs/blog/wp-includes/plugin.php on line 583
    
    Notice: Undefined index: comments_array in /var/www/htdocs/blog/wp-includes/plugin.php on line 583
    
    Notice: Undefined offset: 15 in /var/www/htdocs/blog/wp-includes/plugin.php on line 583
    
    Notice: Undefined index: clean_nonce in /var/www/htdocs/blog/wp-content/plugins/openid/Auth/OpenID/SQLStore.php on line 276
    
    Notice: Undefined index: clean_nonce in /var/www/htdocs/blog/wp-content/plugins/openid/Auth/OpenID/SQLStore.php on line 282
    
    Notice: Undefined index: clean_assoc in /var/www/htdocs/blog/wp-content/plugins/openid/Auth/OpenID/SQLStore.php on line 276
    
    Notice: Undefined index: clean_assoc in /var/www/htdocs/blog/wp-content/plugins/openid/Auth/OpenID/SQLStore.php on line 282
    
    Notice: Only variables should be assigned by reference in /var/www/htdocs/blog/wp-content/plugins/openid/logic.php on line 130
    
    Notice: Undefined index: delete_user in /var/www/htdocs/blog/wp-includes/plugin.php on line 583
    
    Notice: Undefined index: login_head in /var/www/htdocs/blog/wp-includes/plugin.php on line 583
    
    Notice: Undefined offset: 9 in /var/www/htdocs/blog/wp-includes/plugin.php on line 583
    
    Notice: Undefined index: get_comment_author_link in /var/www/htdocs/blog/wp-includes/plugin.php on line 583
    
    Notice: Undefined index: login_form in /var/www/htdocs/blog/wp-includes/plugin.php on line 583
    
    Notice: Undefined index: register_form in /var/www/htdocs/blog/wp-includes/plugin.php on line 583
    
    Notice: Undefined index: login_errors in /var/www/htdocs/blog/wp-includes/plugin.php on line 583
    
    Notice: Undefined index: settings_page_global-openid-options in /var/www/htdocs/blog/wp-includes/plugin.php on line 583
    
    Notice: Undefined index: users_page_openid in /var/www/htdocs/blog/wp-includes/plugin.php on line 583
    
    Notice: Undefined index: admin_head-users_page_openid in /var/www/htdocs/blog/wp-includes/plugin.php on line 583
    
    Notice: Undefined index: load-users_page_openid in /var/www/htdocs/blog/wp-includes/plugin.php on line 583
    
    Notice: Undefined variable: s in /var/www/htdocs/blog/wp-includes/functions.php on line 1707
    
    Notice: Undefined variable: s in /var/www/htdocs/blog/wp-includes/functions.php on line 1707
    
    Notice: Undefined variable: s in /var/www/htdocs/blog/wp-includes/functions.php on line 1707
    is deprecated since version Use instead.
    Notice: 58 in /var/www/htdocs/blog/wp-includes/functions.php on line 1707
    
    Notice: Undefined index: clean_nonce in /var/www/htdocs/blog/wp-content/plugins/openid/Auth/OpenID/SQLStore.php on line 276
    
    Notice: Undefined index: clean_nonce in /var/www/htdocs/blog/wp-content/plugins/openid/Auth/OpenID/SQLStore.php on line 282
    
    Notice: Undefined index: clean_assoc in /var/www/htdocs/blog/wp-content/plugins/openid/Auth/OpenID/SQLStore.php on line 276
    
    Notice: Undefined index: clean_assoc in /var/www/htdocs/blog/wp-content/plugins/openid/Auth/OpenID/SQLStore.php on line 282
    
    Notice: Only variables should be assigned by reference in /var/www/htdocs/blog/wp-content/plugins/openid/logic.php on line 130
    
    Notice: Undefined variable: openid_auth_request in /var/www/htdocs/blog/wp-content/plugins/openid/logic.php on line 429
    
    Notice: Undefined property: identity_url in /var/www/htdocs/blog/wp-content/plugins/openid/logic.php on line 464
    
    Warning: Cannot modify header information - headers already sent by (output started at /var/www/htdocs/blog/wp-includes/plugin.php:583) in /var/www/htdocs/blog/wp-includes/pluggable.php on line 689

    Please advice.

    Eugene

  2. crosser
    Member
    Posted 6 years ago #

    I found solution in this forum: I followed advice by Aliaksei Harabchuk in the topic http://wordpress.org/support/topic/158927 and it started to work. Should this problem be fixed in the distribution?

  3. Navjot Singh
    Member
    Posted 6 years ago #

    That solution does not work for WordPress 2.5

  4. crosser
    Member
    Posted 6 years ago #

    It does for me. Honestly :-)

  5. oeconomist
    Member
    Posted 6 years ago #

    The problems have been or are being chased-down in

    topic 156414

    I'd like to believe that a version 2.1.x or 2.2.x will be forthcoming in the next few days; otherwise I s'pose that we'll be hacking our own copies.

  6. Anonymous
    Unregistered
    Posted 5 years ago #

    Hello,

    I am also facing the same problem with wordpress after upgrade from version 2.5.1 to upgraded to 2.6 I am getting following error

    Notice: Undefined index: edit_page_form in /home/username/public_html/wp-includes/plugin.php on line 583

    Notice: Undefined offset: 10 in /home/username/public_html/wp-includes/plugin.php on line 583

    Notice: Undefined index: admin_menu in /home/username/public_html/wp-includes/plugin.php on line 583

    Give us proper solution for this I am having following configuration for domain hosted server Apache/1.3.41 with php 4.4.8

    Any help will be much appreciate.....

    Thanks

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags