WordPress.org

Ready to get started?Download WordPress

Forums

WP-OpenID (8 posts)

  1. furicle
    Member
    Posted 5 years ago #

    I've installed the WP-OpenID plugin, and it appears on the log in page as well as the 'Your Identity URLs' option in the admin pages.

    If I try and log in using open id, or associate a URL using that option, it goes thru the motions of checking my Open ID, then doesn't log me in or associate it.

    A quick look in apache logs just shows successful GET and PUTs from my OpenID provider (pip.verisignlabs.com)

    What am I missing or how can I get some sort of troubleshooting info to follow up on?

    Comments appreciated.

  2. Will Norris
    Member
    Posted 5 years ago #

    have you tried the latest version of the plugin (3.0)? Do you still have the same problems with that?

  3. furicle
    Member
    Posted 5 years ago #

    Just tried it now (ver 3.1)- getting

    OpenID login failed: return_to does not match return URL. Expected http://www.muskokamug.org/news/wp-login.php, got http://www.muskokamug.org/news/wp-login.php?action=login

    Haven't had time to do anything more than update and try again. Further hints appreciated...

  4. jesterKing
    Member
    Posted 5 years ago #

    I also have a similar problem. When trying to add an openid I get:

    Error: OpenID login failed: return_to does not match return URL. Expected http://www.letworyinteractive.com/b/wp-admin/users.php, got http://www.letworyinteractive.com/b/wp-admin/users.php?action=verify

    I'm trying to add a myopenid hosted openid. I'm using WP 2.6

    For your convenience, I've created an issue here: http://code.google.com/p/diso/issues/detail?id=96

    /Nathan

  5. Will Norris
    Member
    Posted 5 years ago #

    Try replacing the common.php on your site with the one found here:
    http://diso.googlecode.com/svn/wordpress/openid/trunk/common.php

    If that fixes the problem, I'll go ahead and release it as 3.1.2.

  6. jesterKing
    Member
    Posted 5 years ago #

    I get now the following error message

    Error: OpenID login failed: return_to does not match return URL. Expected http://www.letworyinteractive.com/b/wp-admin/users.php?action=verify&janrain_nonce=2008-10-24T22%3A19%3A05ZT11Er3&openid_consumer=1&page=your_openids, got http://www.letworyinteractive.com/b/wp-admin/users.php?action=verify

    Hopefully we can get this pinned down and fixed :) Tell me if there's anything else you want me to do!

  7. Will Norris
    Member
    Posted 5 years ago #

    I've been working with JesterKing and Furicle quite a bit offline this week and we finally figured out what the problem is. Having webdav enabled (more specifically mod_encoding) causes problems because it decodes the query string too early, preventing PHP from parsing it properly. You can read more about the problem at:
    http://www.shauninman.com/archive/2005/05/11/unexpected_get_contents

    The only real solution is to turn off webdav.

  8. jtdennis
    Member
    Posted 5 years ago #

    well now I feel really stupid. I have been having this problem for at least a year with my blogs on Dreamhost. I tested on my new one tonight since I just set it up with the new openid plugin, and sure enough, turning off webdav fixed it.
    *facepalm*

Topic Closed

This topic has been closed to new replies.

About this Topic