WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] WP on Linux VM with LAMPP Can't get past homepage (2 posts)

  1. geredgereedschap
    Member
    Posted 1 year ago #

    Hello all,

    I've been working on copying our site to a local host to be able to test and work on our site without risks. The site is installed on a workstation running windows 7 but on a virtual machine running Linux Ubuntu. The virtual enviroment has shown no errors of any kind so I take it it's working properly. The webserver is XAMP/LAMPP. Ik could find little information specific to Linux/Wordpress. I take it not many people chose this route.

    I can get to the homepage alright although to get there I have to remove index.html otherwise it will display its contents. I cannot brows to any other page though. When I hoover above the menu items the statusbar displays the proper links but I get "page not found" nevertheless. I can logon to WordPress and can navigate there perfectly but as soon as I want to preview my changes after changing a page I get the PNF again.

    I have downloaded the entire site including all subdirectories.
    I've installed LAMPP and tested PHP , Apache and MySQL succesfully.
    I've imported the SQL database using tutorials provided by this site.
    I've edited WP-config to accept the database and set the account settings accordingly.
    I've run queries on the database changing the siteURL, hyperlinks and such. (http://localhost/mysite.nl)
    Since I use the same name for the site as online I set up the hosts file for the VM to link requests to the localhost (127.0.0.1 mysite.nl) to avoid confusion.
    I've searched and found several threads on this forum about problems getting a site on a local machine and worked through all steps but to no avail.

    But it's not working. I can even type the URL to one of the subpages manually but still a PNF. I've looked in the database and the links look just fine. I looks to me like there is some kind of routing problem but I'm just not sure anymore. We're using the octofirst theme which is nolonger supported but since I can't even type the URL's manually to get top the subpages I figured it can't be because of that. Also I don't know how to get rid of it if neccessary. What is also wierd is that I have to remove index.html to avoid gettin it displayed instead of starting up WP. As if some connection between our site and WP is faulty. I've not installed WP seperately but just copied the whole site to the local machine. I have done so to avoid having to figure out how to tie our site back into WP again.

    Any help would be grately appreciated.

    Regards,
    Maarten

    http://www.geredgereedschap.nl

  2. geredgereedschap
    Member
    Posted 1 year ago #

    The issue has been resolved. I've diagnosed a 302 error which led me to .htaccess. Linux considers those to be hidden files... So I never found it. Lesson learned: don't try to do learn something new within an unknown inviroment...

Topic Closed

This topic has been closed to new replies.

About this Topic